Is Pitool changing the mapping or name of the Vive controller?

pitool

#1

I have a beta SteamVR app where all the controls aren’t working for me, but they are for other people. I remember reading somewhere that Pitool internally tells SteamVR that the Vive controllers are something else, so apps looking for specific controllers change their mapping. I also remember reading about a tool you can use to change it back (designed for Windows MR controllers but still usable on Pimax), but I can’t find that thread anymore.


#2

This post mught contain what your looking for.


#3

It’s not that, there was something about one of the newer Pitool versions no longer telling SteamVR it was a Vive (this was when the lighthouses started showing up with the Pi logo), and that mixing up some games that autodetect controllers. The thread mentioned an unofficial tool made for Windows MR that told SteamVR they were Vives, and that it also worked in Pimax.

The problem isn’t one that can be solved by remapping controls, because it’s not like the controls are mapped to weird buttons, they don’t seem to be mapped at all.


#4

I think this is what you are looking for(Pseudo Vive). I have noticed issues with OpenVR Input Emulator when trying to remap the Vive controllers to keyboard inputs, as the only thing that shows up is analog inputs.