Issue Starting Pimax 5k+: Screen does not turn on, LED Red (solid)

issue

#21

I can only find the link to the previous firmware
http://piplay-us.pimaxvr.com/P2.1.255.176.dfu
and
http://piplay-us.pimaxvr.com/P2.1.255.181.dfu

But cant find the 146 or 168


#22

dont use piplay, there are others that had issues with it. only install pitool.

you dont need a good gpu to test. use bootcamp on one of your macs or someones laptop. the headset does show the pimax logo when it gets power so you can test if the screen do work at all.


#23

They need to remove the piplay from the download then. If it is not needed and causes issues it should be removed. Or atleast clearly labeled dont use as a 5k/8k user.

Regardless, as said a few posts back, I had removed Piplay, and tried again from a clean install.

Unfortunately none of the other devices I have have an DP port. I almost at the point I just want to send the device back to get a new one… and would have to buy a separate adapter for it.

the headset does show the pimax logo when it gets power

If the device should have shown the pimax logo on power up if it is just connected, then there is a big ass fault causing my unit’s screen not to turn on at what ever stage.

There are no issues any other devices on any DP on my GPU. Thus by deduction my unit is faulty.


#24

It’s still used on the 4K HMD, right?


#25

They should clearly label it 4k only then or put it under a section of 4k and the newer headset.


#26

I have the same issue.

USB works fine (mic works)

DP says disconnected and solid red power light.

Ive tried all ports for DP and USB even a fresh windows install with no luck.

Running a MSI Z390 mobo and MSI 2080ti


#27

Interesting coincidence regarding the motherboard, I am also using a MSI, but an older Z270i Gaming pro carbon ac mITX board.

Tried a bios update just incase. Didnt work, wouldnt It still does explain why the DP ports wouldnt work since the usb ports were working fine.


#28

Not sure if this would be an issue or not. On the pimax p4k we needed to disable onboard motherboard graphics as it interfered with the headset driver.


#29

Does not seem to be the case in this one, MSI Bios nowdays does that automatically when an dedicated graphics card is added, and there is no option to turn it manually off: Generally speaking the port wouldnt work either.


Any MSI Z270/ Z370 Mobo users?
#30

I made a typo my mobo is in fact a Z370 not a 390 and it is also a Carbon Pro.

Looking in Device Manager it seems that the on board graphics are in fact running alongside the 2080ti


#31

Try disabling onboard in both Bios options & device manager if needed. The onboard might be intetfering with pitool seeing your 2080


#32

MSI Click Bios 5 has no such option available, as said earlier. Its the same bios between recent Z200-300 series. The Integrated Graphics options “exists” in Advanced mode, but no option is outright disabling anything, everything is just prioritisation (Either PEG (PCI-E Graphics), or IGD (integrated) and the ability to enable the IGD via IGD Multi-monitor, to use the port on the motherboard as an extra display port, which is by default off.

That aside, for me the Integrated graphics card is disabled it does not show in my device manager (i7-7700k has Intel HD Graphics 630), and my prioritisation is set to PEG, nor does it show as an active monitorable device in my task manager (thus, not active)

This most likely is something else and not related to integrated graphics: Otherwise more people would have issues as not everyone turns it off from the get go… Chillisix did receive their headset at the same time as I did, so it might be of the same batch with most likely the same defect. @Chillisix, you should probably check the BIOS and probably update, as there was an update recently.

In anycase, been talking with Pimax support, will continue debugging the situation tommorrow with them.


#33

I just turned my on board graphics off in the Bios and it no longer shows in the device manager.

I updated the Bios a few days ago too.

Last night Doman.Chen from Pimax spent 3 hours linked on to my PC but failed to get the HMD working and suggested RMAing it. The thing is it works on my firends older PC so i dont see the point in sending it back.

Hopefully Pimax can figure out what the issue is because i only just bought my MSI board and GPU so really dont want to change it.

I guess the next thing to try is swap my 2080ti with my friends 1070 and if it still fails to work i will know for sure its a USB issue.


#34

Then I would avoid msi.

Peg should move priority to PCI-X. IGD if like Asus/asrock & gigabyte will force integrated run with Both ig & discrete. If I find my msi z270 board will check manual.

Disable IG in your windows Device manager may work to remove it.


#35

Is your friends pc a MSI mobo as well?


#36

Again, its not in Windows Device Manager, thus it not enabled.


#37

Check article above please.


#38

Can’t disable what is not there.

Capture
Thus it is already disabled through BIOS, even if “automatically”.

That article is a generic aggrogate article, and outdated, and does not reflect the MSI Click 5 BIOS settings.

It should be saying After entering the BIOS Setup to goto Advanced, And Integrated Graphics Peripherals, under which you only have two switchable options as I discussed.

And If this really is an issue with MSI Boards, Pimax should probably consider getting it fix it, because it is still a chance someone is using them, and having such issues is just leaving me with a damn bad taste, after all we have onyl gotten a few 1000 in.

Not everyone has the cash to dosh out on Full Motherboards every damn year.


#39

No its an ASRock 20chrs


#40

Msi has been known for nad motherboards. Is there no option showing for shared memory?

I have a z97 gaming mb for example that does not work with i7 4790 cpu. Board is verified fine with other cpus no bios update fixes it.

I only bought the msi z270 itx carbon mobo due to it being really cheap even with some of it’s flaws compared to competitor’s offerings.

With @Chillisix saying his buddy’s rig is Asrock & his headset working suggests might be an issue with msi mobo.

Are you able to test on a friend’s non msi mobo?

This is why with Mobos I have generally stuck with the three Asus, Asrock & Gigabyte.

If the issue is msi mobo pimax may not be able to fix it as it would be MSI. If it is usb then an addon usb 3.x card might fix it.