Large fov basically broken with parallel projection on from excessive blur. (rendering bug)

pitool

#1

I have discovered a bug that when using parallel projection if you had set the large fov for games like elite dangerous and skyrim they look very blurry. You can only use normal fov and they look clear again.

I have noticed that in skyrim if I turn parallel projection off I can use large fov again and the image is clear, but that means the loading menus have double vision if you tilt you head (and the game’s bethesa splash screen)

Just want to leave this report for the Pimax software developers.

If anyone wants to test this turn parallel projection on a reboot pitool. Then Set normal FOV and reboot steam VR and check the game, then change to large fov and reboot steamvr and check the game.


#2

Just tested new pitool with brightness settings. Unfortunately this bug is still there. Slight blur when using parallel projection and large fov. Normal fov is clear with it on.

parallel projection off all fov’s settings clear


#3

I found more distortion or blur layer at the edge although normal fov in version 95.

Easily can see in fallout 4 vr, the blue edge alway jitter when turning head too.

Yes problem found easier on parallel projection option, I tick out, but there is some wrong about shadow in one eye only.

ps. some review talking about bug when move from normal to large without restart PiTool.


#4

I’ve noticed the same thing with my 8k. With activated pp, the supersampling settings are not taken over with large FOV. With any other FOV it becomes ingame sharp as soon as I set up SS.

Restarted computer every time after changing FOV.


#5

others said it is depending on parallel projection not fov if steamVR SS is working or not.

I only use normal fov. every title I played so far with parallel projection on did not benefit from steamVR SS but still had impacted fps.

assetto corsa without parallel projection does benefit a lot of steamVR SS, hence my impression it is PP and not FOV related if supersampling works or not.

large FOV always looks less clear than normal FOV for me.


#6

To make it completely clear :slight_smile:

small/medium/large FOV + parallel projection unchecked = steamVR applied in all FOV´s.
small/medium/large FOV + parallel projection checked = steamVR applied only in small/medium FOV but not in large FOV.

I tried steam home with large fov + parallel projection unchecked and it is supersharp with pitool render @ 1.5/steamVR-SS @ 100%.

Is the bug known at pimax @Dallas.Hao , @Sean.Huang ? :slight_smile:


Why on my Pimax 8K can I see the "pixels" on the screen and readability is near lower than on my Vive PRO?