Latest Pitool Beta, Index controllers decided to stop working, instead acts like "hand on a stick"

issue

#1

So ok, after solving the other issue with the mic, I started steamVR up again and for some reason, the index controllers were not being recognized as such. I had no control over finger tracking in Steam VR home, I couldn’t even select a game to play without holding the button to bring up the steam dashboard first where before I could easily point to a game to play from steam VR home and play it there. The controllers were tracked but none of the buttons and controller functions worked as it should have unless I was looking at the steam VR dashboard. From in a game it was just treated like generic vive controller.

The only change I can think of that I made in this time was trying to set up several games with individual settings under the new beta pitool. Funnily enough, it was working great at first and then I shut it down, and several hours later opened it back up only to see the “hand on a stick” that wasn’t recognized as an index controller by the games that require it (right now only the aperture hand labs and moondust demos).

I tried rebooting and restarting the headset and the service and steamVR multiple times to no avail and then it started making it like the controllers were not paired at all. If I tried to pair the two controllers at once it would only pair one of them and then falsely report the other had been paired when it had not.

I uninstalled and reinstalled the software hoping to clear out whatever bad mojo had built up and even went through the whole room setup process again and tried to pair the controllers again and again. Each time either I got “hand on a stick” or I got nothing and/or only one controller would stay paired.

Again, from the first install it worked great, and the only change I made other than shutting it down and starting it back up again later was to try to assign the most basic configurations to a few games (none of which I started up and none of which were even attempted to start up through Pitool)

I’m attempting to roll back to the previous pitool to see if that solves the issue but so far the last time I can remember it working well (but maybe not flawlessly) was when I was using the workaround method to use the controllers via the drivers from May.

Computer is Windows 10 Pro 64Bit, 1080Ti, Intel i7 4770K, 32GB of RAM, and I WAS on the newly released beta pitool with the separate sections for controllers, base stations and trackers on the main screen.


#2

Ok, so an update: I have since reinstalled the last beta and gotten the hand tracking to work and see that steam recognizes that i’ve got index controllers instead of just a “C” in a hexagon shape. But it seems like works when it wants to and I have no idea why. I mean, I can come back after a reboot some hours later and it may or may not be working. I got it working now, but I don’t know how well it’ll be working later…


#3

hmm… not encouraging considering I just ordered index controllers. Oh well I guess I still have my OG Vive.


#4

I was able to get it working again by uninstalling and reinstalling it, but it seems like every once in a while, the hands are misplaced and don’t react to any of the finger tracking.

When that happens I have to turn the controllers off, wait a minute and turn them back on. I’m hoping when I get an Index that I can just skip all the fiddling with Pitool. I guess Pitool is great for those people invested in the Oculus store but I don’t care about it at all.


#5

It sounds like a quite rare case, and Im happy to hear you found a way to get it solved. I must add though, that PiTool is very useful, and includes many options you wouldnt be able to adjust or enable/disable without it. The SteamVR settings alone are in my opinion way to simplified and limited.