Led flash red and green only


Try leaving it disconnected for 30m.

Might help also there is a link in piplay beta discussion of someone disassembling pimax.

I do remember seeing support mention in something similar to press & hold all 3 buttons for something like 15 to 30 seconds.


I remember several YouTube videos about changing lenses in Pimax and showing disassembly.
Nowhere is there any mention of a firmware lockout and I would be very surprised if this actually existed.

In fact Pimax sent me a copy of one disassembly video so that I could change the lenses in my Pimax and again no mention of any lockout.

I would assume it doesn’t exist and go from there.


Did you ever get this fixed? If so could you explain how?


No, unfortunately Pimax support were not willing to help me. It sucks, won’t buy another with the software issues either.


I also have the same issue - i disassembled my pimax to remove the blue light filter, and now its dead - blinking red&green led.
Well actually $300 is quite a lot to throw away like that :frowning:

Did anyone get a chance to try the 8k in SF?

Hey sorry to hear.

@sjefdeklerk i believe has a solution that may reset your firmware.

Flashing Red/Green LED
Removing the shutter glass

As lots of people have my hacked FW already I figured I post it here. If pimax wants my post to be edited, please go ahead. But I figured this is better for everybody and takes a lot of your work out of your hands having to deal with this problem

Anyway you need to download and flash my hacked firmware: https://mega.nz/#!eZJCWTZY!xoKIxfa73GQeN_15BfBCMwigPEiIRJwx6gEkg3EsBD0
To flash a FW manually you can find instructions and the flash tool here:


Remember to kill your piservicestarter.exe, piservice.exe and piserver.exe before running the flasher tool !! Otherwise it won’t work.

Your headset will work again as normal. You can now flash any other firmware file you like or you can stay on this one, it doesn’t matter. This method has been tested, works and it’s perfectly save. However this is NOT an official Pimax method so do this on your own risk.
Enjoy !

What is wrong with my headset! Please help; Iam very frustrated!
[Resolved]Pimax "working" only fw
[Resolved]Pimax "working" only fw

Thank you @sjefdeklerk very much for your help!!!
Now the pimax works again.

You made my day :slight_smile:


Can you tell me what file do i need and how to do a firmware update
Please help…Thanks!

  • Download the the hacked firmware by @sjefdeklerk , put it on the desktop

  • Download @sjefdeklerk version of the flashertool. https://mega.nz/#!2FJzmbgb!63TSx5pHftCAXNliTOjcj0lQb9jhba1cjRmXTe3g0L4 and decompress it on the desktop too, this is important to be done on the desktop or it does not work.

  • Then you have to close the Piplay and the processes associated with Pimax: (Piservice.exe, Piserverlauncher.exe, Pi_server.exe)

  • With the Pimax 4k connected by usb, you start the flashertool on the desktop and run it in “administrator mode” (right click, run as administrator) then press “Enter dfu mode” at that time you should see that the light changes to a kind of fixed yellow/blue light, that confirms that you are in dfu mode.

  • Press “FW flash” and the file browser opens, there you search for the firmware version you downloaded first in the desktop. (I’m not sure if it opens directly since I’m not on my pc now, in any case make sure both the firmware and the flashertool are both together on the desktop)

  • Once the flashing process ends you press “Return from flash”, if everything is correct, you should not see the flashing red / green lights anymore.

  • When you’re done, run again Piplay it will update to the latest version of the firmware, since the hacked version is 248.

Red & Green LED always flash since new firmware update

The light on handset is flashing kind of blue on one hand and red on the other hand (seem like white mixes together)
When i try to start the flasher tool it give me a message that application can be start,
Should i suppouse to see the application open even if there is something wrong with the hanset ?


yes, it is assumed that the application opens even if you do not connect the headset. this seems very strange … your device is very likely to be fine although you must have the firmware broken, what has happened to you now is that it has entered into “dfu mode” if the application worked well it could have flashed as soon as the application was open. Have you never been able to execute it without error?

I think the support team should see it through teamviewer, you should get in touch with them at support@pimaxvr.com send a message on Skype

@Pimax-Support @matthew.xu @Doman


Headset went down when i tried to adjust it with the latest PiPlay update.
Never been able to open eigther update tools or piMax flasher (giving me an error when trying to open apps)
Already tried many times to communicate PiMax via email or Skype but never answer,…Service is very bad!
Thanks to nice people on the forum always willing to help me!


Support should be on soon within a 2 to 3 hrs. Keep in mind timezone difference can make it hard to find a good time that works for both of you.


Will try again tonight…Thanks you and happy new year!


Do you think the apps suppose to work on Windows 7 pro x64 (french version) ?


It should as far as I know but don’t have the option to test a Win7 setup.

What cpu/ram & gpu are you using?


Intel i7 4790k 4ghz 16gig ram nVidia GTX-960


Did you test this upgrade tool recently ? If, so,…on what system OS


Hi, we are willing to help you, you may install and run Teamviewer 13 and then send ID & Password of Teamviewer 13 to the mailbox: support@pimaxvr.com ,we will connect your PC, thanks.