Lots of problems with PiTool 0.90 detecting hmd, controllers, stemvr, etc compared to 0.84


#1

So I actually don’t know what improvements did we get with 0.90, but I’m having a lot of problems detecting all these devices, while in 0.84 there were barely none.

Basically now it’s a lottery, when you boot up PiTool and the Pimax you can get any of the following prizes: one or both lighthouses not properly detected, one or both of the controllers not detected, the Pimax not tracked, Pimax boots and finds everything but steamvr seems to not work properly and not getting into steamvr home, and any mix of all those.

Most of the time you can get it to work by turning the Pimax off and on again and/or rebooting the computer several times. I know it’s early days and I’m happy I can test the 8k even with some issues, but i’m surprised it’s a lot worse than 0.84, and now I know for sure that if I get a stable PiTool version, i’m not upgrading until a huge improvemente comes along, and I fear downgrading to 0.84 just in case it breaks anything.


#2

Might need to compare setups. I don’t have lighthouses & controllers. I haven’t had the lottery connection issues.

Will need to compare with others with full setups like yourself.

@SweViver @mixedrealityTV @VoodooDE @Ludx @spamenigma @Fresco. 8 think all of these folks have full setups.


#3

i’ve just found that there’s a pretty big thread in reddit with lots of people having similar issues so it’s not just me, check: https://www.reddit.com/r/Pimax/comments/9u78ds/pimax_5k_and_vive_basestations_not_detected/ , i’ll check some the stuff mentioned there.


#4

Skyrimer I’ve been having pretty good luck with using .84 and thank you for this write.
Not updating to .90 until better reports.
Just to share with others something I found this morning if you are having trouble after launching PiTool with disconnect quick check in settings revealed that even with PiTool running the PiServiceLauncher was not running and it was set to automatic. Once I started it running obviously Pitool recognized headset and it turned on.


#5

Today I was about to make a video about all this but with my bad performance of new gpu I tried some cleaning program that is leading me to full Windows reinstall :sob:


#6

Not sure if I’ve noticed any difference here (5k+), although on holiday now so no testing for a couple of weeks.

What I have noticed is if I cause occlusion in some sensors such as one hand on one side lifting HMD covering some, I can lose tracking when I feel there should be sufficient sensors remaining to see lighthouses. In most cases it recovers grey screen back to image, but have had occasions where it seems to get stuck on grey. Needing messing or even reboot to clear.

Also had it where after it recovers it’s a bit glitchy, moving the image about, jumping position slightly.

So am sure of some tracking bugs existing.


#7

I’m using 90 with no problems but no controllers/lighthouses

We need the 3 amigos. & @yanfeng


#8

@Skyrimer Homestly, I have major issues with my Vive Pro and SteamVR. Either it’s audio or compositor or the lighthouses going into standby while I’m playing, I have to restart my computer at least one time every time I play. The only platform that has the least amount of problems that I’ve owned (not owned rift) is the Oculus GO. Everything else has had problems. Microsoft mixed reality has less software issues in my experience but then the tracking doesn’t work or it’s not quite as good of experience. I don’t think it’s just Pimax.


#9

I’m guessing you’re using SteamVR beta and the lighthouse issue just started happening for you a few days ago? If so, it’s a known issue in the latest SteamVR beta.


#10

I justed started beta recently but I’d always have the LH turn off here and there. Thank you for letting me know!


#11

Yeah it’s super annoying, currently I just disable bluetooth in the SteamVR settings panel while I’m playing; otherwise my lighthouses will surely turn off while playing.

Valve dev says they are aware of the issue and working on a fix :+1:


#12

Hey guys

About settings, since I am back on my PC, but dont know yet how is running this gpu.

Sean told me in a mail that better was to set pitool to 1.0 and use steam to change SS.
But this is exactly the opposite of how I like the image. To me this way it looks jaggy, jagged or whatever.
But instead I was (until I changed GPU and dive into a sea of shit) using pitool 1.5 or 1.75 with Global Steam SS, about 20 or auto.
Image was much soft and clear so sharper cause no blinking.
With maximum Antialasing set ingame.

Thats about it for some wierd settings, if one of you want give it a try.
I got back to my reinstall and stuff…test :scream:


#13

Keep in mind some games have their own SS in game.


#14

Current update for steam vr is a shitshow for me. Lighthouses stop tracking. Display went batshit once.


#15

Yes that was me that posted the issue.

PC Specs: 8700k @ 4.8, 32gb 3200mhz, RTX 2080 Ti, running off an M.2 SSD on the Pimax 5k+

I saw the issue where my base stations were not coming up for some reason. I had to restart to get them working. But then I recently noticed another issue.

For some reason my sound would completely go off in iRacing off my SteelSeries Pro Wirteless goes off completely. I’ve had to turn off iRacing and turn it back on to get the audio working again. It’s happened twice and I’m not sure if it’s something to do with PiTool.

Also, whenever I boot into Windows, I see a USB Malfunction yellow window that pops up. It has to do with the USB Port on the pimax. I dont know what that is and why it’s happening. Does anyone else have a similar issue?

And one last thing… Sometimes I turn on the headset and the screen is completely warped. There’s some strange Bar across the screen horizontally, and the colors are off and everything out of whack. I have to reboot or turn off/on to get it working right again.

Oh and I’m not on SteamVR Beta currently. I’m using the regular SteamVR version


#16

LOL, sorry to sound sour, but better get used to the way Pimax does updates: fix 1 thing, break 3 things. There’s a lot of that to come, mark my words.


#17

They already built the headset, if they want The brand to grow maybe they need to admit programming is not their forte and hire outside The company, It seems like they are holding themselves back.


#18

Oh boy - that’s not good to hear.
They got a product that works - they really need to fix the software side of things.


#19

It’s for sure .90 is buggy as hell. Like others, my 5K+ is s crap shoot with pitools using the lighthouses. Most of the time several attempts to reboot or whatever it takes to get the headset recognized in pitools or tracking with the lighthouses. Since my 5K just arrived over the weekend I’ve only tried .90 and not 84 or 76. I really want to try and downgrade to .76 as I have read and saw Swevivers video and post about .84 screwing up SS and resolutions. I have a very elaborate setup with a 9900K 2080TI pushing a full 6DOF motion platform and I’m also an electrical engineer so I’d like to think I know what I’m doing. Conclusions are .90 version is loaded with problems. I’m going to try and find a link for v.76 but I’m a little worried about firmware compatibility because as soon as I connected my HMD for the first time it auto upgraded whatever firmware shipped with the device. I know how to use the flash utiiity so I think I’m going to try this until a future update comes out hopefully fixing these issues. But let me be the one to confirm, if you’re using the lighthouses, expect problems with the latest pitools. Also confirming the horizontal line produced in the HMD at startup on occasion. The only solution is to reboot the HMD and cross my fingers that pitools recognizes the HMD without a reboot or service reboot etc etc.


#20

I havn’t encountered obvious problems with PiTool 0.90. With 0.84 I can’t save the FOV mode, but this is solved with the later version.

I have also encountered some of the unstableness reported by other users. I noticed that there are some delay for the Lighthouses to track the headset, so I usually hold the headset in a place easily to be seen by the Lighthouses, and move it back and forth gently, and it will be tracked.