Lots of problems with PiTool 0.90 detecting hmd, controllers, stemvr, etc compared to 0.84


#21

Do you have any other USB devices plugged into you’re pc that are not required? Can you please tell me your hardware specs on your pc and what Psu you are using… Also what other non external devices are connected consuming power… Don’t leave anything out! Also check if you need to install windows update October release?

Eno


#22

Actually I had Isolated the entire system to just one lighthouse and the HMD with Nothing else.attaxhed. To contribute more I also have a StarTech 4 port USB card that has 4 independent controllers and also tried a Fresco logic 2, 4, and 5 port card plus USB 2.0 to no avail. Trust me it’s the software.


#23

Update------------That reply was directed for @MikeJeffries… sorry just realised that @flash66 may have thought this reply was for him.

its not that i dont believe you … honest! but what you were describing was a power shortfall… so i was going to check if your PSU was giving enough juice to all your internal and external devices. But if your sure, then we will leave it for the pimax software devs to resolve.


#24

This is why though we need to have @yanfeng @mixedrealityTV @VoodooDE & @SweViver

To weighin & see if they have exoerienced these issues as well. I can’t weigh in as not using LHes & Wands. No real connection issues.


#25

I have experienced all of the issues that @flash66 has experienced.

The initial setup of lighthouses was a pain.
Lots of restarts and re-boots to get the lighthouses initialised and tracked.

Now that the lighthouses have paired it just takes about a minute when I start up PiTool for them to be tracked.

If they don’t track after this time, I found that turning the controllers on made the lighthouses track.

Also had the USB error show up sometimes. I just unplug the headset from the PC and then re-plug which generally fixes it.

@flash66 I highly doubt you will be able to go back to .76 as every time I try the headset will not connect.
I have even tried .72 still will not connect.

I still have the issue where my headset is not tracking.
The controllers and lighthouses are tracking but not the headset.

I have tried just about everything to get it to track but as of yet have been unable to.

Have spoken to Sean and was supposed to have a Teamviewer session for yesterday (Monday) but didn’t get a reply?

My headset is gathering dust as its unplayable for me even without base stations as the internal/gyro tracking keeps drifting too often and I have to constantly re-centre the headset.

I am a pretty patient dude but its wearing a little thin!

Cheers
Neil.


#26

That is most unfortunate. I hope that your issues can be resolved soon.

The drift worries me a lot. I won’t have a base station until Pimax sends me one.

Is there any way to recalibrate the gyro? If not, they need to fix it. @PM_Sean


#27

I just want to note this is a complete non-issue for me personally, because 0.90 doesn’t run at all. I’ve had tracking loss several times that is software, however; restarting the Pi service was necessary to get lighthouse tracking on the headset back.


#28

Which headset did you receive & did you have a review thread? Reorganising things to make easier to find.


#29

I think so far I am the only one with this issue.

@Heliosurge runs without base stations and to my knowledge hasn’t posted any issues with the gyro tracking.


#30

Hmmm… Maybe try some sit down games without LH & motion wands.

Haven"t noticed any drifting or even tried Horizontal Calibration


#31

Eno, No worry’s at all and thanks for clarifying! Unholy, have you also tried to downgrade the firmware to match what will run with .72 or .76? If the firmware is a revision that worked with either I would think the HMD should work. I just haven’t been able to try it yet. I’m afraid fellas that this is really starting to remind me of the days of the DK2. It’s obvious to me after hours of getting this thing to work mostly half ass, that logic is telling me Pimax is nothing but development kit at this stage and should be expected. Pimax has 2 months to sort out their software to get a stable release or for the preorder era it won’t be anywhere close to a consumer version by 2019. They’ve got a Shi* Ton of work on their hands.


#32

I have not been able to find an earlier version of the firmware to try.


#33

I write software for a living. The problem isn’t necessarily the time “to sort out their software”; it’s probably more of a testing issue, due to lack of end-users running the software.

PCs are unique beasts with wildly differing setups. Certain issues will not be found by in-house testing, no matter how much time is spent.

We will all be “alpha” and “beta” testers. That’s part of why there’s a Kickstarter backers discount (compared to the final price). We will be the testers who help the software to become stable.


#34

I totally agree 100% with you but the only point I was trying to make in that comment was it’s still inevitable that they have to implement all of the feedback into a consumer stable version soon for the preorder shipments. I’m an EE and also write code so I can relate to what you’re saying in part.


#35

I could swear there are some links posted somewhere on this forum for .72 & .76?.


#36

Yes, they do. I’m hoping that their experience with the 4K will help them with the 5/8K drivers, but of course, the 4K doesn’t have base stations, so that’s going to be all-new code.


#37

Here are the links for previous versions…

http://pisetup.pimaxvr.com/PiToolSetup_1.0.1.84.exe

http://piplay-us.pimaxvr.com/PiToolSetup_1.0.1.76.exe

http://piplay-us.pimaxvr.com/PiToolSetup_1.0.1.72.exe


#38

I cant tell you how many, but I have alot. I have an entire sim racing rig set up
Wheel
Pedals
Fans
Shifter
Handbrake
Steelseries pro wireless headset
Keyboard
Mouse

I have an Inateck 5-port connected
Also a 1000W PSU

So far I haven’t had much issues except it does take 1-2 minutes for the headset to be detected.


#39

Ever since I had (somehow) solved the mysterious green flashing power LED I have to say both PiTool .90 as well as SteamVR have been pretty damn stable. The only issue I tend to have is the 5K+ displaying what has already been described:

Turning the HMD off with the power button and then restarting it has so far fixed the issue every time.


#40

Have you tried turning it off and on again? :laughing: