Make 120hz show up after it didn't at first?

I was looking forward to 120hz on the 5k+. It didn’t show up in my pitool. I’m wondering if anyone who didn’t have immediate success has since got 120hz to work since it came out.

2 Likes

Can you change the color of the front light on your headset? For me the Pitool UI didn’t show any of the new settings at first until I restarted Pitool and the headset. However once I saw the settings for the front light color I also saw the 120hz.

You can also look at this thread and check the manufacturing date of your headset to see if your headset seems to have been manufactured around the same time as others that don’t have 120hz. Here

4 Likes

Yes. Same here. Had to restart the service for it to work (I rebooted, but it should be sufficient to restart PiServiceLauncher service and headset).

2 Likes

Same issue here, I can change the HMD colour. I tried updating the firmware manually, updating windows, updating my rtx 2080, clearing pimax installation including the files in app data and many reboots.

No dice.

Edit: my hmd was made in 2018

7 Likes

It has to be because the firmware only enables 120Hz for specific revisions of the 5K+ headsets.

@Doman.Chen can You tell us if that’s correct? And if yes, if 120 Hz mode is supposed to be coming to all 5K+ revisions?

5 Likes

I have an 8 47 - I’m able to get green. I do have some thing which people might consider black dots on the screen; I’m not totally sure.

1 Like

Could you check the black dots thread here (5k+ Black Dot Pattern Thread. Post here with pics) and confirm whether you have them?

1 Like

Mine was produced 8 47 (backer 545) too, it definitely has the black dots and the first rev (flimsy) housing and no option for 120Hz. I can change the color Pitool V1.0.1.197 and firmware V2.1.255.244

I have tried rebooting computer, restarting and unplugging headset, reinstalling with Antivirus disabled, changing FOV S>N>L and back again, Changing backlight low, disabling each and every setting and reenabling them. My headset definitely does not have the option of 120Hz…

I could live with the flimsy housing and the black dots, but if they give 120HZ to everyone else and punished for being one of the first backers, that will be unforgivable…

6 Likes

Backer 206 here with working 120hz mode

2 Likes

@industria Can you look at you serial number on you headset to find the manufacture date as described Here? Thanks.

2 Likes

Could you also confirm if you have visible black dots?

2 Likes

my 5k+ has 120hz available, serial says 2019 week 4

2 Likes

@manzilla Sn 20360090714855
@risa2000 I can find them on solid colors for testing purpose, but never notice during the normal use

5 Likes

Thanks. Your manufacturer date is 2019 07th week. (Week of Febuary 11th)

203600 9 07…

So yours is newer than the ones reporting no 120hz.

2 Likes

Sn 20260084900174 here, no 120hz mode :frowning:

1 Like

You’re 2018 49th week.

We don’t need the full S/N

Just the 7th, 8th, and 9th digit.

1 Like

It would be nice to try 120hz - it’s not what I backed, but would have been a welcome feature. I’d say this is pretty much (sadly) solved. Thanks for the help everybody!

2 Likes

I can also confirm, mine is 2018 49th week, and no Joy :frowning:
Really hope there will be a easy fix for it thou.

1 Like

5k+ here made in 52nd week of 2018. I can get 120hz on mine. I don’t use it because it’s way too dark, and I can’t get anywhere near 120fps in any of the games I play so I don’t see any difference between 120 hz and 90hz.

2 Likes

Yeah, it’s probably a bad idea to post the whole S/N.

As @risa2000 mentions below, just leave out the last 5 digits:

1 Like