My Review of Pimax and Nolo controlers. ( junk status )


#1

My story.
I recieved my pimax 4k and nolo controllers a few days ago but I very fast realized there where major issues with the hardware and especially software for both products.

The first issue was that the pimax headset could not be seen in piplay. So after trying many solutions and stuff i desided to format my computer and install pimax and nolo on a fresh formatted windows 10 system without antivirus or anything els installed that could block drivers… did it now work = no same problem.
I even tried installing the drivers in windows safe mode… = not any better.
I later found out that if i startup the computer with the pimax 4k headset then it would turn red when i reach the login screen of windows… And if i hurry and imidiatly manualy starting piplay then i could actual see the 4k headset and use piplay.
But if i just let windows startup normaly and wait for piplay to startup on its own then it will not work, and also if i start it manual example 1 minute after startup then it also do not work… wow… so clearly something is wrong with the driver in the headset or in the piplay software. Fun thing is when reading forum posts i realized that this is not a new bug, but have been arround since 2016-2017 and now 2018.

Well now i installed steam, and ocolus software and revive ( i also tried only with steam and piplay ) and I could see the 4k headset, the 2 x nolo controllers… But no matter what i did in steam home i could never really calibrate things so i could use it… I was always under or above the floor, and a few times i made it work by cheating and writing my floor height to high…
Well finaly after many houres of actual reaching the point where i could use my new 4k headset and i power up DCS world flight sim… then i find out that the VR is so got dam dark that I cant even see the ocean move… and worst part is I cant even adjust the brightness of the screen to even compensate for this. Well anyway i started flying.
Now i notised the next issue… The screen look pretty good directly in front of me, BUT the edges are blurry so to see any instrument i have to focus directly on it, and that is not really that cool to “look though a toilet pipe” since you really need to loot at more at one ting at the same time.
Well anyway I fly arround a little bit and I compared to my ocolus rift i sold to buy the 4k and nolo then i must say the game world is more beautifull and i could see further away with more details ect…
But everything related to software is a piece of junk that dosent work, and it ruin everything… also the darkness in the vr headset and lack of “overview” when flying is so bad that I actual prefer to fly without VR headset.
And then there is the fact that often steam vr cant find the vr helmet and you cannot turn steam vr off once it is started and then turn it on again, since then the headset is not visible anymore.
I even tried to update the firmware both forward and back a few times to see if this fixed any things… but no.
Actual the latest firmware update 256 i think its named actual made both of my vive base stations dissaper in steam… sometimes i can see one of them sometimes both are gone… ( but ) they are still tracking and i can use the headset…
Even a format of the computer did not make them come back. ( they are fysical okay, all led and laser light are okay, and can track the helmet in A-B-C mode alone or in pair ).

When it come to the nolo… well what a piece of shit.
I have NEVER been able to function for just 1 second…
Even when i hold the headset and focus direct on the nolo base station then it possition the headset totaly wrong, and the controllers are up in the air or behind me and stuff like that… I ofcourse tried to sync, reset and even turn off my screen and darken the room but no success… I tried placing the base station at the other end of the room, no success and the vr gear is even registred as 90 degree to the left of the direction im looking and the controllers 180 degrees in the other direction… Not even the nolo repair toold and firmware update made it work, and the controllers are flying arround in all directions.
When i recived my device it did not look like new and had a scratch on the glass by the way…
You might think that this is just a broken nolo, but truth is Pimax actual send me 1 ekstra nolo vr controller by mystake… So i actual 1 hour ago open the box and tried the other controllers just to check if it was broken.
Well to my surprise it worked for 10 seconds, and after that it act just like the other one… cant focus and work like the wind blows.
Status is I am able to Tweak the vr gear to working and use it in example flight simulator or watch a movie, but there are so many software issues that I will say no thank you… it dosent work good enough.

So all in all what did this cost me to try Pimax and nolo.

  • I sold my ocolus rift for 320usd.
  • I bought two used base stations ( i updated the firmware ect and they are working 100% ) I think i paied 220 usd
  • I bought a link box 60 usd. ( i also tried using vr gear without the link box to test if it worked ).
  • I bought new high quality hdmi and usb cables.
  • I bought the 4k headset 387usd ( with a discount ) including nolo cv1 controllers.
    Oh i almost forgot i also about 1 hour before i bought on pimax shop, buy the nolo controllers on amazone, still waiting for a refund and seller are ignoring me for +14 days ;-( so something like -200usd there.
    Oh i almost forgot, i also paid import tax -80usd

And all in all, here i am sitting with a badly working piece of hardware that have tons of software issues.
Nothing is working right…

Butt he best things is… It will cost me more than +100usd to send the equipment back to pimax if they even will give me a refund. !

I will now uninstall and remove all pimax and nolo gear, and put it back in the boxes and ask for a refund.

If the upcomming 8k and its software work the same way, then im not interested at all, the last few days have been an absolute nightmare.

PS… nolo sucks to use and seem veyr fragile, I really wish the ocolus touch controlers worked with pimax they where truly amazing.!

All in all, if you are to buy VR gear at the moment i only can recommend ocolus rift + touch for about 300-350usd fantastic product.


#2

Nolo does indeed more or less not that good.

@cmm & @sjefdeklerk have experience with Nolo & maybe able to help you get a ok to decent experience. Nolo supporr was added by request of the community prior to Nolo release & more or less letdown.

The headset on the otherhand can be confusing as some like myself have had very few problems with installation & updating. To date the inly big install issue i had was caused by an AmD ati driver that was broken with Pimax headset (blankscreen)

With the height in Steamvr unless your using Nolo or a headtracker (vive trackinf puck, psmove etc) you have to manually set height as there is nothing outside tracking the headset in your “room”.

With you having a clean install of windows in rheory you should have no issues leaving the headset connected or not (i reccommend though kerping it unplugged til you intend to use it). I also don’t have piplay autoload at stsrtup.

@Pimax-Support would likely be interested in setting up a time for teamview session.

But in the meantime please post the following details.

Windows ver (you said 10)
Cpu/ram
Gpu/driver version
Piplay version
Headset firmware (you typed 256 but shpuld be 265 prob a typo)

The gpu driver might be an issue. With your cpu if intel or your mb has an Integrated graphics; you want to disable it in the bios & potenially in windows as well.

As for return policy that will depend on the E Vendor you ordered the headset from. Ie I don’t reccommend Gearbest as their policy is buyer pays for shipping both ways.

But support maybe able to assist somewhat.

Now your eyesight is it 20/20? Ipd can be tricky to get set right.


#3

Reading nolo oficcial forum make me think, that problem is in last firmware upgrade. I use nolo in condition it came (August 2017 with no updates) & it works well.
P. S. Never installed nolo software, only Piplay.


#4

That’s interesting, I was reading that elsehwere also. What version? Can we downgrade?


#5

Hmm i believe he means the Nolo firmware. Try googling Nolo firmware downgrade.