New Pimax 4k + nolo, no display or tracking

fix-guide

#21

I ran into the same Nolo problems, but this is the case when the latest firmware version became available.

maybe because of this? did not check what is happening there with steamvr, vive controllers blink?


#22

the grey screen is normal if the Nolo “Lighthouse” will be not recognised by the Nolo Headset tracker (normal condition is the Pimax Logo if SteamVR is closed).

I had similar issues while the lighthouse was connected via USB to my PC, do you tried it without a cable (battery only)? Is use the 2.0 FW and can use it properly together with Piplay v3.0.0.85

What is the condition of the LED on the headset tracker?

Best,
Dennis


#23

Hi Dennis, thanks for the reply. I’ve tried the lighthouse both connected and unconnected, with no apparent difference. Most usually it is unconnected.

The headset LED is blue. I can actually use the headset in VR as long as the Nolo is unconnected, so I think the headset itself is fine.


#24

Hi,

is the LED of the Nolo Headset Tracker red or green?





#25

The LED is green. I’ve paired the components a few times since I got it.


#26

is the led switching to red, if you turn off the lighthouse station?

for me it looks like the NoloVR Setup is functional but the interaction between Headset and Nolo is not working.

You can try again to remove first everthing Nolo and Pimax related, then install Piplay v3.0.0.85 and check the recognition of the tracking device in Piplay (chain symbol)


#27

So I did that, uninstalled everything, rebooted, made sure there were no Pimax services, and installed v3.0.0.85. I get a situation identical with the older Pitool driver, the headset works fine when Nolo is NOT plugged in, when it is plugged in there’s no headset and no tracking.

@Sean.Huang
Hi Sean, are you able to give this member some help with the nolo side of the driver, the hmd is tracking but are unable to get the nolo part working.
Thanks Eno


#28

Ok while the Nolo in plugged in what is the tracking status in Piplay?

Maybe the Nolo FW is too new for the combo. I currently use 2.0 and got Pimax4K and Nolo in one package.
You could check the fw with e.g. the older Nolo Driver for Windows tool?


#29

I’m not at home right now, but as I remember it the Piplay displays 2 controllers and one device as connected, the 4th one is not connected. I don’t recall specifically any headtracking status in Piplay, but SteamVR definitely reports not tracked.

This is my feeling too.

Thanks for the link. Do I need to do anything other than install that driver? i.e. do I need to uninstall or change anything first? Otherwise I assume it’s overwriting newer Pimax drivers?


#30

The download contains Nolo_driver_for_windows.exe which is a Windows tray tool. It shows you the connection status as well (need about 10s after booting) and e.g. starts the fw update tool. With the visualiser option you can test the Nolo tracking independly from Steam or Pimax Tools.

I have Piplay and the Nolo tool both installed at the same time and I have no issues. I can even run Piplay and Nolo driver for windows at the same time and both show active tracking.


#31

Thanks for the image. I get green lights all the way, apparently all is connected. But, still no tracking. The visualiser tool displays something that looks like tracking, but I think is only showing internal gyro positions. I think this because I can move the controllers & headtracker around and they only rotate, and even when under my desk (out of sight of the base station).

I don’t get any lights on the front of my base station.


#32

Hi,

do you tried the fw tool to check you current fw of the base station and the headset tracker?

Regarding the lights of the Nolo Basestation, you don’t get the red leds on the front? Did they appear in the past? What is the status of the led on top (powerswitch) and do you hear the tracking noises which were send by the base station?


#33

No lights on the front. I never saw any, and I didn’t know there was supposed to be lights, so I didn’t pick up on that large clue :slight_smile:
The power light comes on, I can feel something spinning inside, but there is no lights and no noise (other than the slight buzz from the spinning). And all the devices light solid green.

But in any case, the techs over at Nolo support recommended I replace the Nolo system from where I bought it, as it’s faulty. So that’s what I did this morning, after work I will try it out & report the result here.


#34

Yep it looks like a HW issue of the base station. Normally there should be 2 red dots visible. If you check it with a camera you see thats actually IR LEDs.

Hope you will get a fast replacement and your issues get resolved with it.


#35

Thanks Dennis. Yes it was a hardware issue, I got a replacement and it works fine. I’m pretty happy with it :slight_smile:

I have one issue where the controllers go to sleep even while I’m using them, requiring me to constantly keep switching them back on. Other than that, it’s good.

Thanks to all the participants here, I appreciate it.

Kindest regards

David Markwick


#36

So glad it’s going for you

@Dennis good work there… I was OK getting the pimax working but don’t have nolo to set that up… Well done!


#37

Hi David,

glad the replacement is working well. :+1:

I faced your reported controller issue myself and found the sudden controller shutdowns quite annoying, especially in dangerous game situations. Luckily there are 2 solutions for that, I will quote the original answer from Nolo support below.
I ended up installing the “disable auto-shutdown firmware” by myself, because I found the firmware and the update tool before I received the feedback from support.
The remote support Nolo provides is still the prefered method in case problems will appear during the upgrade and to keep the warranty.

Feedback from Nolo:
Thanks for your message.
We could update a customized firmware or a disable auto-shutdown firmware to your controller by using Teamviewer (a frequently used support software for viewing remote desktop screen) as a remote session.
a)The customized firmware would allow users to activate the controllers by press buttons/triggers.
b)The disable auto-shutdown firmware includes features to disable auto-shutdown of controllers. It is to solve the problem for some developers/hardcore users focusing on full-body tracking research and development that controllers automatically shutting down in their work.
If it sounds good, please send us preferred time slots (on weekdays).
Thanks,
NOLO Team


#38

Definitely awesome Dennis! :beers::sunglasses::+1::sparkles:


#39

DMarkwick i have nolo to for controlers go to sleep you can sent mesage to nolo support for mine nolo support chance my Nolo firmware to 2.2 with auto turn off disable so you need firmware for your first problem same nolo vr firmware need downgrade to work with pimax latest nolo vr firmware not recronized
i am pimax4k & nolo user to like you