New PiPlay version 2.0.7 Beta is available for downloading


#28

I’m about to buy one of these to use for movies instead of my Oculus Rift. What is the best PiPlay version to install to get the best quality and ease of ensuring 1440p? Thx


#29

The current newest piplay should work for your purposes. Though if there is an issue between support & the community we will get you up & running. Piplay 1.2.97 is also working well.

What is your computer setup?


#30

I’ve got a laptop with a i7 6700HQ and an external GPU dock with a Titan X Pascal. Since I can easily get 60fps with 1440p, should I leave the asynchronous/time warp option off and boost quality value to 2 or 3?


#31

Tbh its something you will want to test once your headset arrives to see what works best. Fo movie watching i would imagine no need for warp. But i maybe wrong.

@sjefdeklerk what is your opinion on this?


#32

Ah yes, this problem.

I upgraded today to the 2.0.2.33 version because the .97 was drifting something awful.

Restarting doesn’t fix the issue, but I’d recommend doing it first. After running into this problem over and over, I ended up having to do the following to get things working right.

  1. Close and quit Piplay and Steam, and Nolo’s software.

  2. Unplug the Pimax headset’s usb port (hdmi can be left in) and unplug the NoloVr usb port. Make sure all Nolo controllers and base stations are turned off.

  3. Open task manager and click more details in the ‘processes’ tab if not done so already

  4. Scroll down under ‘Background Processes’ and close/end the following:

  • pi_server
  • PiService
  • PiServiceLauncher
  • VR Server
  1. Double check that the previous four processes do no auto-open. You might have to set Piplay to not launch at start if pimax’s keep starting, or you might have to close those three quickly.

  2. Turn on the Nolo base station

  3. Plug in the Pimax headset

  4. Place the Nolo head piece within range of the base station and plug in its usb cable. Check for green light on the base and the head piece

  5. Launch Piplay. DO NOT hit recenter, but magnetic calibration can be conducted if desired. Don’t ask why, because I don’t know why honestly the recenter causes issues, but it has been a consistent factor for failure for me so far. Also the magnetic calibration is not to great at preventing drift…(@PIMAX-Support)

  6. Click on the chain link in the bottom right corner to verify Nolo’s connection with Piplay

  7. Launch Steam normally, NOT steamvr.

  8. In Piplay’s home screen, scroll down to any game and click on the ‘SteamVR’ with a square and arrow. This will launch SteamVr.

  9. Open up the display mirror and verify positional tracking is working. Then run the room setup as ‘Standing Only’, not the full room experience. (This step has to be done EVERY time you launch steam vr with PImax and Nolo no matter what) I suggest leaving the headset on the ground during the entire process if in Nolo’s 360 ceiling setup.

You might notice I left out pairing the controllers in step (8). For the first go-round, I would try to only get Nolo’s head piece working first, as I ran into some issues where a controller wouldn’t be detected, then nothing would be. That required a restart and doing the steps all over again. Once things started consistently working, I’ve been pairing the controllers in step (8) with little to no problem so far (only one restart).

Once in SteamVR, however, you should be able to connect them without issue for sure.

Step (13) is important to getting games and such working with no issues, at least for me anyway. Do note you can run the room scale at any time after the SteamVr launch, it won’t hurt.

Yeah, its seems like a lot and is annoying, but once I started doing these steps every time (restart not required usually) I had no issue with getting Piplay and Nolo to work in SteamVr. Spent a few hours and some experimenting, and this seems to be the best strategy so far. And by “every time” I mean it, SteamVR will not work for me right for some reason without these steps.

And a question for you… are you using the front facing or 360 Nolo experience?


#33

@htd2007 Recently we found that some users encountered this issue of firmware update failure.

Please try these steps:

  1. Download and install DFU driver: https://mega.nz/#!BBRmmAjR!tWNGwSZDV-dK7EYLb4Rz-4nHwOPQzJsP-TT0Sxob7SY
  2. Download manual tool: [Release]Pimax 4K firmware

#34

I’m using front facing, with no controllers, and i’ve tried all things described in your post except for ‘launching a game from piplay instead of starting steamvr from steam’. I’ll try it again, thank you.

I cant even get my pimax working when nolo basestation is off and headset marker not connected, have to unplug base station all the time which is a bit annoying (means plugged device prevents pimax from working even if all nolo devices are turned off).

How does this looks like? I couldn’t see any notifications there about nolo


#35

@PIMAX-Support

Is there a way to completely disable the Pimax headset from being the default audio device? Every time I disable this feature in Piplay yet it does nothing the next time I launch Piplay or when I plug in the Pimax headset. I don’t really think plugging in the headset should automatically swap Windows’ default sound output device…


#36

Hey have you tried changing this in Windows Audio properties?

Make sure the headset is plugged in when changing default devicd


#37

So I’m not sure if I’m the only user that’s noticed this but since I wanna say the 1.2.* versions there’s been this weird screen tearing on the HMD. I thought it would get better as you guys improve your render engine and I’ve even noticed that it disappears and reappears periodically. Can anyone else chime in on this issue? I plan on getting the 8k but I’m not really just trying to shell out 500 for more fov. The flickering definitely ruins immersion and invalidates the progress you guys have made in another areas…


#38

@Enopho said if your using Windows with the creator’s update that i believe it activates the option of game dvr ? & to disable it.


#39

Trying new version with nolo.

My nolo still doesnt work ;(


#40

PIMAX-Support the tool download only has 248/251 dfu. where can I download 265?

also when I try to run the tool it complains about missing DLLs.


#41

Followed step by step and it didnt worked ;(
No visible indicators for nolo in chain menu (its green).

on step 12 as soon steamvr stars an error shows (no base) and pimax shows only grey screen (means cant be used at all).


#42

Found the issue with nolo. If it’s connected via usb (for power supply) steamvr/pimax doesnt recognize it. Unplugged usb and it was recognized same moment with no steamvr restart.


#43

If you had it hooked into the computer for power maybe try a wall plug usb charger


#44

Hmm, that’s strange, because I use a 7 port usb hub that Nolo connects too. It is USB 3, and will work with or without an additional power adapter.

I have to use the pimax on usb 2 port, but Nolo can be on any port.

Have you downloaded the Nolo software and run the visualizer to see if the thing will even connect to begin with?


#45

No, pimax or nolo advised to uninstall it so i never installed it.
One more weird thing, after it was recognized i could plug in usb cable back and it worked for 2-3 hours. However as soon it has been fully charged it stopped working via cable completely. While i was in a race tracking has become up-side-down. When i quit the game i have noticed that the base station doesnt work anymore, its 100% charged and recognizes only when I take out the cable. It doesnt requires any software restarts, simply plug and play, works&not works.

Anyway, i will solve with usb hub, i have some. But the issue needs pimax attention in my opinion.


#46

Okay, so the Nolo software will not conflict with Piplay if it is closed beforehand. Make sure it isn’t set to launch on start, though. So long as Nolo’s software is closed, Piplay can interact with Nolo, and vice versa. Its one at a time.

Anytime I have issues with connectivity or tracking, I load up Nolo’s software after closing Piplay and open the visualizer.

It might help to remove/uninstall Nolo under your devices and then plug it in so windows will auto-install it, but you might have a bad base station.


#47

@CryCoh Hi, do you use Desktop without external speaker?
Just now, I checked and unchecked the audio option in PiPlay, and also re-plugged the usb cable, it seemed normally.