New Pitool 1.0.1.180 is available now from Pimax

pimax-official

#222

Why do you apply the dll “fix” in this 180? becuase the gpu trick?


#223

The old DLL file was only meant to enable the “default button tweak” again in PiTool 144 (that apparently blocked the tweak). You shouldnt need to use the DLL anymore it in PiTool 180.


#224

@SweViver Index Controllers are broken when playing Oculus games direct from PiTool. The A button does the A button function AND the B button function at the same time, the B button doesn’t do anything.

Please ask Pimax to look into this.


#225

I have reported this to the team already, thanks mate!


#226

Finding this version to be very good.

PiTool Render setting 1 is poor but 1.25 and 1.5 with Normal and Wide FOV, Aggressive FFR and SteamVR 100%/100% is giving great results. With Wide FOV one might have to bump SteamVR to Vid 50% so as to not blow past 8192 res limit. I can’t seem to get beyond that limit working properly at the moment.

Aggressive FFR is great and seems the most developed. Balanced FFR is garbage by comparison and one can really see the render stepping which isn’t there in Aggressive.

Much potential and hope development continues apace.


#227

By replacing the .dll you’re effectively removing the update. I did the same and not only did my performance go back to 144 levels, but I was unable to reproduce the GPU trick at all in rF2 for the 5 minutes I tried it.

I’d be uninstalling everything, removing that old .dll, reinstalling 180 and trying again. I can GUARANTEE that Assetto Corsa is absolutely not what it was in 144 or any PiTool before it. Something has changed with the increased usage tweak they’ve done and I will be unable to use AC with 180 until it’s fixed.

So for me, using 180 for Raceroom and rF2 and switching to 144 when using Assetto Corsa is actually a thing. Seriously, the beta testing is getting old at this point. Did they even run it before they released it? Menu is buggy, hz options don’t change and save, contrast sliders revert when changing another setting and hitting Save, sliders displaying incorrect values (2 previously set and saved shows as 1 upon relaunching PiTool, but when changing it back you realise it’s actually still on 2).

Use fpsVR while in AC with a clean version of 180. The spiking and frame timing, GPU usage spiking as well and inconsistent frame rate is very very apparent. Swapping that .dll completely negates all of that. The point is, is that AC never needed ANY GPU usage tweak or adjustment,. it was perfect. Now the titles that ran perfect before are actually affected by whatever they’ve done to 'marginally improve the usage in titles like Raceroom and rF2.

I race leage 3 times per week. I spend the majority of my time in menus and staring at fpsVR wondering just what is going on. It’s getting exhausting.,


#228

There is nothing wrong with Assetto Corsa from my tests with PiTool 1.0.1.180.

That with Nvidia RTX 2080, PiTool 1.5 Render, Normal FOV, Aggressive FFR.

Smooth and pretty. Use the game specific settings and launch Assetto Corsa from Steam or from Content Manager if you use it. It just doesn’t launch from PiTool itself for some reason.


#229

Please do some testing, Martin, when you have time.
Pitool 180 has higher GPU usage but worse fps and the GPU trick doesn’t work anymore.
With this version, I’m unable to reach 64 fps in DCS.

With the dll replacement though, I can do the GPU trick which will result in better overall performance and now I’m 64 fps stable in the exact same scenario.


#230

To make Oculus work again on win 7:

It works :wink:


#231

Different people are experiencing differing results. I’m now experimenting with a completely locked frame rate to see if that affects timing and head tracking glitching. As always, not everything will affect everyone equally. But I can assure you I will not be serious driving with 180 if I cannot achieve 144 level stability.


#232

The problem is need consistent testing strategies. Too many are using different recipes in settings. Sure MB & other hardware options/OC will play a role.


#233

As stated, the replacement of the dll for the GPU trick which worked for PiTool 1.0.1.144 is not applicable for PiTool 1.0.1.180 and will nurf that version of PiTool.

From my own observations, GPU usage in PiTool 1.0.1.180 seems to be pretty good.

@anton_Chez, are you using a base station for tracking or just inbuilt HMD tracking based on the 5K/8K in built gyro?

I have a mapped button on my wheel for centering as I am only relying on the HMD for tracking and no base stations. Have to do the same with flying too which is annoying but not a VR killer on my part.


#234

The pump is working just fine, that wasn’t the issue.

I was only speculating due to the timing of the hardware failure- like I said in my original post, it’s entirely possible that what happened was totally unrelated to Pimax. I only wonder because it happened 2 minutes after installing this new PiTool update. So far, it’s been fine with my new mobo/cpu (grabbed an Asus x570 pro and a 3700x, everything is working fine on this latest PiTool as far as I can see).

Yeah it wasn’t the power supply, I’m using the same PSU with my new CPU/mobo without issues. I don’t really feel like troubleshooting any further but if I had to guess I’d say the issue is with the old motherboard (which, upon further inspection, has one bent pin in the socket).

The whole thing was just really weird as my computer has been up and running great for years. Everything is fine now with this new CPU/mobo, though, so I’ll chalk it up to a coincidence.


#235

Sorry, I didn’t actually test without the .dll fix.


#236

Sweet! Must be loving the new Ryzen. :heart_eyes:


#237

OK. I figured that the new .dll was problematic, giving the initial reports. I’ll retest with the new .dll, probably tonight. The takeaway is that combination yielded great results, so others should not be concerned about the results, if they want to try it.


#238

What part of not needing the .dll in the new PiTool (1.0.1.180) don’t you comprehend?

Un-Install your PiTool and then install PiTool 1.0.1.180 and nothing more.

Do not f-around with .dll substitutions. PiTool 1.0.1.180 doesn’t need them for decent GPU usage.


#239

Nothing wrong testing things. Lol. Especially of ypu back things up (that way no need to uninstall).


#240

True but when others have been there and done that and the consensus is don’t use the old .dll on the new PiTool as it makes things worse.

Well …

For me @Pimax-Support
Can we get Fixed Foreated Rendering working stable with Il2?

There is so much potential there but for me - it is like 50% stable. Half the time Il2 will crash or lock up during usage. It seems to work a treat on Assetto Corsa and when it works on Il2 it is great as it allows me to push very good render targets and graphics settings in Il2. Maybe something that needs to be talked out with the developers 1C/777 with. I have been banging on about FFR, getting rid of Parallel Projections compatibility a bit over there.

I mean one can see with those 2 issues getting nigh on 200% improvement in performance which is quite a bit. So pretty when Il2 is cranked up through the 8K. :grinning:


#241

Single base station as I always have been.

I just ran back to back tests with both 144 and 180. Exact same settings, EXACT. Locked frame rate (that was the goal anyway) of 64hz and a Small FOV.

180 won’t be making it back onto my system. The timings and head movement are PERFECT on 144. I deal with the lower GPU usage now by just reverting to 64hz and Small FOV. This way I get a crisper image while not being able to utilize most of the GPU on 144. AC has returned to its glorious former self and rF2 and Raceroom looked amazing with the higher pixel count. Getting those pixels up to around 10M per eye really does give you a great image. Small FOV helps with cramming the pixels into the center rather than giving a larger rendered image.

Any sim racers would best avoid 180. That’s my opinion after a night of free beta testing for Pimax.

You’re welcome :slight_smile: