New Pitool 1.0.1.180 is available now from Pimax

pimax-official

#282

with the latest steam vr updates came also new index controller firmware, update works with this pitool version through steam vr, when sarting the firmware update you will be asked to connect the controller by usb and the controller and radio firmare will be updated
i had not problems doing this and controllers worked after the update


#283

Yes…I also contacted NVIDIA but they do not intend to release it for 1xxx cards. Tried FFR on an RTX of a friend (I have a 1080ti) and I was actually impressed by FFR as it provides a small but very noticable increase of performance.
Let’s hope pimax and/or software devs will implement it from their side.


#284

What does motion compensation do?


#285

it compensates for the motion of a sim rig it’s only relevant if you have one of those things that moves when you sit in them and play.


#286

Ok so this update has been out for over a week now. Im thinking about updating to this new version and not sure if I should yet. Have any of the bugs been worked out of it?


#287

Got no annoying bug on my side, might have restarted service once or twice but very happy with it so far :slight_smile:


#288

I have to second that, this version is a step up. In the past I complained about smoothness, but I must say I am beginning to doubt myself. Definitely an improvement in rFactor 2.


#289

So far no problems here and now being able to run The Climb is bonus.


#290

Yep works fine and even the hmd and lighthouses are now instantly recognized after firering everything up. In the versions before I always had to restart service multiple times or even restart pc. But this version runs really good so far.


#291

Is anyone getting stutters in Elite with 180? I get FPS drops. Using fpsVR seems to show drops in GPU and CPU down to zero. Sometimes random. Sometimes more closer to stations etc. Really annoying


#292

I haven’t noticed a problem with ED and the .180 update. Are the framerate drops everywhere or do you only see them at stations or on planet/moon surfaces? What are your system settings? FWIW, .180 seems to be better than .144 on my system.

For comparison: My system has an i7 4700K, 16 GB ram, and a factory-overclocked RTX 2080.

You might want to try playing in solo. Network congestion can trigger framerate drops in ED. In addition, installation on a hard drive (as opposed to an SSD) will slow down asset loading.


#293

My system is 2080Ti with delidded 8700K. It seems to be stations. But also heavy on a planet. Maybe every 10 seconds on a planet. I may go back to 144 and retry the same station and planet. Its bloody annoying.


#294

PiTool 180 seems to be a fairly good improvement for me. I have been able to increase graphics and SS for IL-2 and maintain good fps. I also find my GPU temps are lower.

There are however two things that continue to haunt my 8K use and stop me from using it for anything other than testing.

  1. Loss of tracking when in game. This occurs after 30 minutes to an hour of use. When this occurs the screen of course goes black and I usually turn my head to get it back but what has been happening is, it comes back for a second, then Pitool, SteamVR and IL-2 all crash. The last time I used it the tracking did come back and I was able to continue with the game. Losing tracking is a no go. I only have one Vive LH and it is currently high in the corner of the room, about 45 degrees off my right at about 65 inches (165 CM). Will the Pimax LHs be better?

  2. I also receive a BSOD when powering down HMD.


#295

Pic of what happens in Elite.

CPU and GPU drop to zero. Game lags heavy. Then resets. On a planet here but also when outside a station


#296

Something is wrong. Your system should be running ED well, since it’s similar to mine, but with an even better GPU. Are your in-game graphics set to Ultra or something? For VR, you will need to set some options to High or even Med. Here are my ED settings:

I’ve got Pimax quality set to 2.0. If you have it at a lower setting you can probably use better ED settings than I do. Your screen res is a bit higher than mine, but that should be OK, since you have a Ti GPU.

You might want to try UserBenchmark, which will give you a heads-up if something is sub-optimal. My overall ratings are ~130-150% (“UFO”). If something is amiss, click the question-mark-in-a-circle icon, for recommendations.

https://www.userbenchmark.com/


#297

Isn’t that showing your 2D settings? What are your Pimax settings?


#298

I don’t understand how others cannot accept people have issues with 180. I changed NOTHING in AC apart from installing 180 and it’s absolutely unplayable. Exact same weird usage and frame time issues like in the pic above.

Seriously, I know you’re trying to help but if changing every setting from what worked perfectly in a previous PiTool is the only way to attempt to get it to work, perhaps it’s, you know, the PiTool?


#299

Sorry, I meant to show my current settings. I don’t use that tool to switch settings, since I always play in VR these days.

I’ve updated my previous post, which is now correct.


#300

I believe you. I’m trying to help.

I have played AC using both .144 and .180; both versions run great (78-80 fps on my 8K). I changed no settings in PiTool or in AC (since updating versions). The same is true for ED, except the frame rate was 62-80 fps. Those 2 games are the only ones I’ve tested.

I have lowered some of my AC settings (from those I used for my 4K monitor. I turned off environmental effects (that yields a huge improvement in framerate and I don’t even notice the difference). I also set reflections and shadows to low (or maybe medium). I still have AA set to 4x. Steam VR is set to Auto and AC app is 150%. ED app is 110%. I have Vertical offset set to +8, so I’m rendering a larger viewport than standard (offset 0).

Did you turn off PP for AC? You should, since it’s not needed.

I have an i7 8700K, which has 12 (hyperthread) cores, 16GB ram, and a factory oc’ed RTC 2080. (Actually, I upgraded to 32GB today, but I haven’t played any games yet.)


#301

And visa versa - there are those of us who use PiTool 180 with Assetto Corsa with great results. There are many variables that have to be taken in account and what of your other VR titles? Are you having issues there?

Have you created PiTool Game Settings in 180 specific to Assetto Corsa or are you running it off the Common Settings selection under Game Settings? I am running Assetto Corsa specific settings profile myself with an 8K on a i7700HQ with a RTX 2080. No Overclocking, PiTool Render 1.5, no Parallel Projections, Normal or Wide FOV, FFR on Aggressive.

$x AA ingame withj Sol weather mod. It is smooth and looks great. :+1: