New Pitool 1.0.1.180 is available now from Pimax

pimax-official

#302

I’m also seeing the bad stuttering/spikes with PiTool 180 when it did not exist in v132. Were you able to find a fix?

(It happens every 5-10 seconds in Skyrim. With Beatsaber, it is far less frequent, but will stutter once or twice per song). I’m running small FOV, 72hz, PP off, with a fast 2080TI rig.


#303

Thanks bud…


#304

My thoughts on the new pit tool 180 :

Robo Recall : I cant grip my guns with the index controllers and still got the height bug . I am too high of the ground . With Robo Revive I dont have the height bug but I cant play any mission because the select button doesnt work.

In seeking dawn I get flickering screen due to too high gpu usage in this game.

The climb doesnt render the resoltion right . Pi tool render changes have no effect in this game.
Defector is broken , everything is too dark …and I am hovering over the ground resulting that the npcs are too small. I am like 7.8 foot tall wtf :frowning:


#305

Indeed. Be good to compare computer setups instead of just settings.


#306

What’s the firmware of the 180 version? My PiTool says V2.1.255.212. Is that the latest?

If not, where is the new firmware?


#307

There’s no new firmware in .180 (it’s still .212).


#308

I’m simply comparing PiTool for PiTool. Not a single other setting matters, What works in 144 should work in 180. 144 has expected frame pacing and smooth GPU usage, no spikes, no funny looking graph in fpsVR. 180 gives all of these things, in some titles worse than others.

The end result is all else being equal, the PiTool experience in 180 is far worse than 144 EXCEPT for slightly higher GPU usage overall in titles that generally struggle with it in 144 and earlier.

NOTHING else matters. It’s a simple exercise of test 144, it’s fine, install 180, immediately test again (after reboot), issues are super apparent.


#309

I really do wish it was not so! I have praised the improvements of PiTool many times over the months I’ve had my backer unit,. But, it; needs to get better and it still feels very second rate in some areas. It frustrates me and it really shouldn’t. There is nothing worse than inconsistent performance with plenty of resources available.


#310

here’s another cool thing about v180 - I never had to restart service due to bases not detected! Fingers crossed that’s thing of the past.


#311

I’ve had to restart the service, but it seems it depends on which order I start stuff in. Still not sure which one is the “right” one (and I really shouldn’t need to know), but after a service restart it works every single time (instead of randomly before)… :wink:


#312

Seems it’s ED causing my issue. Tried slowly disabling most apps. I then tried the desktop version and it’s also stuttering on these planets. Not a VR issue. Meh


#313

Try reducing your ED settings, based on my previous post: New Pitool 1.0.1.180 is available now from Pimax


#314

I have tried many reductions. I even moved my installation folder. It may be my memory but ED only uses 3GB. Also other games that appear more demanding are fine - Witcher 3 with mods, Divs2, New Tomb Raider. It only happens on planets. And I’ve only tested near Sag A as that’s where I am. Doesn’t happen in an Asteroid ring. Weird. I fear it’s texture streaming of the planet. And again happens in desktop and VR


#315

I start PiServiceLauncher before starting the game, and stopping it afterwords. But sounds like I just got lucky :slight_smile:


#316

That’s probably why it works :wink: Mine starts at boot (service only) so I restart it every time I have to use my headset… :slight_smile:


#317

Stations and planets are the most demanding areas in ED.

You should reduce the “Terrain” settings. Lower Terrain Work to the lowest setting and set the others to Low. If you get a good frame rate, try increasing some of them to Medium or even maybe even High. One of those settings (Sampler Quality ???) is the anisotropic filtering, so make sure you are not overriding it in the nVidia control panel app. Also verify that you are not forcing Antialiasing on, since that won’t improve your ED experience. (ED uses “deferred rendering” which means it cannot use AA, but I think it tries to, which might reduce your framerate.)

For quick testing, land and get in your SRV. Use FpsVR to get a consistent framerate reference. Stay in the SRV until you’ve found acceptable settings, so that you can quickly change the in-game graphics settings and test them.

Note: Some settings don’t take effect until you re-enter a system. (I’m not sure which ones.) If the framerate doesn’t increase, exit to the main menu (no need to exit the game).


#318

Appreciate the info. I will do more testing. I tried getting in an SRV. I didn’t see any stutters like the ones I am getting. Super weird. I’ll make changes then ensure I restart the game


#319

Good luck! I hope you can find playable settings. It might be worthwhile to run Task Manager, to verify there are no apps or processes using significant CPU cycles.


#320

I can’t think of our member’s name but remember he said to use I think taskmanger & Rio? To choose cpu thread & affinity on vr processes to optimize individual processes.


#321

Do you guys run games with SteamVR actually open or do you just launch the game with SteamVR closed? It works either way for me, I just lose access to the desktop mode with SteamVR closed. I’m trying to see if there is a difference.

I went back and tried 180 again. It did the same thing in rF2 but not in AC. A few reboots later after messing with some things not PiTool related and I got smoother, expected performance out of rF2 as well. GPU usage still nowhere near what it needs to be but it was better. Then I realised I did not have SteamVR actually running.

I have no idea if these things are related but some feedback as to what you guys use might help.