New Pitool 1.0.1.180 is available now from Pimax

pimax-official

#342

If you want to keep the basic configuration, yes, it would be better to reduce -1 blue, if you want to improve colors and contrast, it is better +1 red/green and -1(or 2) rgb brightness


#343

Same here. I’ve also stuttering in Skyrim with PP on. For me it is unplayable with 180. I went back to .144 and the problem is gone


#344

I think an option down the road that would be great for Pitool.

Would be something like Wine has with being able to run which version works best for a given program.

Or Program containers maybe kinda like Appimages


#345

Same for me, 180 is much faster, but the image has cuts between jumps as a kind of interaction with interpolation or something… 144 works without this issue for me.


#346

I just did and the only one that works for me is firefox night and firefox. There 2 different firefox one that doesn’t have webvr and one with webvr. I can find you the link when i get off work


#347

Back to 1.0.1.144 for me.
Some reason recent SteamVR updates etc have rendered 1.0.1.180 unusable. 144 after testing is more stable nd working with FFR in Il2 and SteamVR Home.

C’est la vie.


#348

Or, or, we could actually get a release that follows previous releases that doesn’t break half the experience while adding half baked features like motion compensation, perhaps? They increased the GPU usage (YAY!) and properly demolished the actual experience of using the HMD with 180.

I’ve spent TWO NIGHTS chasing the ghost that I found Monday that was actually a working Pitool 180 with no GPU spiking and head skips. I have no idea how I actually got it running smoothly and as expected but it was indeed a fluke. I’ve not seen it that way (aka functional) before or since Monday.

The GPU usage ‘bug’ should never have been present in the first place. I have absolutely no idea how any of you running 180 are doing it. Just as you have no idea how stupid I could be for not having it run as intended. I can ASSURE you, something is broken, somewhere.


#349

Motion compensation is not a half baked idea as it is needed for motion rig setups.

Yes I would agree as Steamvr updates have broken a number of things. For example I made the mistake if enabling Xbox controller remapping. Had to disable in desktop Bigscreen Mode to restore use in SteamVR & now can only summon dashboard in steam home to launch games.

Where before I could move around with controller.

While some like yourself are having issues with 180 some of us are not. So question is what is different between pc setups?

And let’s not get into why Microsoft allows us to differ their updates (especially businesses) to ensure stability.

GPU bug can be due to a Steamvr Bug as detailed by Steamvr recent update & Nvidia has had a couple of updates with driver bugs requiring a quick release patch. These things need to be evaluared by the core 3 involved.


#350

I’ve been using version .180 and I haven’t had a problem, so I’m not sure what to suggest.

I scanned this thread and couldn’t find your system specs. I wonder if the problem might be related to the number of CPU cores or something. I have a i7 8700K with 12 hyperthreaded cores, 16GB ram, and an RTX 2080. I am using a different version of nVidia drivers: 143.68, but your drivers are close to that version.

As for the GPU usage, I think you are referring an issue which Microsoft has admitted was their problem, which also affected flat monitors and AMD graphics cards.


#351

I cannot understand how it is so HARD TO COMPREHEND.

144 works as expected.

180 absolutely does not.

PiTool IS THE ONLY DIFFERENCE.

My specs, 9600K oc’d to 4.9, 1080Ti, 16GB 3000mhz RAM.

If 144 and previous gave issues, I can sympathise with thinking it is something to do with my system. I literally switch PiTool’s to fix the issues. How is this not a PiTool related issue?

Also, the GPU usage has largely been ‘fixed’ in 180. So none of that Microsoft or Nvidia update talk is going to do anything. As I suspected, it’s a PiTool related issue. 144 gives me 70 - 75% usage in rFactor 2. 180 gives me 90%+ usage in rFactor 2. SImply by upgrading PiTool.

Guys, again, NOTHING else matters when changing PiTool versions fixes and breaks the things I am talking about.

As for the half baked comment I made, I am a motion platform user. I don’t intend to use the compensation feature, but those that I know who do struggle with missing features and options related to it. A great idea no doubt, but still far from complete. I can deal with this.


#352

What your missing is that were not saying that it’s a problem with your system directly. The fact is for some are having issues with 180 & some are not which was the case even with 144.

With computers have a complex list of componets beyond cpuŷgpu/memory. All the different Northbridge & southbridge flavours & more come into play.

So dev applies a fix fir chipset A & Chipset D has issues. Just look at the mess with Usb 3 chipsets & VR.

Make no mistake no one is blaming your setup. But to identify & reproduce issues described need full pc setup info like Mobo make & model.


#353

Maybe so and if true then you may have to wait for 180 to come out of beta to see resolution, in RFactor 2 at least.
As far as right this moment goes, “for what I am running” on Pimax,180 is the best driver to date.


#354

Yeah, the same for me.


#355

And the same for me in Fallout 4 VR.


#356

Sorry for the late reply I don’t visit these forums too often although I probably should more. In PiTool under My Games you can click import and add the exe file. This will bypass SteamVR. I only use it for Dirt Rally currently but I imagine you can do it with others. With Dirt Rally you have to do it this way if you run it through Steam with ReVive it is unplayable super laggy. You also need to do some other things like create a steam id txt file in the game directory for it to work. I got the info from this thread: How to play dirt rally VR on pimax 8k, 5k without revive and steamvr


#357

I’m running Skyrim VR through Mod Manager 2 with a couple dozen mods. SteamVR @ 128% Pitool 1 no PP, Smooth On, 72Hz. I have no stutter on my 6600K@4.5 and MSI 1080Ti GamingX with 16meg 3200DDR4.
As for Skyrim well it’s not going to be perfect with PP on but I find performance about what it was in 129beta. That being playable but certainly not smooth.


#358

Yeah, i’m running it through Mod Manager 2 as well. I have 315 mods. Plus the VR ENB. Spec is 8700k @ 4.9Ghz all core, 1080ti @ 1997Mhz & 5712 Mhz Ram, 16Gb 3200 DDR4. PP OFF. Steam VR between 100% & 130%.

The problem all boils down to the graphics card usage I believe. In old versions of the driver I had the problem where it hitches every so often but very badly when it does and the entire frame stays stuck without change as you shift your head. Yuck, lol. You could get rid of that by under using your GPU and leaving headroom, but where is the fun in that! They resolved the ‘100% usage bug’ after that. It has been reintroduced in the 1.0.1.180 driver. I believe because they are trying to deal with another issue - the under usage of graphics performance reported by some users and Swiver. But in doing so they are reintroducing this problem for some users. I have a hunch they are not leaving enough overhead reserved for V Sync or frame pacing or something like that. The working 144 tops out at 95%.

I can 100% resolve the issue by reverting to 144.


#359

So, is this Nvidia FXAA/Pitool display issue going to be fixed in the next release? I’ve never seen ANY application doing this…


#360

Can’t say. But easily fixed leave it off globably & turn it on per ap that needs it in Nvidia per game/ap that needs it.


#361

It has been said that FXAA is a poor for of Anti Aliasing to use with VR. Multisampling is the better way to go.

Reddit to the rescue with some good discussion on the different types and what their strengths and weaknesses are.