New Pitool 1.0.1.180 is available now from Pimax

pimax-official

#462

Some VR games are not GeForce Experience ready, aka they are single core heavy and clash with Nvidia Services that are part of the GeForce Experience.

The Nvidia Services can be set to Manual Start in services.msc and not bother the older game engines that suffer performance issues with GeForce Experience installed.

PiTool 1.0.1.180 and Nvidia 436.15 Gaming Experience Driver Installed with Nvidia Display Container LS and Nvidia Network Service Container set to Manual Start in Services.

I can still bring up the Nvidia Gaming Overlay with Alt-Z but not sure if things work with it as I’ve not tested on compatible games.


#463

what games do you have framedrops?


#464

My suspicion is the problem (the hard frame lags) with 180 is related to the graphics card model you have, and that the only way to remedy it is to get a different graphics card or wait for the next pitool that better optimises the gfx card usage levels for all cards. That Pitool is using the higher % which is working on their test card, but going too high when the software tries the same trick on other cards out in the wild.

I didn’t even have Geforce Experience installed when I had the problem.

I did have it installed when I experienced the separate Nvidia driver related performance issue though.


#465

Framedrops in every game in .180, even the PiMoon and SteamVR Home.

My graphicscard is an MSI RTX2080Ti Gaming X Trio.

I will try blitze’s recommendations. Hope that works, thanks


#466

By " Nvidia 436.15 Gaming Experience Driver" you mean the “436.15 Game Ready” driver?

I couldn’t find a Gaming Experience Driver :frowning:


#467

Probably the version of the driver which also installs the nVidia “GeForce Experience” app.


#468

It does not work, the framedrops are still there on PiTool 180. 144 is fine. 2D games are fine.

original message //////Unfortunately, neither this nor that. I tried all the ideas, but it didn’t help. Thank you anyway guys! Here is the solution: Easier than thought! Eventually I upped the pre-rendered frames in Nvidia control panel to 2. That solved the issue.////// original message


#469

Thanks for posting your solution!


#470

What exactly was the result of that ?


#471

You’re right (I hate to say it :stuck_out_tongue_closed_eyes:)

We have https://www.geforce.com/geforce-experience/download
GeForce Experience and then we have

https://www.geforce.com/drivers/results/150585
GeForce Game Ready Driver.

C’est la vie.

What VR apps were you experiencing studders with?

Did you try uninstalling Nvidia GeForce Experience? or at least shutting down the 2 services via services.msc?

Never had an issue with pre-rendered frames set at 1 and I have been using that since early in the year regardless of SweVivers recommendation then to use 3

I find it weird I can run Doom 2016 via SteamVR Theater Mode and have all 4 cores of my powerhouse CPU thrashed with no issues what so ever yet I run Il2 with FFR and a little single core stress via AI or something and = Crash.

Maybe it is a DirectX vs Vulcan thing or something else.

Have been running FFR with PiTool render at 1.25, SteamVR both 100% on Normal FOV and Balanced Graphics Il2 with some success. More like 80 to 90% up time and even online with Finnish Multiplay server but if I go in to ground attack a heavily defended target - Crash.

Looking forward to the next Il2 update and see what that brings under the hood.
PiTool 1.0.1.180 - been great. Does need some polish with interface like Hz switching and so but on the whole.:grin:


#472

Delete all that. The issue persists. PiTool 180 still leads to hard framedrops on the RTX2080ti. The GPU loading fluctuated between 96 and 84 last time I checked. There’s something seriously wrong with PiTool’s load management.

I first thought I may have a bad card, but it doesn’t appear in 2D games.

It appears in all VR games. Only with PiTool 180:
I am using an msi rtx2080ti gaming x trio with nvidia drivers 436.15. Boosts to 1950MHz coreclock by itself. No overclock. Current fluctuates between 970mV - 1050mV. GPU usage fluctuates between circa 96-84%.


#473

Don’t qoute me on that, because I did not try this yet, but there’s a person in rF2 community who did multiple measurements with newest driver, and he found that setting VR Prerendered frames to App Controlled and Latency to Ultra improves framerate in rF2 and ACC. This is counterintuitive to me, but oth if game does not do good job at pacing frames, I can see how new latency could reduce amount of throwaway frames. More here:


#474

Just to say…I have the same. Very good cpu with 2080ti and although framerates are solid, I get these missed frames very often. Not found a solution myself yet. It’s the only thing left that’s still bugging me. :slight_smile:

Will keep trying things but hoping the next update fixes it…


#475

i just tested pitool 180 with 436.02 and 436.15 without geforce experience with ETS2. (1080i oc and i9 7900x)
Result a little better on 436.15, but very unstable my gpu turns at 96% and then drops to 46% … and it’s visual horror, I use fpsvr.I will test with a 430. to see where I go back on pitool 144.
Damage in 180 with a gpu 96% Smith Smoothing is top.


#476

Are you framedrop guys using SteamVR beta?
Noticed the same kind of behavior with the Index with 436.15 geforce, the smoothing goes on and off and causes lag spikes. Prob. different thing tho since Pitool doesn’t use SteamVR smoothing who knows.


#477

I use steam vr normal


#478

yeah well, maybe try 431.60 drivers
Edit. I’ve never installed geforce experience, like… why? Imo just a nonsense bloatware.


#479

yes, I was with the 430.60 with pitool 144 … I will test see …


#480

I say stupidity, the 430.86 with pitool 144, go test on the 180 if gpu stable or not


#481

Just adding my 5 cents. Not extensively tested but if you install pitool 144 and grab the dll file out of the system32 directory then install 180 and replace the dll file in the system32 directory it appears that you get 180 features but not the juddering and skipping issues.

Have been testing in AC and Rf2 and both seem to behave the same as on 144 but I can also use the 180 features and 180 seems to play nicer with my lighthouse tracking.