New Pitool 1.0.1.197 (beta) is available now

Just managed to install .197 better, first did a total uninstall of previous pitool and deleting all the remaining pimax files and directories in various folders, now the FOV selector is working again, the viewing area looks changed a bit, more oval like but still nice anyways; still no 120Hz selection available, wonder if it is related to the type and refresh rates that the Pc monitor is supporting, as mine only works at 60Hz, in fact if I try to select 72Hz in PiTool it tries to restart the headset in that mode but then reverts back to 90 or 64Hz, this is clearly visible to happen as the headset does two consecutive reboots and reverts back in PiTool to the other available refresh setting.

Perhaps @PimaxUSA or @SweViver can shed some light on the matter, as so many users seems to miss the 120Hz feature.

Will keep doing more tests and update on the findings, if any…

3 Likes

Well I read on YT Pimax # that this is becouse Pimax 5k + is using 2 different panels versions, some ppl have newest and other older but Pimax working on to run 120 hz in both panels. Looks like early backers have no luck like me and we just cant run it yet or never will…

6 Likes

Too bad this could happen to early backer 5K+ models… :frowning:

At least one positive thing I immediately noticed on .197 is that Valve base station now seems to track the headset a lot better and never lose tracking like it was happening in the past.

4 Likes

For the record I have a GTX 1080 and a pretty clean install of windows. I recently updated my tower - which now runs NZXT light control software. I had the stuttering issues before upgrading my tower - which had NO LEDS at all… I do have a razer mouse, but it has no light control capability. I’ve heard of LED software messing with pitool but eh, as you’ve said I have had this issue for many revisions now and with different hardware.

.132 and .144 work fine for me. I tried increasing pre-rendered frames in nvidia control panel to no avail last night and reverted. Even if the solution was to disable LED control thats pretty crap

Will take your advice, thanks!

I would like to see some confirmation that early 5k+'s have panels with lower specs, mine has cracked housing and I will be more willing to RMA if it means getting a unit back that supports 120hz as I’m one the people who still dont have the 120hz option in the drop down

7 Likes

For fix stuttering multiimage issue install this old dll from pimax, works for me on .197 with 120hz and large fov in mode 120hz without image stuttering

Copy on: windows/system32
https://cdn.discordapp.com/attachments/341001980950609932/639908158642585620/LibPVRClient64.dll

3 Likes

Honeybadger tried this with .180 and while it helped it did not eliminate the issue. I may play with it tonight but I don’t think this is a definite fix.

Confirmed with support that new firmware is coming in a day or two to fix backlight issue from 120hz mode.

6 Likes

nice, how about the flickering ?

1 Like

Something broke that was working. The 64hz mode on Pimax 5K XR with OLED does not stick anymore. Lowest I can go is now 72hz, use to be 64hz. If I try 64hz, headset reboots twice and I am still at 82 hz. I thought 64hz mode was great to play Elite Dangerous where I get as low as 32 fps and with motion smoothing can take to 64 fps hence the need of 64hz mode. I hope you repair it for the next version.

1 Like

they should change the title is very misleading.
it should say beta pitool is available now…

1 Like

How do I put something on the official issue list. This is a forum and not a sure way to report bugs right?

No 120Hz for me. Is my 5K+ too old or something? I am very ****ing disappointed

2 Likes

Hello Their. Just installed new PITool to refresh my 5K+ to checkout newest features. But it cannot update the firmware! It stays like this until more than 1h hour! What can i do. Please help!
image

Mini just will not receive the firmware…look post below :frowning:

I just rebooted and it was done :wink:

2 Likes

Anyone can change the title, I think (I just added the “beta” part).

It was stated in the post itself though:

2 Likes

Yes i did some weird stuff now. Its Working now. And i can switch to Green LED!!! This saves my Day! LOL

3 Likes

Very useful post haha

My headset firmware says 255.244. I can change my front LED so at least there is one improvement lol

2 Likes