New Pitool 1.0.1.197 (beta) is available now

It’s def not the refresh rate but probably their implementation of low persistence. I think they should offer some control in this avenue for sure.

1 Like

Skyrim should be a solid 120. I am getting almost solid 120 in the forest vr 1080ti on large mode (which is really medium)

1 Like

Further to my reports on the frame jumps in 180 and 197:

Troubleshooting steps tried so far,

  1. all low latency, frame rendering options, multithreading options inside the nvidia tool

  2. removing CPU and Ram overclocks

  3. setting legacy reprojection in steamVR

  4. changing fan profiles to ensure no thermal throttling on 1080ti

  5. swapped to two other display ports

  6. swapped to two other USB ports

  7. removed wireless keyboard transmitter dongle

(BTW no issues with the current configuration on 144)

3 Likes

There may be a bug somewhere. I have an 8K (so no 120 Hz) and I had a bit of trouble switching between 80 and 72 Hz. I had to restart the service and reboot my headset to get the value to “stick”. I’ve decided to run at 80 Hz, so I doubt I’ll have problems, if I’m not trying to switch the framerate.

2 Likes

In .197, the FFR (conservative) seems to have a bit less bothersome flickering in Elite D. (It’s especially noticeable when orbit lines are turned on.) I think the center (highest quality) area is somewhat larger.

2 Likes

Further troubleshooting, I tried swapping the. Dll and for 192 it actually made zero difference, it behaved entirely the same even after restarting etc.

Unfortunately it looks like I am going to have to revert again. I have tried everything I can think of now and it is just a hitching, stuttering mess. My overall frame rates are higher but 144 feels smoother even if it is running 60fps while 197 feels like s%it even with mostly solid 90…doesnt make sense to me at all why it gets these spikes on the gpu only. Sigh.

Edit: you can downgrade to pitool 144 without downgrading the firmware.

2 Likes

For me, .197 is a definite improvement. You might want to verify that your system isn’t suffering from any unsuspected bottlenecks. I found this app to be very helpful. If there’s a particular slowdown, you can get more info and suggestions by clicking the gray question mark (?) icons.

https://www.userbenchmark.com/

2 Likes

Installed .197, firmware successfully updated, can set LED colors perfectly, but 120 Hz option is not showing in any FOV mode. Kickstarter 5K+ here.

3 Likes

It goes back to running perfectly fine soon as its reverted to 144. The big hitches are all on the gpu and it’s FOR SURE related to the monkeying around they did to increase the graphics card utilisation. 144 seems to overall yield lower framerates but none of these frame jumps occur. I don’t know what changes they made but I wish they would revert them.

2 Likes

thanks for updating the title but what happened to180? it never got released and now we have to wait for this beta to finish?

It’s the current “stable” release:
https://www.pimax.com/pages/pitool

Release Date: 2019/7/25
Version: v1.0.0.180

EDIT: Just noticed that the version still doesn’t match (filename says 1.0.1.180 and beta (http://pisetup.pimaxvr.com/PiToolSetup_1.0.1.180.Beta.exe), but link/version info says 1.0.0.180)… Oh well, it’s considered stable enough to be on the main download page.

3 Likes

I have received my Pimax5K+'s RMA and clean installed 197R244 before plugging it in. Updated FW.
It has 120, 90, 65 Hz mode. No 72Hz anymore.
I have strong distortions on the outer edges, beginning at the outer 1/3 of the surface. I restarted everything, used different modes and FOVs, to no avail.

I did not have this distortion issue with my previous 5K+s.

Is 197 loading any newer distortion profiles? Which PiTool version had them**, do I need to flash FW?**
How can I fix this?

It is unusable this way. I am slowly losing my patience. Will I have to bring this to Berlin, so they can fix it on-site? Any idea?

2 Likes

Guess it must depend on the revision of the headset?

Mine is from 2nd week of 2019:

image

6 Likes

How do you have 120 90 72 64 Hz mode.

I have 120 90 65 only, my 72 64 was removed! And distortions on the side. Was an RMA I received last week…

The biggest issue is distortions on the edges. I didn’t have them in my previous 5K+.

The S/N is 20420494223076.

Is there a software solution ?

1 Like

I can only guess it’s different revisions, but @Doman.Chen might know if that’s the case?

3 Likes

Yeah. I’m certain that’s what it is. They need some kind of resolution. Either reverting completely, or giving us a toggle.

Or even give me the file that makes the change to patch it myself! As long as it works.

It isn’t sustainable to just ignore broken software for a healthy fraction of all users, with the aim of a moderate performance increase for the rest. I kind of feel for them though, they stuck behind a rock and a hard place.

1 Like

Have you tried different face foam/distances from the screen?

1 Like

Exactly.

In the 1st and 2nd 5K+, there was no distortion problem with this foam. They ran the pre-197 Firmware.
In the 3rd 5K+, there is a strong distortion problem with this foam. It only ran Firmware from 197.

I tried other foams as well. Instead of solving the problem, the side of the lenses blur completely out of focus, when I increase the relief.

Might it be, that a previous Firmware version loaded a better distortion profile?
If 197 did not update the distortion profile - there was no other PiTool version that the 3rd 5K+ ever touched.

1 Like

I wonder if that is something related to the 5K+. I didn’t notice any distortions on my 8K. I have a 72 Hz option and the only trouble* I’ve had with the .197 update is problems with switching framerates. I had numerous issues, but eventually got 72 Hz running: The headset locked up, the left panel went black, both panels had horizontal stripes, and I kept having to restart the service and reboot the headset. Once it successfully switched to 72 Hz, it was fine, until I tried to switch back to 80 Hz.

Losing 72 Hz is a problem, since that’s ideal for movies that were shot at 24 fps, because 24*3 = 72, so the result looks smooth.

(*) I have 1 other very minor problem: The front chevron keeps switching back to green.

1 Like

Can I be honest here - this is a normal **** show with Pimax. Nothing ever just works for people. I know it’s new tech. I held off buying the new 8KX because I have a feeling the first batch versions will have a load of bugs/issues. I am going to wait a few months. I literally have 1700 USD ready but didn’t click BUY

I am a little disappointed that being an early backer means I dont get 120Hz. But hey, I’m not gonna get that mad

6 Likes