New Pitool 1.0.1.197 (beta) is available now

@Heliosurge
@Thall

Setup:
ASUS ROG Strix Z390-I
16GB Crucial Sport
8700K
GTX 1070

I do not use WiFi

The stutters appear to me on 180 and 197 but not on 144. The issue also appears when not using basestation tracking and even in PiTool “home” with no game started. Headset firmware seems to not influence it. I really hope this problem will not be ignored. That 180 is the new stable version but is the one that introduced the issue makes me unhappy.

2 Likes

@dogbite

You think introducing a new headet might cause the issue? Might be worth it to uninstall my mixed reality software to check…

Do you get the stutters in the PiTool “home” with the planets? I do, if you do not your issue might me another one.

It would be nice if people with stutters could describe their setup, maybe the factor could be deduced.

@RedRiver 180 is the new stable. Usually that is the one you should install. This one (197) is the most recent. It has all the newest features but still has more frequent bugs. If you experience stutters, you need to go to version 144.

Ah, I’m so sorry. I now feedback to the developer. Thank you.

3 Likes

@Milopapa

If you have gone up to 197 you have to roll back your firmware to remove the stutters in ver 144. Using the new firmware with 144 has the same issue but the stutters are slightly smoothed over. Either way I’m done testing this. There are people from i5 cpus, i7 cpus, intel 4 series to 9 series. Nvidia editions from 10 series to 20ti. So I do not believe this is a hardware issue. I am pretty convinced it is a problem with the Piservices/drivers after they FIXED the underutilised GPU usage by rendering most people’s headsets unusable.

2 Likes

Well, problems are more likely with beta drivers. We need a solid, non-beta release.

FWIW, I haven’t seen this problem (i7-8700K, 32 GB, factory-overclocked 2080). It seems to be more likely in certain games and in VR, I mostly play Elite D.

Have you tried lowering the SS in SteamVR and/or lowering graphics quality in-game? Lower overhead might help.

1 Like

I’ve only gone up to 180 but I did a firmware reflash to .144 so I have both Pitool and firmware on 144.

The other really annoying thing about newer Pitool versions (even on 144) is that when I change refresh rate, it will keep reseting itself to 90Hz and it takes quite a few tries to actually make it stick.

It isn’t an overhead issue, you get the frame timing wildly swinging from 7-9ms up to 17+ ms+ sometimes. Just huge spikes. No problems like that at all with 144. As you can see from the multiple posts it is a common issue across multiple systems and I don’t play ED, but if you are hammering that with a high load so it is down in the 60’s or so you wont find this issue. It is when you are up or around 70-90 fps and it just has massive variance.

It might only be a UI bug. Check the current refresh rate in the lower left corner of PiTool, not the value on the pushbutton. That’s what the headset is actually using.

Hmm. I wonder why I don’t see a problem. My fps is mostly in the 70-80 Hz range, especially with 197 drivers. That’s maxed out for an 8K. Previously, it was more like 60-70 most of the time. It might just be that ED is less likely to have the problem. Or maybe it’s less of a problem with the 8K.

Could it be related to Parallel Projection? ED requires it to be enabled. Also, I have Smart Smoothing OFF and FFR set to Conservative. You might want to try changing those settings (if you haven’t already).

Yes, that’s what’s changing. It flips to 64Hz, then in the UI it will change back to 90 and then the lower left corner will also change to 90.
I’ll try to record it next time.

I had trouble with 72 Hz in 197, so I’m currently running 80 Hz, with good results. I don’t need to drop to 72 anymore, the headset is now able to hit 80 much of the time. Also, the visual quality seems to be a bit better.

My aggravation is that I now need to reboot my PC more often. PiTools is complaining about a disconnected video port. I’m pretty sure it’s the nVidia drivers, since that’s what seems to have triggered the problem BEFORE I updated to PiTool 197. I’ll try the older NV drivers, to see if it fixes it. I’ve upgraded them twice more in the last couple of weeks (NV keeps releasing new drivers), but that hasn’t fixed the problem.

Do you use FpsVR by any chance? I had horrible stuttering while playing Asgards’s Wrath every now and then until I closed that app.

1 Like

just to add
Radeon 19.11.1 is also stating: graphics driver too low, please update

I did’t get an option for 120Hz, in Motion Compensation there is only None selectable. Smart Smoothing can be selected though. I find it difficult to understand what is what and why sth available or not. There should be some ToolTips/Info boxes explaining why it is limited. BTW the pop up messages don’t get rendered propperly, the background box is too small for the text to fit. @PimaxVR

grafik

1 Like

I use fpsVR a lot. I used it for tuning 197 and didn’t notice a problem, but I’ve left it off for the last week or so.

1 Like

I wonder if the “missing 120Hz” issue is due to hardware/driver limitations of some video cards. Others have suggested it might be due to an early version of the headset that can’t support 120Hz. It sure would be nice if Pimax would acknowledge the problem and explain what’s going on.

As for Motion Compensation, you probably don’t need it. That’s for motion rigs, typically for driving and flight simulators. You need to attach a third VR controller (or similar tracking device) to the rig’s frame and (I think) run some sort of setup/calibration (similar to room-scale setup).

7 Likes

Thx for the explanation. See, I wish the Pitool would be self explaining enough about what and why is what…

2 Likes

@spamenigma has I believ3 a similar setup but wirg a 1080. He might have some ideas.

About the stutters with Pitool version .180 and higher, let me point it out one more time that it is not about SteamVR because you can see this stutter in the Pimax home planet scene when even no SteamVR is running anywhere in the background. This has been stated by many users already.

Also it has been mentioned before in this thread, that the stutter bug had been already addressed in the past by Pimax and fixed in the Pitool version .132 but then reintroduced again in the version .180 and still found in .197 also.

3 Likes

Man, still huh? I’ve been using Index since around July / August and I actually forgot about the low GPU utilisation and poor frame timing / pacing with PiTool. I’ve been able to achieve 90%+ GPU usage with the Index and SteamVR in pretty much every title I’ve tried running, and the frame pacing is pretty much spot of given enough headroom for more intense loads. Also, Since July, I’ve had my HMD and base station ‘drop out’ without recovering a total of ONCE, just tonight. Another thing that used to happen daily and has since disappeared since making the switch.

As a former 5K+ owner, I can almost 100% guarantee all Pimax users that the problems are PiTool and PiTool ALONE related. I feel sorry for the people still dealing with abominations of PiTool releases after waiting so long for a new build.

1 Like