New Pitool 1.0.1.197 (beta) is available now

That sucks. Is it one of the early 5K+s? Hopefully, Pimax will be able to get all the 5K+s to run at 120Hz. It would be great if they could increase the framerate of my 8K, but that seems unlike, since the 8K appears to be a discontinued product.

Disabling fpsvr has no effect on the stuttering issues in my testing

1 Like

I had issues previously with stuttering, I found out that I could remedy the issue by disabling Core Parking on the CPU.

2 Likes

Actually I am one of the last backers who recieved the 5K+ because I switched from 8K to 5K+ and back to 8K. Since the 8K got delayed horrible I accepted a swap in the end but that was when most backers allready had their headsets.

2 Likes

@Heliosurge Thanks for the tip. I’ll have to check and test by disabling the PiHome all together and see if that helps (always thought that it is a simple light tool to check first for the headset functionality but I guess you might be right about its bugs, memory leaks etc. :slight_smile: ).

@Thoemse I am not running any FPSVr. My 5K+ headset should not be among the first produced batch as my Kickstarter backer number is over 6800 and I’m among the last backers to receive their headsets. The sticker on my headset only says Pimax 5K Plus and model P2. I have been able to update the firmware on my headset to the latest one but lacking the 120Hz mode in Pitool for some reason (even f setting FOV to small) :frowning:

@Intet If you install the Pitool version .144 back, you can do a manual firmware flash (on your own risk of course) with the tool included with Pitool which can be found from C:\Program Files\Pimax\Runtime\Dfu.exe. When the tool asks for a firmware file, it can be found from C:\Program Files\Pimax\Runtime\dfudriver\p2.dfu. This Firmware version is the older one which has been included with at least Pitool versions .132 to .180.

2 Likes

I went back to 144 ( because any greater version of pitools is a pain to play with …it just doesn’t feel smooth) but i didn’t had to flash my VR headset, works stutter free with the firmware that came with 197.

120hz is still showing and can be launched but the picture is wrong with 144 whereas it was ok with 197 ,

I wonder if Pimax will adress this stutter that some of us experience with any version of pitools except 144.
My specs 8700 K@5.2 ghz (hyperthreading on or off…doesn’t change a thing in Iracing) 2080 TI @+150Mhz CORE +700 memory.

3 Likes

I had the hanging firmware update with .197, then after rebooting I had a 120hz option, but selecting it would cause the HMD to reboot. Ignoring those aspects, the rendering seemed smoother except for the frequent stuttering when turning my head.

In the end I reverted back to .144 again. The stuttering is unbearable.

Running an 8700k and 1080ti.

2 Likes

Why would core parking affect any version of pitools except 144 ?

who knows :slightly_smiling_face: just sharing my findings. Try it, if it helps you then great :smile: if not you didnt break anything by trying it :wink:

4 Likes

It was not sarcastic on my behalf, just trying to figure out the logic behind only 144 is stutter free for me and for some here :slight_smile:
Anyway i just disabled it :stuck_out_tongue: I ll do some testing, may be even try the 197 again thx

Update : I have noticed, since updating my firmware with this patch, and subsequently having to roll it back to a previous version, that my right eye/screen seems to have lost some brightness and clarity. I thought I was imagining it or that my eyes were getting old, but today a friend tried my Pimax and noticed it right away. It’s most noticeable in basic scenes, like the SteamVR loading area - which I rarely have the headset on to see - my left screen shows the white lines on the black background as clear as it always has, but my right screen seems dull and has a little bit of blur as if there’s no ‘sweet spot’ anymore

Does anyone have any suggestions?

@Pimax-Support @Matthew.Xu

1 Like

Try moving the brightness/contrast sliders back and forth. They might be off but not showing correct values?

2 Likes

I’ll give it a go, thanks Doc

2 Likes

I got a replacement 5K+ last Friday and had the same thing on my right panel when I first turned it on but it cleared up after it warmed up (about 30 seconds and no issue since. I am not on 197 yet.
I also had some light that flickered between sharp and dull in one map in Overlord on the same panel. Adjusted my backlit to low and back to normal and it was gone. I have had the replacement since last Friday and using Pitool 180 since issue in July without issue. This started after the SVR update last Sunday,
Also new after that update is flickering on many Steam VR games only with the game menus and SVR loading screens within games. The actually game play and performance is about the same since July. Good.

I still maintain the problems are mostly SVR WIP and Pitool versions may just be a victim of trying to keep in sync with SVR changes still happening.
The SVR release notes say they are working on spatial position tracking and sound as well as tracking position of the headset and reprojection. Steam seems to indicate some of it is resolved in the beta and will soon be live, but they also are still working on some ? of it.
The various types of stutter, flicker, hesitation and such people are describing are all potentially related but some many coming at it from different conditions and specs, it’s hard to nail down.
I know this is a 197 thread but felt it worth pointing out since even though my Pitool and firmware have not changed in months, SVR has introduced issues this week that were not present last weekend.

It’s voodoo mon.

5 Likes

Just for the record, do you have visible black dots? (5k+ Black Dot Pattern Thread. Post here with pics).

See also this thread which is discussing this (Pitool 1.0.1.197 Beta missing 120Hz option).

4 Likes

Hi all. can someone please explain this?

Popped up every time i tried to reinstall Pitool 197 to get the 120hz working on my HMD.
Did everything suggested. Windows update, new driver nvidia, deleting all pimax/pitool folders in appdata and so on. Still no joy PIMAX!

image

It’s supposedly a false positive, your antivirus software thinks the Pitool installer/files contains a trojan.
You can exclude the corresponding files in your antuvirus software.

5 Likes

do you think this may have effected the 120hz not working? ill try installing it, but i just figured out my HMD was manufactured the 49th week of 2018 (if the aforementioned info is true).

1 Like

No, it should have nothing to do with the 120hz mode working or not. Well in a way it does, if you can’t install the latest beta version because of the antivirus software.

3 Likes

well, everything else works fine with new features and firmware update went smooth as well. Im posting the other thread which relates to this issue thou. Thanks for clearing up the potential tojan image

3 Likes