New Pitool 1.0.1.197 (beta) is available now

Well, we have MS releasing an update to DirectX 12 with some goodies in it that might help but again, the Dev will need to update the engine to support it. Maybe in 5 years time.:rofl:

If Valve implemented it via SteamVR I wonder if that would make a difference as I know I can run it no problem on VR titles that don’t rely on SteamVR like Assetta Corsa.

FFR in SteamVR Home is a mess.

1 Like

If Valve implememted it into their OpenVR Sdk like Oculus did in their sdk(oculus haags like 4 types) devs might incorperate it more for sure.

Echoarena if mem serves has it & the bonus is it is gpu agnostic: Amd, GTX, RTX etc…

1 Like

Is there a ways to play on 120hz with the “real” small fov, or only with this super small fov?

Doesn’t work for me, 120Hz is not available in the refresh rate selector menu, and changes made to the FOV have no effect at all now…it stays in large mode inside the headset.
Tried various reboots, restarting piservice, hmd reboot, reinstalling newest pitool with win defender disabled, no luck…

I don’t get a 120Hz option but I can see the different FOVs taking effect OK.

I go to Steam VR home, set different FOV in Games Tab > Common Setting > Apply and can see the FOV change in real time.

The only thing not working is a 120Hz option. It would be nice if Pimax replied in this topic to acknowledge the issue. It’s not user error because I tried on a different PC from scratch.

  • Install latest PiTools
  • Reboot
  • Attach HMD to power, USB 3.0 and DP port on GPU
  • HMD is detected OK
  • Reboot

Once Windows is loaded I go into PiTools, set FOV small in Common Setting (verified working as above). Back to HMD Tab and select Refresh Rate and see no option for 120Hz.

2 Likes

I’m guessing their way of checking if the headset can support 120Hz (checking serial, revision or similar) is to blame.

Seems like it “just works” for some (incl. me) and for others PiTool isn’t recognizing that it has a 5K+ connected which should support 120Hz.

Either that, or (and I really hope that’s not the case), it’s only supported on “later” revisions of 5K+ (I pre-ordered and mine was manufactured early 2019).

On my side it seem everything in the newes PiTools works except the hmd front led color (won’t save after hmd reboot).

Could set to 120hz -> hmd reboots itself -> startet steamvr, opened fpsvr, checked a game and it shows 120fps on fpsvr

Mine will run 120hz on normal fov , closing and restarting steamvr when adjusting pitools helped , also not using any extension cables ( late backer )

Tested a bit around and in 120Hz mode the screen is way darker then in 90Hz mode.

In 120Hz setting backlight to high and brightness to 3+ it is still darker then 90Hz and backlight low / brightness 0

For my taste its way to dark and doesn’t look good anymore as if the displays are damaged. Hard to discribe. I’ll stick with 90hz since I really don’t see any difference between 90fps to 120fps.

Also the suggestet SS rate in steamvr is now lower in 90hz then it was before. With the version before it says 110% on normal fov for my rig and now with the same settings only 98% SS

1 Like

Hi,
After installing the latest Nvidia drivers, I updated Pitool from version 144 to 197. (version 180 did not work for me, too much hesitation when moving my head)
Pitool 1.0.1.197 seems to work very well in X-Plane 11 with 120 hz in my 5k+ at normal FOV.
The shimmering with 2xSSAA+FXAA is very much reduced with Xp11 texture quality set at high (HDR)
Overall the picture is darker, but that can be compensated with higher contrast in Pitool. Increasing brightness did not work so well.
So far I like Pitool 1.0.1.197 very much.
Thank you Pimax!

3 Likes

Could be…mine is one of the early models of 2019 too, but this doesn’t explain the FOV selector having no effect at all on the headset.

BTW the new chevron color selector is there, and works, except it is not saving the last selected color and resets to blue every time…

2 Likes

Not at home right now, but isn’t there an “apply” and a “save” button on that tab too?

1 Like

Only under Games tab, but not under HMD, just a Restore button there.

2 Likes

I’ve logged a support ticket as the lack of meaningful response from Pimax is bloody annoying.

I cannot launch Asgards Wrath anymore with this version. I runs a message shows up saying

failed entitlement check

anyone else having trouble launching oculus games?

120hz mode worked on beat saber. very smooth.

1 Like

Just need backlight fixed

Yep same here. Furthermore, I couldn’t open the oculus tool at all. It just kept saying ‘the software is probably updating’. Not sure what to do, I just played some other games. Gonna try again when i get home.

120 Hz in Aircar is stunning! Very noticeable difference. I normally feel a little nauseous playing this ‘game’ but not at 120 Hz. Smooth as silk and solid as a rock on a 1080 Ti. The higher frame rate makes this game more immersive and beautiful than a wider FOV! :heart:

6 Likes

Yes it;s a welcome setting but until the screen can be ( globally ) brightened up it’s only good for a limited number of games ,
the 120 Hz normal mode and steam ss 100% runs fine on my 1080ti
120hz small fov and steam 150ss runs ok too

I did find that any extension cables both usb3 and dp messed things up a bit

1 Like