Obduction 1.8.0: Promising Update (PP no longer needed)

issue

#41

Don’t you miss the flipping hour glass? Lol


#42

I miss the days when I thought to myself: “It’s a complicated task which is going on, so it’s OK to wait a long time for it”. I don’t really feel that way any longer… :smiley: Spoiled by Linux/UNIX for years… :wink:


#43

Indeed. Though Windows did finally reach quite an achievement on install bar (somewhat accurate estimate on time left) lol

Though do miss some of the bling w95 had.


#44

Yeah… :slight_smile:

Looks like I’m almost there… :open_mouth:

image

EDIT: Windows updated. Same issue… Crap… :thinking:

image


#45

Im going to try it right now and see what I get.


#46

@DrWilken I’ve also reported it to Cyan support as not working on Vive so we will see what they do about it.


#47

Thanks @tonka. I’ve gotten a reply from them and offered them to help out with debugging if needed.

This is what I wrote (it was before others confirmed the issue but after @brian91292 said it worked for him:

I wanted to try the new update the other day as I read that You had
updated to UE 4.21.2 which means we no longer need the “Compatible with
Parallel Projection” (which is a hack for games not supporting canted
displays) option enabled in PiTool, but as soon as I start a game (i.e.
leave the menu) all I see in the headset is a black background.

I read on Steam that others have had this issue way back in time so I
though I would ask You if You know what caused it?

I created a thread on Pimax forums regarding the issue, but it seems
it’s something on my setup causing it as at least one other can run the
game without issues on latest PiTool version, latest SteamVR beta and
Obduction 1.8.0.

Link to thread:
Obduction 1.8.0: Promising Update (PP no longer needed)

Let me know if You need any debugging info from me?

P.S. I’m a backer of Firmament too. Love You work (since first time
seeing my dad and uncle playing Myst on my uncle’s Mac)… :wink:

And their reply:

Hello Christopher,

Thank you for contacting Cyan Support.

Virtual Reality still arguably being in its infancy (and making great strides as it is), not all VR devices are supported by all VR games. Our development team is always watching new tech developments, and we are continually looking to integrate as many platforms as possible.

As the Pimax is not officially supported VR hardware for Obduction ( no word on if it will or won’t be for Firmament yet ), we have not investigated this issue further. However, we’ve forwarded your notes to our developers for review.

We do not know what caused the issue for the Pimax, unfortunately. We’ve seen some users in related forums comment they were able to get that hardware to work, but we have no details on how or why it worked for them.

We’re sorry we don’t have more news to share in this case.

BTW - Name is Christian… Not Christopher… :wink:


#48

Last night the game started to do the black screen thing on my Index, too, by the way, after having worked fine the night before…

Game still renders and displays on the desktop mirror window, and I can actually see a thin sliver of the view peeking out from behind the bottom of the occluding grey rectangle that seems attached to the viewer – still wondering if that rectangle isn’t the thing that fades you out if you go out of bounds.

…and right now I went to launch the game, and suddenly it no longer lists in Steam as a VR game, and no longer opens the launch option window; On the contrary, a window opens to claim to my face that the game has no VR support at all. :stuck_out_tongue: Menu environment still views as expected in the HMD, though, and takes index controller input… :7


#49

Wow… :crazy_face::grin:

Maybe the game will fix itself (after a SteamVR update or two)…? :roll_eyes::smiley:


#50

@jojon I had exactly the same as you, no longer recognized as VR game. I reinstalled the game, no choices at launch but it did start in the headset, still black screen unfortunately.

I don’t know what they have done in this update.


#51

As far as what categories games sort into in Steam: Isn’t that all down to what tags the developer attaches to their titles?


#52

I still haven’t downloaded it off of GoG yet. But if I recall right didn’t it need a commandline option?

I know distance & I think Ark require a launch option.

With the update may need a commandline switch.


#53

You’re absolutely right. It no longer shows up in the “VR” part of my library and doesn’t ask which mode to launch at start any longer. Guess that somehow happened without a game update. Wasn’t even aware that was a thing, i.e. changing stuff like that without an update being installed (unless Valve pushed something in an update I didn’t notice)… :slight_smile:


#54

Could it be because they’re using proximity sensor data to decide when to show something in the headset? If that’s the case, wouldn’t that result in no image shown as the Pimax has no sensor?

EDIT: I have written to Cyan support asking if that might be the reason (i.e. if they use proximity sensor data)… :wink:

Pimax really should do what I (and probably many others) suggested a long time ago:


#55

But they do display the main menu and the menu help info.


#56

I know, but it might only be something they do in-game perhaps? :wink:


#57

Also I have exactly the same problem on my Vive and that does have a proximity sensor.


#58

(Incidently, the reason I wrecked my Vive, was that I was opening it (again), to plug the proximity sensor lead back in (left out when doing a previous mod), specifically so that I could keep playing Obduction, after they added the auto-pancake/VR-switch feature. (some glue had dibbled onto the SMD components halfway along the way on the right eye display flex ribbon, and through it, they ended up more attached to another part, than to their designated PCB - it was not a pretty separation… :P))


#59

i the steam client you could try right klick on the entry, maybe there are 2 additional start options for steam vr and oculus vr (beside the normal start option)
same place has has uninstall option, you can try this too to make it reappear as vr game
does work for me now, i started it from steam vr home


#60

I just received this reply from Cyan:

Hello Tony,

Thank you for contacting Cyan Support.

With Obduction’s latest update, if your VR equipment is all connected, the game should launch in VR. If any piece is not connected, you may not see it launch properly.

Please verify all your VR equipment is connected and powered on and try launching the game again.

Thank you,

When I tested with the Vive I only used 1 controller which was connected to a dongle as I didn’t want to re-pair my Pimax controllers so maybe that was the reason that the same problem occurred.