Obduction 1.8.0: Promising Update (PP no longer needed)

issue

#61

So it seems it might be related to the Pimax missing a proximity sensor.

This is what I wrote to Cyan:

Hi again Lloyd.

I just had a thought. Are You using proximity sensor data to toggle headset display image on/off?

If yes, that might be the reason why it doesn’t work in the Pimax headsets as they have no proximity sensor.

If this is the case, I will suggest to the Pimax devs that they fake proximity sensor data using their gyro (to sense if headset is being worn (moved))… :wink:

And the response:

Hello Christian,

Yes, that’s essentially how it works, assuming the headset works as expected. Some headsets refuse to pick up on the signals if they have no sensor.

Let us know what you learn if you reach out to the Pimax devs.

@Sean.Huang or @Doman.Chen: Would it be possible to “fake” proximity sensor data for games that rely on it to show an image in the headset like suggested earlier?

If You can’t use the gyro for it, maybe just make a toggle for it in PiTool to let games/programs think it’s always “on” (i.e. headset is being worn).

It might be why there’s no image in-game in Obduction 1.8.0.

If You don’t think that’s the issue, could You try to run the game and see if You get any valuable debug data? The issue is there’s no image in the headset after starting the game but You can see that the tracking works when You look at the monitor and move the headset.


#62

why does it work on my system then? my 5k+ does not have a proximity sensor
maybe old settings from using a vive are somewhere?
might be worth trying to delete
C:\Users%username%\AppData\Local\Obduction
and start fresh


#63

I have no clue, but I was thinking the same thing. Might be a SteamVR setting some of us have set or leftover “hack” or something. Even uninstalled ReVive as I thought that might have something to do with it.

EDIT: Deleting the Obduction directory in

C:\Users\USERNAME\AppData\Local\

didn’t change anything sadly.


#64

Maybe this is not specific to Obduction but something else.

I’ve seen a few people recently have issues on Vive’s, Indices (black screen on startup) on Dirt Rally 2 (mentioned on VoodooDE’s YouTube video about VR feature in DR2) and other games (don’t remember which) so it might be a SteamVR or engine issue ?


#65

After the new update… still no joy…
Acts the same as before… tracking works but no image in the headset… only the monitor…


#66

Yeah, not sure how this could be true. I haven’t messed with my SteamVR configs/installation at all, and Obduction works fine. I’ve also reinstalled Windows since I got my Pimax, so there’s no chance any leftovers from when I had the Vive are still present.


#67

There’s another patch (1.8.1):

Thank you everyone for your feedback on Obduction’s latest update! Reported issues addressed in this patch are as follows:

Improvements made:

  • Fixed issue that caused you to strafe and turn in VR Free Move mode.

  • Fixed the large stone stair sphere in Hunrath. It now rotates as expected.

  • Controller note: In Teleportation mode, both left and right controllers can be used for turning. In Free Move mode, only the right controller will turn.

Known issues:

  • If you run into an issue where you cannot move, you need to delete your Input.ini file and run the game again. This file is located at…

  • Windows: %LocalAppData%\Obduction\Saved\Config\WindowsNoEditor

  • Mac: ~/Library/Preferences/Obduction/MacNoEditor (Use Command+G to type in the path.)

  • When using smooth motion input with Windows Mixed Reality motion controls, a movement ‘drift’ can occur. We’ve found this is a common problem. If this happens, open up the SteamVR Input configuration for Obduction and add a dead zone to the left joystick “move” input.

Doesn’t look like they’ve fixed the issue were facing, but I’ll give it a go in a few minutes… :wink:

EDIT: No dice for me. Still black screens in HMD but tracking fine when viewing on monitor.


#68

I just tested it too, and got the same result.


#69

I have no idea if this is relevant, but I looked around in the config files for the game and found a selection of .json files in the folder \Steam\steamapps\common\Obduction\Obduction\Config\SteamVRBindings

The file vive.json contains the following code:
“name”: “Default bindings for Vive Headset”,
“controller_type”: “vive”,
“bindings”:
{
“/actions/main”:
{
“sources”: [
{
“mode”: “button”,
“path”: “/user/head/proximity”,
“inputs”:
{
“click”:
{
“output”: “/actions/main/in/SteamVR_Proximity”
}
}
}
]
}
},
“description”: “Obduction”

Maybe someone who knows better can say if something can be edited here to avoid the problem of the missing proximity sensor…


#70

Nice find… :+1::wink:


#71

Same problem here.

last steamvr NO beta, 2080ti, pitool 180, windows 10


#72

Okay just finally Downloaded Obduction from GoG Galaxy.

Ran it to my surprise started in VR mode no issues.

Pitool x1.0 FoV Normal. SteamVR Auto non Beta
W10 r7 2700x 1080ti

Plays fine but first game I have felt somewhat off in. May need to tweak settings quite demanding only have gotten stable around 40fps. Looks really nice though.


#73

I gave it a go here and got black headset but perfect on the normal monitor :slight_smile: sigh.


#74

Try loading in Desktop mode. RdToVR said goto Setting More & choose VR

When it loads only on desktop does Steamvr Launch? If so while no pic in headset does it track?

I am loading mine from GoG Galaxy as importing to pitool doesn’t seem to work for me.


#75

It shows in the headset until You start a game (i.e. the menu shows normally in the headset).

When You have started a game, You can see on Your monitor that tracking works (when moving/turning the headset).

In short (as stated earlier): Image in headset is turned off for some reason, that’s why I’m thinking it could be related to the missing proximity sensor and if You look at previous comments it could seem that way, but I’m not sure as it works for others… :nerd_face:


#76

Psst I don’t have a prox sensor either.

I think we need some settings files to compare. As I & @john2910 have it working fine in pimax.


#77

Thanks. Will try that on the weekend when I’ve next got time free. :slight_smile:


#78

I know, but I don’t see what else it could be… :wink:

How are You starting the game?

Do You have or have You had ReVive installed?

I’m sure it must be some leftover config somehow (SteamVR, Nvidia Control Panel, Windows, PiTool).

You never had a Vive, did You?


#79

No Vive. No Revive.

Launched from Gog Galaxy with pitool running Steam running (but didn’t have Steamvr running)

Didn’t even have to follow imstructioms from RdToVR to get it to launch into vr.


#80

So You’re running Oculus mode without SteamVR?