Pc dosent recongnize pimax 4k


#1

My pimax is now 2 weeks old and have been working allright for the past time but nowout of nowhere my Piplay cant recongnize my Pimax ? i havent updatet the sodfware or any drivers on my pc or anything so i find this odd…
Anyone have same exp ?


#2

@Community @Pimax-Support @PM_Sean

Could you provide the following?

Pc specs
Windows Version (7 or 10)
Cpu/ram
Gpu/driver version
Piplay version & Firmware version
First 3 serial numbers of headset ie “100”

If you recently updated graphics driver; reinstall previous version.


#3

Operating System
Windows 10 Home 64-bit

CPU
Intel Core i7 5820K @ 3.30GHz
Haswell-E/EP 22nm Technology

RAM
16,0GB Unknown @ 1198MHz (15-15-15-35)

Motherboard
ASUSTeK COMPUTER INC. X99-A (SOCKET 2011)

Graphics
BenQ XL2720Z (1920x1080@60Hz)
Philips 273EL (1920x1080@60Hz)
2047MB NVIDIA GeForce GTX 980 Ti (ASUStek Computer Inc)

Storage
232GB Crucial CT250BX100SSD1 (SATA (SSD))
931GB Seagate ST1000DX001-1NS162 (SATA )

Optical Drives
TSSTcorp CDDVDW SH-224FB

Audio
Realtek High Definition Audio


NVIDA GrForce GTX980 TI
Driver Version: 24.21.13.9836


Piplay Version: v3.0.0.81
Dr.Pi Version v1.0.0.12Reminder


Dont quit understand the serial number thing my english aint the best but do you want the first 3 numbers after the number 100 ?


#4

First 3 numbers of serial

Example
100 is the 4k model (38402160)
102 is the BE model (2560
1440)

The 4k is likely what you have. Awesome detailed setup!

Was there any recent updates/install just before it stop recognizing the headset?


#5

yea first 3 is 100 so a 4k model.

i havent updated anything big, did a java update and install NVIDIA GeForce Experience thats it,


#6

Yeah that doesn’t sound like anything that should have caused an issue. But possible 1 of the 2 installs may have caused an issue.

Was Piplay version your using the same version when it was working before?


#7

yes it was the same version. i will try and reinstall since my AVG just tryed to block piplay


#8

@xzl

i have seen that even your USB is not recognized in the connection page.
So first of all, you should make sure the USB connection is no problem.
after you incert USB cable, you will find a new HID compliant shown in device manager on PC.

Cable connect:

  1. HDMIcable directly inserted into HDMI port of computer independent graphics card
  2. USB cable is inserted directly into the USB port of the computer
    Helmet status:
    What color is the LED on the helmet after the connection?
    Blue: normal connection state
    Green:Please check the HDMI connection
    Red: Please check the USB and HDMI connections. Replace the USB port to re plug.
    Display card driver:
    please download latest driver:http://www.nvidia.com/Download/index.aspx
    Piplayinstall:
    When installing, anti-virus software / all kinds of security software must be turned off.:
    If the installation is not closed in time, please completely uninstall piplay and reinstall it.
    piplay download address:http://pisetup.pimaxvr.com/PiPlay_Setup_3.0.0.81.exe
    if you still have problem, please leave your teamview id and password, We could book a time for remote control help, and our available time is 10:00 to 18:00 Beijing time.

#9

Ty so much guys for all of the fast help. I uninstall Piplay and install it agian and now eveything works.
The only issue i have now is how i get Pimax 4k to work whit firefox VR