Pimax 4k ghosting problem on head moving


#1

Hi Guys,
First of all sorry for my english :sweat_smile:
When i move head,
I have a sort of ghosting, like seeing double :scream:

To make me understand better, here are some pictures:

Head stationary:

On move head:

How can I fix it?

Thanks :heart_eyes:


#2

Buying another brand of hmd


#3

Very helpful … another brand user’s complain of screen door, blurriness, lag… lol


#4

Yep. So far no hmd is perfect.


#5

Other thread mentions need 60 fps to reduce // stop the ghosting ?


#6

I get this too. It is for example clearly visable in virtual desktop on the edges of explorer windows but only when turning my head. There’s no ghosting/judder when not turning the head but quickly moving the window around with the mouse. Makes me think it’s not an hardware problem but another software issue.


#7

The refresh rate is 60hz.

The recommendation is 90+ and a tall order even for an 1080 Ti, currently.


#8

Hi Fabian,
Thanks for reply. I agree with you.
This problem occurs in all games (Steam VR, Video Mode) and only when moving head.
It is not a FPS problems. Also in movies with the stationary head the problem does not occur.

Pimax 4k was tried on two different PC (Intel i7 + AMD RX 480 + SSD, Intel i7 + nVidia 1080 GTX + SSD) but with some result.

With oculus and vive (Tested on Intel i7 + nVidia 1080 GTX + SSD) no problem. :rage:

At present Pimax is valid only for 3D videos.


#9

Yeah they use OLED screens, that’s why. LCD has way more latency, hence the ghosting.

It’s a downside of this headset. Yet the 4k screen solves the screen door effect. I don’t like Vive or Oculus at all, the SDE is way too much.

At present there’s no ‘perfect’ headset, each headset has its pros and cons. Unfortunately it will take a while before better headsets appear in the market. For now I like PIMAX the best.


#10

That’s not the problem, since this ghosting effect doesn’t happen on the Gear VR platform, where the phone’s display also only operates in a 60Hz low-persistence mode (motion blur is still detectable, but it’s a different and more subtle effect than what has been illustrated here).

As sjefdeklerk has stated, it’s the LCD display that is the culprit. They can’t really pull off a proper low persistence mode the same way that OLED displays can, regardless of the refresh rate.


#11

Agreed, the screen display in the Pimax 4K is not fast enough to keep up but the 60hz still feels slightly off in certain titles.


#12

Hi. I have now two pimax headsets. sn102xxxx (this i got earlier) i tought that i broke it but got it fixed. i allready orredder new one. this new one is sn100xxxx and it have awfull ghosting problem.
sn102xxxx have no ghosting but maybe littebit screendoor effect.

but still i put sn100xxxx back to its box, maybe i try to sell it for someone.

does sn100xxxx ghosting get anvy better in time (maybe screen heats little and get better)
I only did very short test. just plugged it in an ran unity chan demo, watched it about 15 seconds and that was enough for me.


#13

The same problem, is this is normal? any solution? its look very very bad :frowning:


#14

the sn 100, model there will be some ghosting as they are using LCD screens which cause ghosting… The latest piplay is optimized as much as possible at this stage on ghosting.

Also using the older 1.1.92 drivers that utilize steamvr compositor has better ghosting algorithm although pimax support says that the latest piplay is comparable to 1.1.92 version.

Eno


#15

Does version 1.1.92 have the Brightness control?


#16

Hi stixvr

You have to use the debug tool in piplay to set the brightness. To be honest I have not needed to change my brightness since setting it months and months ago.

You can find the brightness debug codes in this forum if you search for it

Eno