Pimax 4K Headset issues - Blue/Green screen, ghosting and modes)


#1

Good morning or afternoon :slight_smile:

I have received my 4k headset and been running it and testing games in steamvr for the last few days without any problems, however, most recently having the following issues, system specs are below:

Hardware:
*Windows 10 64 bit (most recent update)
*Processor: Intel i7 PU 920 @ 2.67GHz (overclocked to 4.24 Ghz)
*Ram:32 GB
*Graphic card: EVGA GeForce GTX 970 4GB SC

Software:
*Pimax (Piplay)
*SteamVR
*Oculus Home
*Revive

Issue#1
For some reason now, when I enter the (steamvr) home or any games my headset has an overlay tint (top blue and bottom green). I have no idea whats going on, i have tried resetting everything in iplay, running room setup in steam a few times and I am running the latest firmware and software versions.

Issue#2
No matter what game in iplay or steamvr I have really bad ghosting effect when moving my head around. Is this due to my system configuration. I did purchase some updated components for that I will be installing soon:

*Intel BX80684I78700K 8th Gen Core i7-8700K
*Corsair LPX 32GB DRAM 3000MHz
*ASUS ROG STRIX Z370-E GAMING motherboard

  • EVGA GeForce GTX 1080 Ti FTW3

Do you think this will fix the issue? Anything else I should be doing to reduce this effect.

Issue#3
When I am launching a game in steam at times the headset does not show anything and is black, I have to switch it to extend mode and back to pimax mode in order for it to work.

Can you please help me figure this out.

@Pimax-Support


#2

Hi @jcdionne, regarding the situation you have met, we suggest that you may manually update the Graphics card. Please be advised.


#3

I have tried uninstalling the graphics card driver (using a deep uninstall tool), then downloaded the latest driver from the manufactures website. Did a new install and still having the same issues. Are you staying that all three issues can be caused by my graphic card or drivers?


#4

Try using the previous Nvidia Driver. @Enopho is a 1080ti user as well & may know some tips/fixes.


#5

I can’t tell you if those new components will fix the colour separation in your hmd but will most defiantly make it run smoother!

the best Nvidia drivers to use are 384.94 July 2017 ones. They have the best performance with the 4k. The latest Nvidia drivers cause micro stutters even on the 1080ti cards.

But to be honest I have not seen the colour separation before.

Regarding switching from extended to pimax. I don’t need to do that, but I do need to unplug USB and plug back in again if the hmd light is red rather than blue, this usually happens if I have had a windows update… But I only have to do it once so it’s not a big deal.

Regards

Eno


#6

Ok, well I will update my pc and hope it will fix itself. The blue and green colors are almost like a film has been added to the lens and has a perfect horizontal line running across the screen. Almost like if I am running a calibration mode or something along those lines.


#7

yea… that’s not normal and i have never seen it… can you take a photo of it possibly? maybe someone else on the forums might recognise it if they can see it?


#8

@jcdionne sometimes, very rarely, the blue/screen issue you mentioned, it happens to me too when I plug my 4k before start Piplay software or if I forget to disconnect it before restart windows, but a plug out/plug in solves the problem instantly.
Anyway I use a laptop with a 960m with latest nvidia drivers


#9

Also not sure if you could help me but just got a 1080 ti card installed it and when I go to try to switch the 1920x1080 OFF, which would be a huge improvement in quality the headset goes black / no image. Both HDMI and USB shows connected. When I switch to video mode I see the desktop in the headset but green pixels all over. Can anyone please help…

@Pimax-Support


#10

@jcdionne Try to uninstall pimax from device manager(generic PnP monitor under monitor menù) and than reconnect it with piplay software opened. If it doesn’t work, try again to uninstall pimax software and device from device manager and install it again.

Another possible cause for your problem could be caused by the use of an adapter with 1080p max output, so you can try to connect 4k directly to your gpu


#11

Hi, as per the situation that you have met, we suggest that you may manually upgrade your Graphics card and reinstall the Piplay software. In addition, you may plug again your HDMI and USB cables to your PC. Please be advised.


#12

I have resolved the Green / Blue issue but still getting a lot of ghosting even tho I am running two 1080 ti in SLI cards. Is there settings I should be looking at to reduce this effect. I understand that this is the downside to this headset and I will not be able to totally remove it. But I just want to ensure I have the best settings for my video cards. Can I please get some guidance on this topic. If I open up my Nvidia control settings where to start?


#13

@Pimax-Support

Unfortunately to reduce ghosting we need an option to adjust shutter timings.

Now for potenial download Unity Chan in piplay (its well programed)

Games with moving backgrounds are decent with ghosting.

Depending on the game @Enopho may have some suggestions.


#14

Will this be part of a future update ? Be nice if pimax fixes this issue would make the experience amazing. I notice it big time in steam VR home


#15

Hopefully should be in an update. Though atm were on wait while they try & get the 5k/8k ready for release. However they do really need to give us some kind of quick fix in the meantime as they are still selling the current 4k & this issue could serve to taint folks opinion against future purchases… Even though i can say from trying the 8k with the new display tech that ghosting is not present.


#16

Agreed, pimax think of your current customers that back your brand. A fix would be a big step forward and help us promote your current and upcoming products to others. Specially first time users.


#17

The ghosting has always been an issue with the 4K. Even now i am holding my breath in the hope that Pimax devs can come up with a new algorithm, although the last post many months ago from @bacon seems to suggest that they are already at the best it can be.

I do find that if there is video driver latency or micro stutters in game (which can be caused if you are using the latest nvidia drivers) then dropping back to the July drivers from Nvidia makes a huge difference. and also that being said the latest piplay version is pretty much as good as the good old stable 1.1.92 driver (and me being a long time fan of that version… its hard to admit it!)

regarding the SLI version of GTX cards, I do have 2x1080ti’s but 1 card in 2 pc’s so i might just try using 2 in SLI… i know of VRWorks from Nvidia where 1 of the SLI cards runs the left eye and the other card runs the right eye https://developer.nvidia.com/vrworks/graphics/vrsli
but i have never tried it myself and i dont know if Pimax can utilize it… there always seems to be a ‘it cant work in pimax’ type answer… i.e. ‘direct play’.

and to be honest i already run my go to game Elite Dangerous in VR Ultra and Piplay SS at 3.0 already on a single Aurous GTX1080ti and its buttery smooth… unless i use the latest nvidia drivers then its soooo bad and the stuttering makes me want to throw up!


#18

Regarding the ghosting issue with the 4K, it did exist. However, this issue can be solved in our new project, it is estimated that it will be listed in April. Please stay tuned with us.Thank you!


#19

Hello @Pimax-Support can you please elaborate on this new project? as it is the 1st time we have heard about it. and ghosting on the 4k is one of the biggest issues we have. if you have indeed resolved the issue can you tell us if this is a hardware mod of a software patch of some kind?

any info would be great at this point.

thanks

Eno


#20

Hi Eno, sorry for my unclear reply above. Regarding the ghosting issue, the engineers are utilizing the spare time from 8K project to fix it through software and hardware, we will let you guys know more details soon. :slight_smile: