Pimax 4K - I can not connect my Pimax via HDMI


#21

That’s right, I had it plugged on the second pci-e bus to get a little bit more space between the CPU heatsink and the back of the card so it would breathe. I don’t know if it was running at x8 or x16, but I benchmarked it on both and couldn’t see an impact in performance, so I plug it on the second.


#22

Hi Antonio,

I believe that the pci slots should always be filled from the nearest slot next to the CPU as that will be the fastest one. If you have multiple slots like on a gigabyte motherboard the gpu will fit in other pci-e slots but may be limited by bandwidth restrictions on those slots… I.e pci-e x16 in a pci-e x4 the gpu will only run at x4 speeds.

It maybe a restriction of pimax 4x requiring a x16 slot?

Glad you got it working though!

Eno


#23

That’s the way it should be, but running at x8 instead of x16 doesn’t penalize performance (x8 transfer speed is around 8000MB/s @ pci-e 3.0 specification), and getting the card space from the CPU heatsink meant I could point a fan to its backplate to help with heat dissipation. If the performance wasn’t impacted then I don’t think the Pimax wasn’t getting the signal because bus limitations, but maybe bus number matter in regards to what’s consider a primary display adapter, like, for example, I have read in multiple threads that if your mobo has an integrated hdmi port, you should disable the integrated GPU in the BIOS so it doesn’t cause conflicts running the HMD… I don’t know, go figure!


#24

It’s likely looking at bus locations & not seeing the vid card due to being in slot 2 or 3 instead of one.


#25

When your headset is having green light,then try looking into the lens whether you can see the desktop.

If you can see just the desktop wallpaper in pimax, it means that the PC is treating pimax as a monitor.
If that is the case then try this solution.

(for win 10)
Go to your display settings and go on multiple displays section.
You should see 2 displays named as 1 and 2.
There go to multiple displays section and go to advanced display settings,disable the pimax 4k and then restart the pimax without touching the USB or HDMI cables(Hold power button for 7sec).
I did the same in my case and it gave me message that pimax device is connected.

Please reply if this works for you otherwise contact support.