Pimax 4k not working since nVidia update


#1

Pimax is now only recognized as 2nd monitor.
Anyone had this problem and found a fix?

@Community @Pimax-Support @PM_Sean


#2

If using the latest piplay version 85 reinstall 71.

@Enopho can tell you most likely if new Nvidia driver good or not.


#3

@flexodood please post what Nvidia driver you are using and what piplay version you have and I will test it tonight when I’m home

Eno


#4

I installed yesterday 416.16 version on Nvidia drivers. I’m using 1.1.92 Piplay. Everything is OK.


#5

both latest…
but i found another thread with this problem…
http://forum.pimaxvr.com/uploads/default/optimized/2X/e/e28d4a946cbac675a13f87b92105b8d35a62f853_1_544x499.png
(posted by “3D_FAN” in HDMI/DP not connected due to piplay software issue)
sadly no working solution. but it doesn’t seem to be the driver.

i already tried reinstalling piplay (updated from the old version hosted here…)
and the “fix” posted at the end of the thread…

edit:
just uninstalled and deleted everything pimax-related and reinstalled, tried older version, updated… no luck


#6

What version of Windows & what is your hardware config?

Try installing previous piplay to latest version; don’t update to 85.


#7

fx 8350
gtx 980
win 10

i installed 2.07 and updated. the older versions had the same problem.
just tried reinstalling the gfx driver (clean install)

how?
isn’t 85 the latest?


#8

Some users are experiencing trouble with the latest version.

Is klite the version that came with piplay?


#9

i will uninstall klite and reinstall piplay

i didn’t have issues when i first updated to 85 though… only after nvidia driver update.
will try a rollback after.


#10

ok, 2.07 is terrible too

dual screen while steamvr is running on a “virtual screen” on pimax and main desktop is gone.

trying 71

edit:
71; same old problem… only dual screen, no steamvr

can’t rollback nvidia driver since i just did the “clean install”

i might reinstall the driver but nobody else seems to have a problem with the driver so i suspect something else.
but it can’t really be hardware since the gyro was working in 2.07


#11

Eno said he will try new Nvidia driver. It is possible Nvidia driver broken…i had that issue a whilw back with amd.


#12

but i’d expect much more responses to this thread if that was the case…

and TForm4 said he’s running the latest driver… on an ancient piplay though…


#13

That version of piplay is very different than newer versions


#14

Never seen this problem …


#15

i am installing latest nvidia drivers now to test for you…

Eno

------------------- Update ---------------------

I have installed the latest nvidia drivers on both test machines and can confirm that Pimax 4k works on both after the update… that means it works on 1.1.92 (steam compositor version) and 3.0.0.85 (latest piplay version)

i had no issues with the nvidia installation on either machine and tested using unity chan. both played fine.

Eno


#16

@flexodood

hi,we have made a try for you and connected with 4K successfully by Piplay 3.0.0.85 Nvidia driver 416.16


#17

ok thank you guys, i just tried 1.1.92
it’s stuck at “Searching devive…” and green led.


#18

That is quite normal for that version. Usually requires a few attempts of plug in & unplug replug.

New versions are best for connectivity.


#19

Try unplugging hdmi on your discrete GPU and then plug it back in.

Also plug the USB into another slot.

Eno


#20

tried unplugging a few times…
just gave up on it and reinstalled windows.
running 1.1.92 right now in assetto corsa competizione…

can you tell me which version has the best scaling of objects?
the car/cockpit is just huge. last time i played rfactor 2 in the newer versions i had the same issue.
will just have to try the 85 again i guess, hopefully i don’t break it again.