Pimax 4k not working since nVidia update


#21

Not sure I think @industria @CMM @jonnypanic @Enopho might know(think he still has the old piplay on one system & new one)

It’s been too long for me since used 1.1.92. Quality wise visuals are said to be equal with pi render being potentially better.


#22

the newer version of piplay has the best scaling now in my opinion, and the ghosting on both old and new are very similar. but that game your using has got some issues with performance, as detailed in @SweViver youtube video - admittedly he was using the pimax 5k+, but even so, its not really optimized for VR at this stage, he even said that in his test he felt like he was virtually on the dashboard as the FOV was not right. it is a alpha version.

try running something like unity chan, war thunder, ABE VR, DCS, No Limits 2, (all free for you to try) see if they improve the scaling.

Eno


#23

there’s no way to keep both versions installed, right?


#24

1.1.92 & latest no not that I am aware of.

Pitool that Pm_sean posted might be able to be installed alongside.

But you might need to launch taskmanager & kill pi services & piplay/pitool before launching either.

Eno reported above your post on pros & cons of using pitool (mainly ghosting is stronger in pitool)


#25

yeah, so i installed 85 again and can’t get it to switch to pimax mode.
on a fresh windows install just uninstalled 1.1.92 and updated from 2.0.7.54.

@Pimax-Support @PM_Sean


#26

Hi I had this issue when first installing my headset, it was a driver mismatch. Was using psvr at first. Your device is probably showing in device manager as rift p12, you need to update driver, search comp for driver. Not sure what driver named but it was bottom. If all goes OK device should now show as rift p2 and all connect properly.


#27

Add driver is named hidusb


#28

can’t find anything like that in device manager.

but i get it running now with multiple reboots and reconnects…
but it is still active as a second screeen in windows which is quite annoying sometimes. and when i turn it off it’s a gamble if it will work again when turning it on.


#29

\Steam\steamapps\common\SteamVR\drivers

Delete the pvr folder if it’s present.


#30

I had problems with the 4xx.xx drivers. My 4K got blue light, but showed disconnected in Piplay. HMD screen turned on via sensor but just gave black screen. Reinstalling same drivers without the HMD connected gave same results. Reverted back to 399.xx drivers and it once again worked perfectly.


#31

PiTool v1.0.1.76 works great for me!


#32

What drivers are we talking about?

Im having same problem


#33

@Enopho reccommends dialing back ro something like 398? As Nvidia seems to reducing performance in the 10series carda since tye rtx carda have been released.

@SweViver said he noticed the same earlier.


#34

Basically al 400 series of drivers (the ones released after the 2K RTX card release).
399.24 works fine here.
Dunno what to do if you have a Nvidia RTX card, you probably need the 400 serie drivers for it to work properly.


#35

416.34 has been working on my side.

Piplay 1.1.92 & PiTool 1.0.1.90.


#36

does it require piplay now? last time I tried upgrading it didn’t work…


#37

No, it worked with either or and only one was installed at a time.


#38

…?

as of now it works ok. if it doesn’t i have to reboot while the pimax is turned on. turning it on wile pc is running causes the connection-problem everytime.

it is still running as a second monitor in the background though and i had to lock my cursor with “dual monitor tool” (and to recover windows hidden “behind the pimax logo”) as a workaround.


#39

could you or anyone name a source for this?


#40

Simple independent tests. @Enopho for example has 2 identicle setups with 1080 ti & often uses them to test Drivers side by side & noted since the 400 series driver a drop in fps on ED.

@SweViver also noticed a drop in fps on his 1080 ti as well. Of course there is many other compares on the internet promoting both scenarios.

Best is to test for yourself & come to your own conclusions.

It’s possible that fixes for tge 20series has degraded tge 10series by introducing new bugs. But iften driver code will often start to favour newer versions of hardware architecture. Though this usually comes much later when they are prepping the old to be classed as legacy or end of life.