Pimax 4K screen is displayed on monitor instead


#1

Hi there, I got my Pimax 4K yesterday and I did the installations as guided. I got it to work fine and was able to enjoy a few hours of VR playing on Steam.

However, I’m facing some issues today. The game is displayed on my monitor instead of the Pimax headset, and when I move the headset around, the monitor seemed to reflect the position changes.

I tried exiting the game and starting up the IPD adjustment on PiPlay and it was the same, there was no screen in the Pimax 4K but a light shade of blue. At other times, the Pimax logo is displayed in the headset. (And yes, I do know that you need to wear the headset to get the screen to turn on.) I’ve restarted my machine multiple times to no avail and the result was the same. Booted with headset connected, booted with headset disconnected, didn’t work. Switched from Pimax mode to Video mode and back, didn’t work. I tried uninstalling PiPlay 3.0 and installing v2.0.7.54. Didn’t work. Upgraded back to 3.0, still no. I updated my graphics driver as well. Result was still the same. Reinstalled Steam VR (though I don’t think that’s causing the issue here), and as I expected, nope.

I’ve tried various ways to get it to work again but it just wouldn’t show on the headset again. Can I get support to help me on this?

CPU: i7 3820 (Windows 10 Pro)
RAM: 16GB
Graphics: GTX1060 (Driver version: 397.31)
Headset firmware: v1.0.0.265
PiPlay version: v3.0.0.71
I have my Pimax 4K connected on the first HDMI port of the graphics card (the one that was recommended for VR headsets).

@Sean.Huang @Pimax-Support


#2

Hi, Welcome to the pimax forums.

Sorry to hear your having some issues getting your headset up & running.

I had the issue you described but with an Amd gpu. What ended up being the issue was Amd driver update.

I would reccommend try installing the previous Nvidia driver. I know @Enopho has mentioned one of the newer driver was not as good in terms of performance. But your reporting a different issue.

Here is a newer guide that may help. Have you tried launching something non-steam in Piplay?

What color is the led on the headset?

Also added pokes to your post & bumped your user level up 1.


#3

I actually get this issue sometimes… Fix for me is close piplay if it’s open… Then force close steam and steamvr using taskmanager, unplug the pimax USB and then plug it in… Restart steam and launch steamvr… Then play your game.

Let me know how that goes.

Eno


#4

Hi all,

Thank you for your help! I’ve tried the above methods and it still didn’t work. However, somehow I got it to work by uninstalling PiPlay and removing all related files in the system (other than registries), restarted my computer and installed PiPlay v2.0.7.54. Didn’t upgrade it to 3.0 as it’s currently working, I don’t want to risk getting it not to work again.

Will keep this thread updated if the issue occurs again.

Once again, thank you everyone!


#5

Awesome glad you got it working.


#6

glad to hear it… at this stage i would not upgrade to piplay 3 anyway as there is additional ghosting and my fps drops about 5 frames in games… i even get ghosting in youtube videos. i would stay with the version you have now … i generally test the new betas when they come out to see there are improvements… and in version 3 the only improvement worth noting is the better laid out UI.

Eno