Pimax 4k, steam vr - big gray box


#1

I am having an issue with the pimax 4k. I am trying to run Elite Dangerous (Steam).

I have 2 systems that can run VR - 1 is a laptop with a GTX1060 MaxQ 6GB, It’s a core i7 and Windows 10 - this machine runs the pimax just fine so far.

My desktop however which is a Core i7, Windows 10 and a GTX 1080 will not work. I launch the game and I can see a loading screen with the elite logo and some bars, then I just see a huge gray screen in front of me and when I look around I see a line almost like a signal of some kind on both the right and left and another huge gray screen behind me - everything else is black.

I installed the latest file I could find on the website PiPlay_Setup_3.0.0.81

I have tried switching modes and settings in steam VR with zero luck. If it helps I have 1 monitor connected to the 1080 via DVI to HDMI adapter and another to 1 of the hdmi out’s and then the pimax to the other hdmi out.

I also own an Oculus and it works fine on both machines.

Would appreciate getting this working.

Thanks,

Tom


#2

@Enopho

Might have an idea. Is it just ED or other titles as well?

Try installing piplay 2.0.7


#3

Hi Tom,

I would like you to screenshot the problem please, also confirm if you are seeing the ed logo in the hmd on on your monitor? i need to see what these beacons are like that you mentioned and how your installation of piplay went? did you have any errors or anything that you didnt expect? warning about klite for instance?

thanks tom… make sure you add @enopho to your reply as im working away at the moment and it sends me an email.

Thanks

Eno


#4

@enopho

Here are a couple of images.


This one is the mirror from Steam VR - it the same, in front and behind me.

this one is kinda what you see when you look left or right, it’s like a scanline - it’s not just white, it’s almost like each screen is shrunk down to a single line one on the left and one on the right of where you looking if that makes sense.

I tried the 2.07 download, same thing.

Tom


#5

Hi Tom,

thanks for the screenshot. can i ask please… the order you launch your game… is it this order?

  1. Open Steam Portal.
  2. Launch SteamVR (icon is top right of steam)
  3. wait for steamvr popup to open.
  4. click on your game Elite Dangerous and choose Launch in VR?

at this stage we wont worry to much about the orientation or the obvious horizon tilt in your image, but is that the order you are launching please?

Thanks

Eno


#6

@enopho

yes that is how I am doing it. I have tried to launch steam vr first, then launch the game. I have tried just launching the game as would when using a rift which is just click play and it asks me if I want to play in steam vr and I have also launched it from the PiPlay library.


#7

Have you tried reinstalling steamvr? It may be an issue on steamvr as the display mirror and steamvr home is not looking right?

Are you on steamvr beta showing the steam ‘home’ or should you be seeing the steamvr gray room with white square floor and room lines?

Did you have any issues with piplay install? Anything that popped up during install that did not complete.

Eno


#8

I’m about to jump on flight so will check forum in 4 hours when I land
Eno


#9

@Enopho

I have not tried to re-install steam vr, I don’t see an uninstall option.

I do sometimes see the “steam room” but my view is at floor level. I have also seen the lines at times almost like a globe and the elite logo with the 3 vertical bars loading but it always goes to the screen I sent images of.

I cannot try until later today but I will look into uninstalling and reinstalling steam vr.

Thanks for all the help so far.


#10

With steamvr setup you need to set the height during roomscale as the headaet is not positionally tracked.


#11

The roomscale setup did the trick! I did not need to do this on my laptop, don’t know why and would not have thought of that since these don’t do roomscale at least without additional things from what I have read.

Now the only issues I am having is the oculus software always launches when I launch a game and especially what to do when they lose center in game as that has happened a couple of times and that is a pretty big one and then to see if there is a way to minimize the slight “fishbowl” effect on the edges and to figure out how to get the most out of them for clarity - my main game for these is elite dangerous so sightseeing is on the agenda and I want to get it as crisp as possible. My Oculus does not have the fishbowl but it also does not have the clarity these do, for example on a ship with a carbon fiber dashboard looks great in the Pimax, in the oculus it’s kinda hard to tell it’s carbon fiber. Is there a good place to read up on what settings can be used to get the most out of these?

Other than that - I am wondering since I have a dead oculus if there would be a way to put those lenses in front of these screens but that is a whole other subject, right now mainly getting it to recenter in game would be good enough for me.

Thanks for all the help so far!


#12

This link of @Enopho should help.

Eliminate gyro drift pretty much completley


#13

When you use pimax 4k, Check that the oculus rift’s usb is connected to the PC and unplug it.