Pimax 4k steamVR issue


#1

Hi guys,

Can I get some help getting pimax work with steamvr properly? Iwant to use the Pimax as a monitor replacement. I figure Virtual Desktop would be the way to go?

Steps:

  • start Pimax mode in piplay.
  • start steam and activate steam vr.
  • I run virtual desktop, bigscreen
  • then my system slows down, becomes laggy or freezes and I need to restart.
  • The image in virtual desktop gets laggy as well

Can I get some help getting this work?

I also tried to run virtual desktop, bigscreen directly without activating steamvr first.

My desktop system is:
Windows 10 pro version 1709
i7-5960x
32gb Ram
Geforce GTX 1060 itx 3gb

Pimax 4k firmware: 1.0.0.248
I have piplay 2.0.5.46 x64
and latest Steam


#2

What is your Nvdia driver? a recent one apparently broke things - the latest and greatest Nvidia Driver 388.31 makes it a lot better.


#3

Hi, what’s the driver version of GPU you use?
Are other SteamVR contents working well? You’d better check whether the Intel Graphics runs or not in your PC.


#4

Is it a notebook?The graphics card 3g may be the problem i think


#5

Driver version is 23.21.13.8831
I did check multiple times, including restart to make sure only 1 content is running.
I did notice that during startup of Steam. Virtual desktop automatically starts running as indicated in steams library. I probably checked an option in settings that does that during testing.

Can I tell windows to only use the gtx 1060 and bypass any other internal card?


#6

I am indeed using the nvidia driver 338.31(x64)


#7

A desktop pc with processor i7-5960x


#8

During testing I was able to use virtual desktop smoothly for short periods of time by tweaking the image quality render in piplay.

I would:

  • set quality to minimum
  • start steam and virtual desktop
  • then adjust quality to higher settings

I still get an error after 15-30 minutes. Image quality render should not be an issue with the gtx 1060 cards though


#9

Can you please make sure that in steamvr settings that the SS is no more than 1.0. Make sure that Asyncronus reprojection is on and interleaved reprojection is off.

When in virtual desktop check your task manager to see what is using all of your resources and causing lag. Try temp Disabling your Antivirus in case it is interfereing with steamvr.

Set the PiPlay render to low setting to start with.

Eno


#10

I think the driver version is the problem. Now my driver version is 22.21.13.8494.I think you can try it