Pimax 4k v Nvidia GTX960 GPU 'monitor not found' trick fix

fix-guide

#1

I recently got my new Pimax 4k & couldn’t wait to fly in VR. Connected everything up and installed all the recommended Pimax softwares but my pc rig just wouldn’t ‘see’ the Pimax hardware. my rig basically consists of Gtx960 4gb GPU; AMD8350 cpu: Gigabyte 990 MB After hours of Nvidia driver updates, roll-backs, & other efforts I eventually found a trick that worked every time…for me at least. To cut the story short this is my ‘fix’.

  1. Download Nvidia Control Panel software
  2. leave your primary monitor or tv connected to the pc via vga cable
  3. disconnect the Pimax HDMI cable and usb lead from your pc.
  4. get hold of a second monitor or tv with a HDMI port.
  5. connect 2nd monitor to pc via HDMI to HDMI cable & turn on
  6. open Nvidia Control Panel & you should find that the 2nd monitor has been recognised
  7. disconnect the 2nd tv from the pc & reconnect the Pimax headset
  8. close Nvidia Control Panel and reopen it again
    You should find that the Pimax headset is now recognised & you can continue with the set up process.
    I don’t know if this works with other Graphics card such as AMD or Intel, but worth a try if you’re having same issue that I had with mine. Even doing same config process in Windows Display Settings and configuring ‘Extended Monitors’ is worth trying.
    I’m not pc guru by any means & I’m a newbie to this forum so I apologise if anyone has already posted any similar ‘fix’ previously. I just find this forum to have like minded folk who are willing to share experiences with the Pimax. So I thought I’d contribute my tuppence worth & hope someone finds it helps to get their VR up & running.
    If you feel the info is rubbish or crap, then accept my apologies, and please be gentle with any comments…

#2

Hello
I first remove my hdmi connector to the monitor.
Then connect headset and wait for the blue led on the headset.
After this I connect my monitor.
If I have the monitor connected while insert headset the hw will not detect the headset.


#3

Hi. This was my original issue too. No matter what i tried , the pc would not recognise the Pimax as a 2nd monitor. But i disconnected the pimax from the pc; connected my 22inch screen tv monitor to the pc using the vga ports on it & the pc.
Then i connected a 2nd tv monitor using hdmi cable. The pc immediately recognised both monitors but i still went into both the Windows 10 monitor settings to check that the monitor setting was set to ‘extended screen mode’ .
I have an Nvidia graphics card & also I checked the monitors were both being recognised as (monitor 1 & monitor 2) in ‘extended screen’ mode.
Now, if you have an Nvidia graphics card & Nvidia Control Panel installed, to the right of the 2 blue monitor icons theres an option drop down tab with DirectX options: Auto, CPU, or Nvidia GPU.
Select ‘Nvidia GPU’ then ‘Apply’ .

Keep pc running, disconnect the hdmi cable from the pc. Now connect your Pimax hdmi plug to the pc & then plug in the Pimax usb.
So now you should have your tv/ monitor running via the vga & the Pimax running via hdmi. Open the Pimax software & everything should be working & communicating ok.

As i mentioned previously, this method worked for me & i repeated the process 4-5 times to confirm. I found it by trial & error as I’m not a computer expert. I hope this helps. If your Pimax problem still remains i don’t have any further advice to offer, but I’m sure that someone using this forum will help to get you sorted. Regards.