Pimax 4k version and troubles

pitool
issue

#1

Hi,

I have 2 Pimax 4k units (the BE version with serial starting with 102)… I have 2 computers I run these with

The problem is one works great - I have pitool 1.0.0.132 on both PC’s. one of the 4k’s will only work on 1 PC.

The other thing I noted is the 4k that works shows up as Rift B1A, the one giving me trouble shows up as a Rift P1 - both were flashed to firmware v.1.0.0.265

None of this makes sense to me - it makes no sense at all - it’s stuff like this that made me send back my 5k XR unit, a friend sent back his 5k+…

I just want these to work, once that is done I might get another 5k unit but if I cannot even get these 4k’s to work as a mature product it just don’t make sense. I also have had Rift and picked up a Rift S and have zero issue’s with those.

What do I need to do to get these 2 4k BE units both working and with preferably the same software and firmware so they both work on both PC’s regardless - it’s all to frustrating.

Thanks,

Tom


#2

Hey Tom,

Your Pimax are Pimax B1 (Qhd Oled) not the p4k.

If Pitool doesn’t give option to run/switch between Pimax Mode & Video Mode.

You might need to install Piplay to switch the 1 B1 unit from Video to Pimax mode. Then pitool might work on both. (Just guessing tbh) @Enopho might have some ideas.

You may need to also manually reflash the B1 unit not working.


#3

The B1 unit is a different model to the 4k that i have. I am not even sure it uses the same firmware as the 4k? not too mention if the same pitool software works with it as i dont have that unit to test… sorry.

I would check with Pimax support … raise a support ticket and ask them what pitool version works with the B1 model and what firmware is best for it? find out if they have stable versions for that model and if there are beta versions also? start with the latest stable version and go from there.
create restore points before and after each pitool/firmware update, just in case.

i suspect that the detecting of B1A and Rift P1 in windows is down to the HDM config files reporting the device… so it maybe that both headsets might be different generations of the same product.

Good luck checking with Support on this one. I do wish you get a solution to your problem?

Eno


#4

They do use the same firmware. Though at one time had specific firmware for each.

Eno doea pitool still allow p1 (p4k & p1B) switch between Pimax Mode & Video Mode?


#5

No … that was a feature on the Piplay versions. Pitool removed that and made it unnecessary to need to switch.


#6

Thanks for the replies - I guess I will email them - it would be great to know what version of the software and firmware is really recommended - the 2 units are identical, same firmware - same software - even when I plug them into the same PC they show up different - I had a normal 4k and both of these are definitely the BE version and I am wondering if they made more than 1 BE version, it certainly seems like it.


#7

I would Tom if you can boot up the B1 that’s not working in piplay & ensure it is in pimax mode.


#8

Well things get more interesting.

I have tried just about everything, now the unit shows no display at all although the light turns blue… what is really interesting is the unit’s serial number is:10241163003198 as indicated by the sticker on the HMD BUT the software is showing: 10041163003198. I can also tell the difference between the normal 4k and the BE visually and when this worked it was definitely a BE but now the screens don’t light up at all in video or pimax mode - it still gets picked up differently than my other BE… something just is not right here and with the screens not coming on I fear this thing is bricked now… it simply should not be this hard to get 2 identical units with the same firmware to run the same on the same PC… it’s crazy strange.


#9

well the good pimax headsets are hard to perm brick. I wouls maybe manually reflash the firmware. And file a ticket for support.

But yes seems odd to have this much difficulty suggesting a deeper issue.