Pimax 5K+ and Alienware 17 - anyone got it working?

issue

#1

So I got my Pimax 5K+ and was quite excited about the specs compared to my Oculus or Vive. Sadly it’s not working - going to contact support anyway, but I wonder if there’s someone here using it with an Alienware 17 R4 and a GTX 1080.

To make it short - if I plug the HMD to my laptop I get only the red light on the headset. I am using an adapter as the laptop has a mini displayport but my adapter has been reported as working, so I don’t think it’s an issue. I am also sure that the displayport is connected directly to the graphics card. Reinstalling USB ports, other drivers, etc. didn’t help, I even removed the cable from the HMD (which was a pain btw), but didn’t help either.

I was pretty sure that my unit was faulty, but I decided to connect the headset to my old Alienware 18 R2 which is like 6 years old, but Oculus was working fine on it and as it also has a mini displayport I decided to give it a try even though it has two GTX 780M in SLI mode (and this can cause problems). And guess what - to my biggest surprised the green LED light on the HMD appeared just after a few seconds and the headset came to live, with both screens working (even though it was not set to Direct Mode in Steam VR).

As I am using the Alienware 18 only when going on vacation to watch Netflix, etc. and to play some games, I’m not updating the drivers on regular basis. Actually the drivers were really old - I’m not even sure how old. The same goes with Steam VR which even requested an update of the GeForce drivers.

So I did just that - updated the GeForce drivers and… the LED light on the Pimax changed to red and I cannot force it to work again. Sadly I didn’t write down which version of SteamVR and GeForce drivers I used, so I’m not able to revert to check it out. But this gave me an idea.

Went back to my Alienware 17 and I started experimenting with the GeForce drivers. After reverting to some older drivers (older than 417) my Alienware 17 was able to detect the Pimax 5K+ as a secondary display in my Nvidia Control Panel, but… still no green light. Now I can observe (depending on the Geforce drivers) two things:

  • or the Pimax gets detected in Nvidia Control Panel as a secondary display for a few seconds and then it disappears;
  • or it sees it in Nvidia Control Panel, but in Pitool it shows me that the cable is disconnected and thus it doesn’t work anyway.

So - could it be a faulty cable? I’m just not sure as I was able to get great picture on my Alienware 18 before upgrading the drivers. This is why I think it is something software-related and my suspect are the Geforce drivers and Pitool, but still didn’t find a drivers version that work. Any ideas? :slight_smile:

Or maybe there’s sb else with an Alienware 17 who got it working and could share which Pitool, Geforce drivers and SteamVR version he or her is using? Thanks big time in advance!


#2

Which pitool are you using?

Your Alienware 17 R4 have you tried running Nvidia Bios firmware update? It enables DP 1.4.

Your Mini DP adapter is it passive or active? Is this the adapter used on the Alienware 18 R2 laptop?

What is the error code in Pitool? Your Alienware 17 might need a powered usb hub.


#3

Oh, that’s a nice tip, thanks - will check it out. EDIT: Sadly the BIOS update doesn’t support laptop cards.

Either way I was able to get back to the previous status (green LED and picture on the HMD - but not in direct mode) on my old Alienware 18 - after installing an old version of SteamVR (1.1.4) I can once again get my extended desktop picture on the Pimax.

So probably it has something to do with SteamVR, will try with a different version as well as updating the Nvidia BIOS.

As for the cable - I’m using this one - https://www.amazon.de/dp/B00YOVKWQS/ - I’m pretty sure it’s ok, as this exact model has been reported as working.


#4

Well I’m running out of ideas :). Can it be a faulty cable? But on the other hand I’m getting picture on the Alienware 18 on the HMD (but VR not working), on the Alienware 17 I still get the red light even though the Pimax 5K+ gets recognized in Pitool and in SteamVR.


#5

Have you tried a powered usb hub? Often laptops have low powered usb ports.


#6

I tried all ports, even with an USB-C adapter. Besides my Oculus works even if I connect it just to the USB port (I don’t even have to plug the AC adapter), so I’m pretty sure the USB ports are ok. Anyway I gave it a try with a powered USB hub, but it didn’t change a thing. If I install older NVidia drivers (before the G-Sync official support) the Pimax gets detected in Nvidia Control Panel as a secondary monitor, but still no picture, so I get exactly the same results as before :/.


#7

I would reccommend submitting a support ticket.

The odd thing is the headset should not be shown as a monitor in Nvidia Control Panel.

@Doman.Chen


#8

Now looking at your Laptop Specs I see it has also Intel 630 graphics…

In Pitool click on help Tab & choose Diagnose. Post Screenshots of output.

This will check application integrity & show if pitool is seeing your Nvidia. You might need to change something to ensure Nvidia is ouputting through DP.

Is your mini DP a Thunderbolt port?


#9

Yes I already contacted support - waiting for their feedback. It’s a laptop with a G-Sync screen so the Intel HD Graphics is not being used by the system as far as I know - I also tried to make it run by disabling Intel Graphics in Device Manager, etc. Anyway here are the screenshots: