Pimax 5k+ drops to 50hz randomly


I’ve had some recent issues where when i’m racing in iRacing, my fps drops to 50fps flat and stays there. I have to restart the iracing window to get it back to 90fps

Why is this happening? Is this the brainwarp? I havent had this issue before last week when i update to win10 1809

fpsVR app shows the GPU Frametimes go into the orange on the graph, and the entire view is choppier and jaggedy.

I dont understand what’s causing it to drop to 50 from being at 88-90fps consistently, and once it does that it stays there and doesn’t go up/down - it just gets stuck at 50fps.


Hard to say @fresco noticed something similar. @Enopho gave some details on checking whether related to Windows/steam updates.


Yes, Heliosurge something has happened in the last week to either Windows, or steamVR, part of the reason for my frame drops I discovered was do to not having my overclocking app running but I still think something more is going on here as of yet undetermined. I have to give a thanks to @MikeJeffries for mentioning this and am curious if anyone else has noticed a recent lack of performance or some other alteration.


My setup is an rtx 2080ti FE, 8700k @ 4.8, 32gb @ 3200

Im running msi afterburner for the OC on the rtx 2080 TI. Which gpu do you have?

I hope it’s not RTX-related.


My Gpu is the EVGA Geforce GT 1080ti and am also using the msi afterburner for OC.


I wonder if it’s OC of the gpu/ vram

Did you have similar fps drop to 50fps where it stayed steady locked to 50 like i did in iracing?


No, I didn’t have the drop to 50fps steady like you had. I was experiencing the dropped fps playing Fallout 4VR. In my case I have already determined that most of my loss was simply absent mindedness of forgetting to run msi afterburner with my presets. Also what I experiences was a change in the monitors mirror window after a steam update. My fps is much improved now but still not as good as before, going from stable green to now random orange dips in fpsVR to occasional dips into red. This was not the case for me before. I hope you find a solution to what is causing your fps loss. I will just continue to monitor for other Pimax owners experience of something similar. Then again it could just be a temporary glitch in my sytem, something didn’t load properly or a nvidia setting i adjusted by mistake. So not doing this stuff without a scientific approach it is hard to pin down. I do this as a hobby with out much seriousness so later this afternoon when I try Fallout 4vr again I may experience different results unfortunately.


Are you using supersampling?


Was your question for OP? sorry


I have a couple of ideas but about to board a plane for a short flight to Auckland… Will post when I’ve landed.



1.0 pitool and iracing dx11renderer at default 116. Steam vr is 100% but it doesnt work in iracing anyway


Thanks let me know what you think @enopho


just landed… i’m waiting for my taxi to arrive so will post this quickly.

This is ‘assuming’ that these fps drops have happened since the latest 1809 iteration of Windows 10, and not on the previous 1803 version?

And this should ONLY be done if you are not using Microsoft’s Game bar in any way , screenshots/recording etc.
can you try this please…

right click the start button.
click settings
click gaming
click game bar
click on the slider switch below record game clips. screenshots, and broadcast using Game Bar, so that it turns off.

now we also need to disable xbox game monitoring,

this however has to be done in the windows registry. Note its always prudent to back up the registry before making changes as a damaged registry can stop windows from booting!

Open this key HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\
now look for xbgm
(you might have to scroll down to find it)
right click in the right window and choose START >REG_DWORD
Click Modify
type 4 (replacing the 3)
Click OK

this will disable the Xbox service

restart the PC and try your games again, let me know if that fixes it for you.



Awesome thank you for this. I’ll try this in the next few days


Just in case you did not know already, a VERY common issue is low harddisk space if something feels different suddenly and gives lower performance. I have lots of friends that did not know that especially HDDs but also SDDs cause framedrops when disc has not apr. (might vary from model to model) at least 10% free space. Since we use all kind of cache/temp files for various purposes on multiple drives this may also affect non-system drives. This may not necessarily be what is causing your issue but it’s worth to double check to rule it out. With is HDDs it is easy to figure because you can hear that it is constantly busy read/write/delete although you are actually not using it. In times of silent SSDs you really need to find the “sweet Spot” or be on the safe side and leave 15% free.


I found the problem but I dont know how to fix this.
So I have an Acer Predator X34 100hz monitor for my main monitor.
The monitor on my racing rig is a 49" Samsung 60hz. In Nvidia control panel it showed my acer was set at 50hz for some reason. I changed it yesterday to 100hz.

When iRacing opens up, it starts on my acer monitor and i move the window over to my samsung monitor, so I can see it in front of me when I am racing, when i take my pimax headset off.

When it was on my acer predator just now, fpsVR showed 90fps and normal frametimes. The moment I moved the window over to my samsung monitor, it dropped frames to 60fps

Why is it connected to the monitor’s refresh rate now?


Have you googled this? Coyld be sn Iracing issue.


It only started happening recently. Not sure. Also i noticed my samsung monitor is stuck at 60hz when it should be 120hz. I have an HDMI to DP cable for that monitor. I will switch the cable later to DP

Even though its setting the pimax fps to the monitors refresh rate, i should still have 100+ fps on either monitor, if that’s what it started doing


maybe this issue is related with " Compatible with parallel projection" Have you tryied on/off this mode ?


Ye but in iracing it will cross images if i dont use that option. I should test this in other games and see if the fps still stays the same as the monitor’s refresh rate