Pimax 5K+ still unusable after 3 months (Help needed)

pitool
issue
fix-guide

#21

I do know when I conducted tests with my buddy Vega Gpus had problems with getting the headset to connect. Interestingly though my r9 390 8g worked better & decently playable.

I will see if I can maybe get a hold of him as he has strong ties to Amd & might be able to help at least perhaps with some info.

Imho Amd & Pimax should audit Amd gpu users & see if they can organise sharing logs & xp to better see about optimizing driver interactions.


#22

Thx. My main issue is really that it just straight out causes my PC to crash (or at very least causes it to freeze for several seconds and all VR stuff crashes until it recovers).
All the connection issues etc., sure it might take half an hour or an hour to get past them, but it almost always ends with a crash and having to start all over again.


#23

Here’s another one I received just now when I started Pitool and tried starting Beat Saber directly from Pitool:

Pitool itself crashed as well.

Also, I might have forgotten to mention that I own a Vive which never crashes and doesn’t experience any of the issues I experience with the Pimax. My PC also never crashes from anything else like games, software etc. It’s only Pimax.


#24

Can you see which DLLs are missing and what permission conflicts? Maybe I can fix them then.
The DLLs missing I see on the list seem to be not a real problem and other people get those missing DLLs too.
https://social.msdn.microsoft.com/Forums/en-US/a28331ae-19a3-4a34-b3ba-1e8fd4430375/missing-apimswincore-dlls


#25

So I just did a complete reformat of my SSD, completely erasing everything and clean reinstalling Windows 10 1809. Did all the updates and installed the 19.4.3 GPU driver and the latest Pitool Beta.
I could manage to get beat saber running for now, although smart smoothing causes blurry double vision, so I cannot keep it enabled.
I will report back, if it’s running stable after I’m done with some testing.


#26

Great news. It’s almost like you didn’t have full admin privs on the other install.


#27

Well late but can report my r9 390 is still running well on pimax 8k.

Updated pitool on that machine to 121B (needed to due to hmd FW)

Current Radeon Driver 18.10.2

Looks to have had some performance gains. No connect issues. The old card is still impressive; but as my Friend said this card was not properly utilized as well as it could be. And folks say Amd cards often improve with age.


#28

I do have one question in pitool Diagnose it shows

Video Protocal Unknown? What does that represent?


#29

So, after Beat Saber, I tried The Lab. It crashed my GPU driver and I couldn’t get the HMD to work anymore until after a PC reboot. Then I tried again and it crashed again, shortly after the game was loaded. The third time I got it to work, it finally worked without crashing.
After playing The Lab, I tried Space Pirate Trainer. It loaded fine and crashed in the third wave of the game (after like 1 minute of playing).

So all in all, it’s now working better than yesterday but still a very bad expierence, usually requiring several restarts of the HMD, Pimax service, or/and the PC until something runs and often crashing.
It’s still a much worse experience than the OG Vive right now for me, as I’m spending 80% of the time with rebooting and fixing instead of playing.

When it’s running, it has some advantages and some disadvantages compared to the OG Vive.
Advantages are obcviously FOV, lower screendoor effect and somewhat better sharpness,
Disadvantages are Smart Smoothing causes massive display errors, so it’s unusable, there’s large amounts of distortion (looks like seeing through warp lense camera), colors are plain and much backlight bleed compared to the Vive (that is to be expected with IPS panels).
This isn’t really what the topic is about though, I’d just like to get the headset to run without it crashing my PC.


#30

They must have made some interesting changes as the r9 390 gives a decent experience on par with Nvidia it seems.

The rx 480 is that one of the gpus using hbm2?


#31

No, Polaris GPUs use GDDR5, like R9 390.
I might still have some R9 290x or R9 290 lying around, but it’s kind a hassle to build them into my PC, so I’d rather not try them. They are slightly slower than my RX 580 on average and use more power and lack some modern features.


#32

I agree with you there. Why I have multiple computers less hassle.

But this does demonstrate changes in the Amd architecture seems to be what is causing issues. The T R9 390 being as old & performing well compared to the rx 580 which back in November was the same with the 2 vega 64 setups.

The Vega 64s were completely unplayable. Connection isssues, desktop stuttering(mouse movements) etc…


#33

That’s odd that the performance is low on Vega too. I’m also expierencing the mouse lags.

Pimax needs to find a solution (together with AMD) to solve these issues, this is really unacceptable. Pimax could at least keep us informed on the progress, because right now it doesn’t seem like they’re working on it, as it’s still the same as 3 months ago.


#34

This is honestly on both. My contact in Amd is on their advisory board. Their driver has had known issues. But yes both of these parties should be giving the community updates. Truthfully at this stage Amd should have their side fixed up.

I spoke with my friend after testing the r9 390 so he could give Amd feedback on the r9 working well. It does seem to go on the old standby of Amd makes better hardware but suffers on tge driver releases. Where as Nvidia usually has goid drivers & Hardware not as good.


#35

I haven’t even used it ever since i got it. But zelda vr pc is out… will motivate me


#36

If this is indeed an issue with all AMD cards of some type, and Pimax is aware of it, then at very least we need an official statement from Pimax on which cards are supported and which cards are currently not supported.

Also, it would be nice to get frequent updates on the progress.

This thread has also never really been answered, if it’s an AMD driver issue that is going to be fixed by AMD, or if Pimax is working on fixing their Pitool or if neither AMD or Pimax are even aware of the issue because of lack of communication: AMD Driver is coming eventually?

Maybe it’s just my specific hardware combination that’s causing trouble with the Pimax headset, so I’m also going to open a support ticket linking to this thread, requesting Pimax support for my issues, as soon as the support website is working again (it’s still down for me).


#37

While I myself am not official for either company. My friend did get confirmation that the primary issue is on the Amd driver side.

I would haphazard a guess why it’s maybe not presenting itself on Vive & Oculus is the high vr res maybe. But yes either way updates on this issue at the very least should trickle down from pimax.

The 121B pitool did say improved Amd support.

@Dallas.Hao @PimaxUSA can your team maybe see if we can get updates on Amd Gpu status?


#38

Check support site as they might have things resolved or resolved soon.


#39

Is it just me or is the support website still down?


#40

I haven’t checked it as of yet.