Pimax 5k+ turns black every few seconds and white pixel flickering

issue

#1

Hi,

I have issues with my 5k+. The screen has white flickering pixels all over the place and the screen turns black every few seconds for a short amount of time. It happens in every application.

Example video:

I tried different USB ports even on an pci usb card, different display ports on the gpu, Removing and reattaching the cable on the headset. I tried a universal power cord but it didn’t really work headset will stay 90% black with it. (specs and connector is correct).


Flashing Dots, faulty cable?
#2

Turn off PiHome it’s currently just wastes resources.

Please post your system specs.

@Dallas.Hao please add to earlybackers group.


#3

i7-9700k @5.0GHz
Z390 AORUS MASTER
16GB DDR4 3200MHz
RTX 2080 Ti
1x Lighthouse 1.0 / No controllers (I only want to use the headset for Simracing)


#4

Nice setup! @park likely have some insights for single LH setups.


#5

Tracking is working perfectly for me. Game is running fine. Only issue is the black screen every few seconds and the white dots. Seems like a signal issue. I ordered some noice filters and a different DC power plug. (They should arrive tomorrow)
I think the issue is the cable itself. Which I can’t replace on my own.


#6

Indeed could be a cable issue. If so might be good to submit a support Ticket (might be best to submit on the 10th with the CNY)

If you have the option try on a different pc.


#7

I agree…judging by other posts sounds like a dodgy cable


#8

I think all three parts of the cable could use filters for a total of 4. (@Sean.Huang @PimaxVR @Dallas.Hao @Matthew.Xu @xunshu) to reduce possible interference.

1 @ headset input
1 @ DP pc in
1 @ Usb pc in
1 @ wall plug psu

But yeah likely a cable issue


#9

I got the same issues (5K+, i7-6700, 16GB DDR4, GTX 1080 Ti, 2x Lighthouse) and Pimax seems to be pretty slow about it. I mailed their support on Jan 24. Five whole days later they responded and asked for a video which I sent them about half a day later. And since then it has been six days without any sign of life from them. And due to Chinese New Year I guess I can’t expect any for a good week at least. This is frustrating to say the least.


#10

Replaced the dc power plug, added 4 ferrit cores. Nothing still the same issues


#11

Hopefully after the CNY support gets on top of these issues. If you have a Supen number post it here @Dallas.Hao.

@Dallas.Hao please add to earlybackers


#12

Ticketnumber: SUPEN-1809 @Dallas.Hao @Sean.Huang