Pimax 5k+ with PREPAR3D



I agree Prepar3D seems an obvious software to support. I ordered my Pimax ONLY for this software, never thought there could be an issue.


Why does everyone keep saying L&M? Its Lockheed Martin not Lockheed and Martin…


Using the 8K mainly in Il2 Battle of Stalingrad Series WW2 sim.
Finding using the 8K at 64Hz, SteamVR both Video and App at 100% and then PiTool Render at 0.75 or 1 gives very good results.

Colours, depth, clarity. Gauges are easy to read and sense of flight is great. Aerobatics in these war birds is a hoot as is shooting them down :smiley::+1:

Higher Render Settings in PiTool does increase detail a little but then it is harder to spot as you go up from 1.25 onwards. Also turns my flight into a slide show. The landscapes, weather and lighting are lovely to behold.

I have no real interest in commercial aviation but similarities are a given especially if you are using a HMD for training. VFR would be quite easy to learn and there is no comparison to multi monitor setups.

My other little sim thing is hurtling a car round race tracks in Assetto Corsa and it is a blast for that too.

All that said, I can’t wait till lighthouses are shipped so I can get 6DOF and constant stable head tracking. At the moment with gyros only, I have to recenter my view every 5 or so minutes as it drifts to the left. That and the lack of being able to get up and close with elements of the cockpit make life a little more challenging.

If LM broke compatibility with their update - the onus would be on them to fix it.


Not sure I follow here, I used P3D 4.4 just two weeks ago on a RTX 1070 and with my 5k+ with no problem using high-res France scenery and pre-brainwarp driver I don’t remember the version


I can’t use LM Prepar3d v4.4 in VR with Pimax 5K+ because of large black triangles all over the screen. I know this has been reported before by other users but I wanted to know if it was likely to be fixed and by whom, LM or Pimax. I contacted LM and they replied:

“We implemented the OpenVR stencil mesh, which could cause unwanted artefacts in the headset if it does not have a valid stencil mesh. You can contact Pimax support for information on their stencil mesh”.

Well, here I am, can I have some information on your stencil mesh? Not that I would have a clue what to do with it but is it likely to be made valid, fixed or made compatible with Prepar3D. Thanks.

@Dallas.Hao @Doman.Chen


disable the box above pp in pitool for p3d


I am also a big fan of P3D and, me too, I have invested in Pimax, GC 2080Ti and CPU I9 and I am disappointed to have this issue. And reading all your messages doesn’t make me not confident in any coming solution because it looks like everyone is throwing the stone in the other’s garden…

What do you mean Thaycoon ? Did you find a way to get rid of the black triangles ? Did not find the box that you are talking about… Can you be more accurate ?
Thanks in advance.


I believe he means Disable Smart Smoothing?

(Setting box above Parallel Projections)


I just tried and it didn’t work. With Smart Smoothing disabled I still have black triangles throughout the screen making it completely unplayable.

EDIT: I turned off hidden area mask and it works! I have no more black triangles!


You need to disable “Hidden area mask” and “Parallel Projections” in P3D

EDIT: I see you have found it, good!


I also did that and actually the black triangles have disappeared but some sceneries (installed airport) have also disappeared and the frame rate is drastically reduced (photo realistic sceneries remain blurred and contribute to an uncomfortable experience… For example I have landed on a black runway surrounded by all black building (no textures)…
I returned with the black triangle that are, at the end, less disturbing in some cases… On the same airfield, all returned to normal (except of course the mesh issue).
Hope either LM or Pimax will solve that !