Pimax HMD Bug/Fault Pimax 4k - dredded black line


#1

Greetings fellow pimaxians. AAAAAAAAAAAAAAAAAAHHHHHHHHHHHHHHHHHHHHHHHH

I have been losing my mind lately with an odd issue with my headset which I feel I understand really, really, quite intimately, in regard to some of the older legacy piplay versions 1.x.x, and older driver, and the way in which they interact with the HMD headset. Specifically I have an issue that isn’t firmware dependent but it is piplay version dependent, a black bar is introduced which is so goddamned irritating it completely ruins my experience and i’ve managed to get rid of it before through some elaborate steps. I.e. I have a 100x version headset and I’ve tried reverting the firmware to an earlier one (100XXX_1.0.0.251 to be exact). Nothing helps, except from reverting to the legacy version and repeatedly fudging around until it works… ahhhh please help someone, im losing my mind. Let me elaborate more specifically at what the problem is, what the HMD view looks like of the issue, and the steps I’ve done to fix it before, and some of the accompanying strangeness that comes with the black lines (such as when changing Render under devices to anything else, piplay goes into video mode). I’m pretty sure this isn’t the intended affect, and, I’m pretty sure, from my own software engineering experience, something is going on, that shouldn’t be because of something or other how the software interacts and sets certain modes on the HMD. I’m guessing one mode here or there in the older legacy drivers is a bit broken, and, regardless of the firmware, can leave certain states of the headset in a buggy condition where such artifacts as Im about to show appear. I fixed it earlier today, but I believe it came back after i opened steamvr and used the ‘recenter’ button in v.1.2.97

OH GOD PLEASE HELP ME WITH THIS. It’s so frustrating.

The same black line is visible in video mode, and I am sure it is software causing it somehow because i’ve fixed it before by reverting and playing around with the device settings of the pimax in the older pimax 1.x softwares.

aaaaaaaaaah I WANT TO PLAY PROJECT CARS :joy: :joy: :joy: my pimax headset is cursed, and the WORST THING IS i’ve managed to fix it but then AAAAAAAAAAAAAAAAAAAAAAAAAAAAH

I’ve had this cursed problem before. See the image, this is exactly what the issue is. Big black line almost in the center of the headset screen. (although the images attached aren’t pictures of the headset, this simulated image is nearly exactly what both VIDEO and PIMAX mode look like).

The interesting thing is, I’ve fixed this before, by faffing around, much like as is described in this post.

specifically;

‘‘I found that Piplay 1.2.57 and the 248 firmware causes some odd light
black bars in the HMD. I just spent a few hours ‘fudging’ with it, and
it now appears that it is the piplay version that was causing my issue.
Once I downgraded back to 1.2.53, the black bars are gone (but the rez
seems lower or less clear). With 1.2.57 the HMD seemed more clear, but
the black vertical bars killed it.’’

For me it is just one ‘light dark black bar’ in nearly exactly the place as the below images.

The truth is, I managed to fix it, after about 6 hours jumping between windows 7 and windows 10 months and months ago. But, I accidentally booted up the old install (I believe 1.2.57 or 1.2.97 and the black bar returned.

Today I’ve had another real go at it, but I must admit, Pimax , I’m starting to lose my mind.

Today for a brief duration I managed to fix it again after incrementally switching between PiSetup_1.2.53_x64 PiSetup_1.2.57_x64 and PiSetup_1.2.97_x64. I believe today, after about 6 hours of playing I managed with PiSetup_1.2.97_x64 install, (after uninstalling the software and services for the later versions i’d tried which all had the blackbar). The black bar disappeared for a while. The way I seemed to remmeber getting rid of the black bar was by changing to and from pimax and video mode in the old pi1.2.97 application, and to change the Render from 1.0 to 1.3x and 1.3 to 0.75x and 0.75x to 1.0x.

It’s really hard to recreate the issue, and, the black line seems to ‘stay inside the HMD’, regardless of the firmware the Headset runs, and regardless of the sotfware version. After managing to get rid of it again today by incrementing in the manners I said above, the black line had completely vanished, and i had got steamvr running without the black line, then after recentering the hmd using the pimax app, it seemed to return. I believe it is something with the older legacy versions of the application and any firmware version over 248 which causes this issue. I believe somewhere in between the software increments and firmware increments, something has happened to my headset to cause this black line to appear, it’s frustrating, having recreated the steps before and having got rid of nearly 2 or 3 times now, but I have to be very careful after using the older versions of piplay, uninstall it, and then install the new versions for the black lines to stay away. I hope that this makes sense. I am really losing my mind here, I’m wondering if pimax or anyone who is learned with the headsets might have seen this before like in the other post i point to which is incredibly similar to my own;

As I have said, I am a fairly experienced software analyst and sysad, and I know what I am doing jumping from version to version, and having succesfully recreated the steps to put the black line back by booting an older disk with the cursed earlier install, and having at least 2 or 3 times got rid of it using the render 1.0x 0.7, and 1.3x settings in piplay under ‘Device’, I believe I am getting really close to understanding what is going on.

I believe part of the bug is, that when I change the ‘render’ (which i believe used to be called IPD or similar in earlier versions of piplay), it will change pimax mode to video mode, even though all I changed was the rendering above 1.0 or below 1.0. Sometimes this before would get rid of the black line. Also, when piplay would start on the affected earlier legacy version, the headset would sometimes at least appear to startup, without the black line, and then it as if something ‘adds’ the black line, as shown in the pictures. AHHH this is so frustrating.

The really sad thing is for me, I love Pimax, and after reporting the issues I had with there being dust inside the HMD etc, and beinf refunded some case, it’s a real booger to be running into this issue again, it’s completely my fault! In the sense that I know I had fixed the bug before by ‘reinstalling’ the older legacy version that introduced these black bars, after that uninstalled it, and installed the new 2.x versions of piplay and was having a whale of a time with my pimax 4k until i bloody booted up the windows disk that had the cursed piplay driver/application - so although a pimax bug, I feel like I’ve shot myself in the foot after before really perserving to fix it. This time, after much much burden I cannot fix it, and I’m running out of ideas.

I really hope someone understands what it is that is going on, or that my experience can help someone else.

Please pimax, a penny for your thoughts? please prevent an unnecessary death of a headset, and it’s user.

Best wishes and many thanks to anyone that had the patience and bravery to read my entire farce of a post. I need help, but my pimax HMD needs love, please help it recover again. Help me remember how the hell I fixed it the previous times.

many thanks
Adam


#2

Here is a picture approximating how it looks like on the HMD when in video mode in KODI. Please note, the LINE/black/BAR is in the same place on the headset in kodi view (VIDEO mode) and the steamvr mode (PIMAX mode), I created these images to approximate what it looks like in the headset. My approximation is damn accurate what im seeing in the headset!!

Please does anyone know how I can fix this? Or a way to reset other variables that these older software versions might have set when changing the render? I believe the bug of the black bar relates to when I change render mode in the older legacy versions, and unless i get rid of the black bar in the older versions, regardless of the firmware of the pimax device , or the piplay version I install, I never can get rid of the black bar, until I install correct legacy piplay version. I’m really having a hard time recreating my previous fixes.

AAAAAHHHHHHHH. Help :smiley:


#3

Okay best of the legacy piplay is 1.1.92.

Have you tried using 2.0.7 (the version just before 3.x)?

The latest firmware believe 265.

@Enopho & @sjefdeklerk might know some tricks.


#4

Thanks Heliosurge, I’ll try 1.1.92 later tomorrow, since i been up all night trying to fix this and 8am now.

Yes, just wanted to say I have been having this problem with firmware 265, but I succesfully reverted the firmware to see if I could fix the issue without reverting to the legacy software versions like I’ve had to before to get rid of it. I’m just struggling to get rid of it this time!

I’m pretty sure it’s not a firmware issue, but might be something regarding the way the different versions use the firmware to 248 and 251 i believe, just to see if it would make anything differently and/or store variables/state/draws on the viewscreen differently, because it feels like the black line is being added by the software somehow. and this ‘sticks’ even after upgrading to the latest 2.x and 3.x versions of piplay. But I’ve got it to unstick before reverting to legacy versions, then uninstalling legacy and upgrading to the 2.x version.

I’ll try 1.1.92 again and see if I can replicate the circumstances where I have fixed this black line, but yes, I really am struggling here, so any additional tips would be greatly appreciated from @Enopho and @sjefdeklerk

The reason why I am sure this is software, is because the screen sometimes goes ‘grey’ completely grey with a white pixel dote in the center, after transitioning states video and pimax, but failing on occasion, and the black line is completely gone then. It leads me to believe its not a headset of cable signal issue, and given that I noticed when booting when driver/software loads, for a brief moment before when i was having this issue, the line is not there, then ‘appears’ as if it is drawn.

Sorry if it seems im not explaining as well as I can, it’s just been an odd issue throughout that has driven me round the bend :smiley:

Cheers guys, I’ll update soon.

Best,
Adam


#5

Your welcome for ease of finding it here is a link


#6

Hey chap, so I have tried piplay 1.1.92, it seems to be very unreliable, I had much better luck with 1.2.57 and 1.2.53 and I believe there is a 1.2.97 as well.

Black line appears for all of the firmwares I can test: 248, 251 (100x) and also 265, in software versions

It’s also interesting to note I’ve tried 1.1.87 as well as PiSetup_1.2.53_x64 PiSetup_1.2.57_x64 and PiSetup_1.2.97_x64.

Still the same black line appears. I noticed a few popups saying that my HMD had been changed to ‘extended’ mode a few times, even when using a pimax version that only has the ‘PIMAX and VIDEO’ mode. So, Im a bit confused by that.

I know that altering the render from 1.0x to 1.1x made the black bar go away, when using the older pisetup’s i’ve given. I’ve fixed the issue before, but was stupid enough to accidentally boot the buggy windows OS with the bad piplay version and it’s back, and I am no longer able to recreate the circumstances of fixing it, although I am able to easily recreate the circumstnaces of breaking it. Just install the older legacy versions on my OS and boom, the black line suddenly appears on the headset and it WILL GO AWAY when the screen is grey (i.e. on), it adds the line in later but I HAVE NO IDEA WHY OR HOW.

and the black line is there, until I’ve pressed 100 buttons, and lots of fudging, but its JUST NOT WORKING THIS TIME and after 20 hours of changing drivers and apps and versions and flashing with the dfu utility I’m starting to worry for my mental health :joy:

Please can someone from piplay/pimax help me fix this? I know it’s an issue with your software or headset, and I want to provide information so this ABSOLUTELY ASS OF A DREADFUL NIGHTMARE DOESNT AFFECT OTHERS.

All I want right now is to use my piplay, in fact, for the last 8 months I’ve wanted to, but because th e ebay seller said they would respond and fobbed me off for long enough I’ve been left wiht a brick, a brick that, despite real amounts of affection, love, and a really clever user who understands what the issue is, for love nor money I cannot replicate the circumstances to remove the black bar.

For the love of god PLEASE let there be someone that has had this issue also and found a fix, PLEASE

Best wishes,
Adam


#7

I’ve just tried 2.0.7, which doesn’t work at all for some reason or another. All of the 3.x versions work, and all of the 1.x versions work, however it was struggling to come in and out of direct mode on the 1.1.92 version you recommended and I had to restartt theheadset and/or the OS to get it to work or switch the mode back to pimax or video.

Still no dice, same big bad black line, one i’ve figured out how to remove before, but just can’t fudge with the drivers and software this time to get it RIGHT, i wish there was a way to reset the headset, I’m wondering if the line is something to do with steamvr, or the recentering of the headset calibrator just not getting removed, then I could just install the later version and not feel like stabbling myself in the eyes, signing off here with a heart full of regret and sadness. Thanks again for signaling to help I really appreciate it :joy:

AAAAAAAAAAAAH

Best,
Adam


#8

This is the problem I have with the 2.0.7.54 version

to be honest though getting piplay/pimax to work is easy, yes drivers/software is not great, but this black line introduced with one of the firmwares or one of the softwars, line i have removed at least twice by changing IPD/focus/render setting under ‘devices’, this fixed it before, but I am unable to replicate the fix and have been left with a brick :frowning: (that is to say a fully working pimax 4k and fully working piplay in video and steam mode, but black line seems to reappear as soon as piplay initializes, regardless of the fact that at times the black line is gone, and, the black line seems to be added by some older legacy software. Regardles of the fact yesterday with the 1.2.97 version the line was briefly gone, until I rebooted with same version and it was back. AAAAAAAAAAAAAAAAAAAAAH

I need to find out how to undo this damage, since it is not really any fault of my own, but literally the pimax product very difficult, very buggy, and I am not able to achieve the removal of the black bar anymore, and this is driving me absolutely insane :frowning:

AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA


#9

1.1.92 was a dance to get the hmd connected.

Maybe try reseting firmware as described. Then let piplay update the firmware. Might fix the blackline.

I haven’t experienced the issue you describe.

@Sean.Huang may have an idea.

Have bumped your user level up 1.

Please post your system specs with gpu driver version. Sometimes new gpu driver causes issues.


#10

OK chaps I have got it - this is the steps to ‘prove’ the black bar is removable.

If I plug it in, using 1.1.97 software, and the 265 driver, it will ‘start’ in extended mode, and if I then switch to ‘pimax’ mode, as the screen mode resets in the HMD, the screen goes grey, (and is backlit still so this is a video signal from my understanding), background is continuously grey (also note no black line).

Also, sometimes wehn pimax fails to transitition mode states like pimax-> video or vide-> direct/extended , occasionally what happens it the grey screen appears, and the black line is STILL THERE, but then the black line ‘fades’ away, as if it was actually drawn, and ‘ghost disappears’ away, until there is only 1 white pixel in teh center and a grey background.

Something is wrong with the way the software is interacting with the HMD and I am absolutely sure of it (if not mentally insane from fscking with the thing 20+ hours) - I can at least show a lot of things which indicate the black bars, remembering I had removed them before with the steps I gave aformentionedly, and that the black bars do ‘fade out’ when transitioning state, which seems to me like it is ‘being drawn’ to the hud/hmd.

I think its something to do with the recentering function of the piplay/pimax utility, but I need input from pimax to fix it. please please please please please help before my head explodes :smiley: :joy: :joy: :joy:

Best,
Adam


#11

Sorry If I seem angry guys, but I kind of am :frowning: I know what the issue is just struggling with these legacy drivers to reproduce the way I’ve removed the black line beforehand.

I FEEL SO STUPID for booting into the old piplay/pimax drivers, but I promise, this is definitely the reason.

Also you can see the grey screen im talking about, black line appears on it, and then ‘FADES’ away, when the pimax fails to transition states, what does this mean?

It must MEAN SOMETHING. Like that the black bar is being drawn by the pimax/piplay driver.

Pleaseeeeeeeeeeeeeeeeeeeee AAAAAAAAAAH, would it be possible for someone to take a look at this fault? I know it is absolutely 100% 10000% a fault with the pimax headset, I know exactly wehat the fault is and have given specific examples how the problem presents, changes, is created, and fixed, I’m just having problems recreating the steps of the fix previously, mainly because it was so many months ago that I removed the black bar last using the black magic of the legacy drivers, becaue black magic is exactly what it is!!!

AAAAAAAAAAAAAAAAAAAAAAAAAA


#12

replication:

From the failed transitioning state, the pimax hmd screen goes a light ‘grey’. the black line appears on the grey screen, and ‘slowly’ goes away, indicating that the black line was ‘burnt’ into the display, and it took a small time for the ‘ghost’ of the black line to disappear.

This a) proves that the line was rendered and drawn by the piplay/pimax/hmd/driver and b) the ghosting shows that the line was rendered, and as the pimax failed to transition state, the line disappears.

Given that C) I have seen the HMD display boot with the OS and not have the black bar, and then 100ms later it appears, it means something of interest is going on, and that particular thing of interest holds in it somewhere

  1. the cause of my problem
  2. the solution for my problem.

I hope this helps someone identify what the hell is going on. I’m literally curving my toes and pulling my hair out over this one gents.

as you can see from the simulated image, after the failure to transition from states and the grey screen in pimax hmd headset, the black line fades away and then is gone COMPLETELY… the black line is definitely being caused by directdraw/draw because of these reasons, the black bar is being drawn onto the HMD some how.

Hence the black line ‘fades’ away. hence, the image updated with grey background, not black line i.e. pixels are working. headset is working but driver/firmware is BUGGED.

Before the grey screen/pimax fails to transition I am presented with the normal working pimax screen and the normal video screen, both video and pimax modes work absolutely perfect, the headset and performance is absolutely perfect, I have no problems at all with my pimax, except for the black line which is being drawn because of the legacy driver, I know that this is the cause, I know that there is a reason, I do not know what hte reason is, but I am certain it is the old driver from these details.

Also, given that everything works, except for the black line, and during the fail transition state where screen goes grey and the black line ‘ghost fades’ it means that the black line is being drawn, it means that the black line isnt caused by dead pixels or a bad lead or cable, or contact with my gpu, I have 15 different gpu’s and i’ve tried a few, I’ve ruled out all of the reasonable expectations, having maintained cisco 3550 and quagga partial route tables and my telecom company, and I work for a large ISP as a linux system administrator working with linux redhat and enterprise cloud.

I’m hardly an idiot user, and literally understand what is going on, just don’t know WHY. WHYYYY PIMAX do you do this to me :frowning:

Soo good news is

  1. when pimax fails to transition state and is left with ‘grey’ screen and 1 pixel WHITE dot in the midel, I can see the black line isn’t there, it isnt dead line of pixels etc. EXACTLY what happens is the black line fades away in about 1000ms to leave a full completely grey screen with a 1dot 1px white dot in the middle.

  2. pimax has to fail transitioning states for me to see tha the black line isn’t a ‘dead pixel’ or something similar (and whole screen goes grey as the black line ghost-fades away). IMHO COMPLETE PROOF its not a ded device, and I’m not imagining what I’ve said so far.

  3. I have fixed this before using older legacy driver and altering the pixel rendering quality, but it wasn’t called ‘Render’ under the pimax/piplay devices pane, it was called something like IPD or IFD, and when you applied the slider, the headset is reset, I found in my case, that this sometimes got rid of the black line, but it isn’t working anymore, and I am not sure why. I suspect it is very specific with the order I install drivers/piplay so I really need help to take it further than I have here, please please, has anyone seen anything like this? or have any developer experience to know what it is that is going on for me here? I dont develop the pimax SDK so I dont know what the implications of my observations are

Best,
Adam


#13

Why I put a poke. A pimax team member may need to setup a teamviewer session with you. Might need to wait til monday for that.

However @sjefdeklerk might have some ideas. He coded his own firmware update tool & hacked firmware in the link above.

Note I don’t doubt the issue your experience just not sure on a fix.

What gpu & driver version are you using?


#14

Howdy Helios, yeah no worries at all thanks a lot for the effort!

I’m using the latest catalyst drivers which are the adrenaline drivers with the RX570 and RX580 polaris 10 chipset. Though I had the exact same issue with the Geforce 960 SSC from EVGA, so don’t think that the issue is specific to the graphics driver or gpu chipset, but more to do with the way the firmware interact on hmd with the piplay software. I think piplay software might send some signal that can draw this black line. (what is also interesting to note if I change from landscape to portrait the line does not rotate with the image, it remains constant as it the line is drew by the HMD and seperate to the video coming from the piplayserver and gpu).

Yes, it is really odd issue, I have been very pulling hair out over it, so I hope that you do not mind my spirited AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAH’s earlier, its just AAAAAAAAAH!! :smiley: :joy:

Thanks again for discussing this, I feel like I am getting it out of my system and describing it, at the very least, one pertinent step to a hopeful fix, and yes if pimax were interested in doing teamview session that would be interesting to see if they can figure out where the line come from.

If anyone knows way I can debug this some how, I may be able to do some of the steps myself - the linux is strong with this one - also this problem exists on windows 7 and windows 10, i dont’ t think its an OS, gpu or driver specific issue, but am very open to new interpretations that might make the complexity of my interpreted problem simpler :joy:

Thanks again helios chap, you are most kind sir

Best,
Adam


#15

Hey noticed you said linux? Do you have the headset working in linux? Definitely interested. :v::sunglasses::beers:


#16

Hi Adam,
As you mentioned your a sys admin, I feel comfortable asking you to edit the registry. Your description of the problem defiantly sounds software related.

WARNING: EDITING THE REGISTRY CAN CAUSE YOUR PC TO BECOME UNBOOTABLE AND SHOULD NOT BE USED UNLESS YOU KNOW WHAT YOU ARE DOING!! PLEASE DO SO AT YOUR OWN RISK

Have you tried…

1 uninstall all versions of piplay
2 backup your registry
3 download ccleaner and go to registry cleaner and run that, then choose the option to clean and remove
4 open the registry and search (F3) and look for either pimax and piplay entries and remove those keys manually.
5 once all piplay and pimax entries are removed… Reboot
6 ensure kLite is not installed this will be reinstalled as part of piplay install
7 install your preferred piplay driver as user admin
8 plug in pimax 4k once driver has installed
9 do not use the latest nvidia drivers… The best one is from July 2017 can’t remember the version off the top of my head but it has been mentioned before and I’m not at home to check for you for another 3 days
10 once pimax is in and piplay is installed open steamvr settings and enable async reprojection. Ensure the render in steamvr is set to 1.0 as piplay 2.x uses piplay own render and not steamvrs compositor.
11 test is steamvr home room. Look for black lines. I would also try using unity Chan and look for black bars

Hope this helps

Eno


#17

Hey @Enopho thanks for your more kind and informative help. So, regardless of the fact that Ive seen evidence that leads me to believe this isn’t a OS or registry specific issue, I wanted to go thru your steps thoroughly to try and rule this out, so far so good, because your instructions dude were really awesome, thank you so much.

You might ask? What leads me to believe that it isn’t a OS registry specific issue but something deeper to do with the way the hmd interacts with the software to draw this bar? well…

Before, I was running a dual boot, multiple versions of windows, I used my windows 10 install for VR since I was having some odd issues in windows 7 using the AMD catalyst drivers, and/or nvidia drivers. Back then I also had a 960. But please note I’ve seen this issue on both my AMD and Nvidia chip, im pretty sure the issue is with something in the ‘headset registry’ or ‘view state’ if there is such a thing, is it possible for the firmware to accidentally draw a line accross the view screen of the HMD? I believe it’s something specific set in the hmd viewstate causing the software to react this way. I’d managed to fix the bar by fudging around with the older legacy drivers like other people mention, but i think t here were some auto firmware updates in between that is leading my pimax 4k to ‘change state’ from pimax mode to video mode, but only when changing the render setting under ‘devices’ for the piplay settings, I am sure this isns’t normal behaviour and that I managed to fix it by swithcing between them and playing with the render setting, I am pretty sure this is where the ‘fix’ I had before lays around, but I can’t be certain, I’m really not greatly familiar with the way the thing works or how the firmware and hmd interacts over usb with the piserver api. etc

The reason why I say this is, because I accidentally booted up the old install OS on a seperate disk, and it borked the HMD, so that, when I went into the new OS, the line also shown there too, if that makes sense . Then, I reinstalled, my entire OS, on a seperate NVME, which i now dual boot natively and non natively inside libvirtd, but anyway, I digress a bit, the point is something borks the HMD whatever machine i use it on after this happens with the older legacy drivers ,so it’s kind weird and kinda annoying.

Evidently, I went through registry, and deleted all the keys for pimax and piplay like you said, and tried the following versions PiPlay_Setup_2.0.4.42 and PiPlay_Setup_2.0.2.33 and piplay_2.0.7.54 which seems to be the most current and uptodate, sadly alas, same black line. I’m gonna try fudging around because I know playing in ‘Devices’ on the legacy drivers got rid of the black line before, it’s just I was stupid enough to boot into the old OS and fudge up the HMD again, so to clarify, I sincerely believe if I sent this HMD to you or someone else you’d have exactly the same issue, and the weird thing is i’ve fixed it before :joy: just changing settings under devices in piplay.

Weird tho right?

Thanks for the help so far, I’ll let you know how I get on. and yes, very happy to play around more with this.

The only thing I haven’t done yet is play around with the steamvr compositor settings as you instructed, so I will do that now, sorry I had forgot about that, as installing/deinstalling and clearing the registry each time is a pain !

Thank you again kind sirs,

Best,
Adam

UPDATE: (BECAUSE CANT ADD ANY MORE POSTS ON MY FIRST DAY! :joy:

What is also very curiously interesting to note,which is endemic of the issue I suffer, I believe caused by the way render mode and the pimax/view mode works on the older legacy drivers broke something to cause the hmd to ‘insert this line’ with ALL drivers and ALL versions of piplay/pimax software.

  • uh - long setence - the curiosity is that when i change pimax to video mode, the headset goes into red LED state, and never changes, and it says ‘mode switch failed’, I believe this relates to the way the HMD has been ‘left with instruction’ to do something, because the state change in firmware/software didn’t end ‘properly’ and/or something similar to this. It’s the only explanation I really have.

Einstein said if you do the same thing again and again and expect different results I am mad, but, actually that is exactly what I see here, I think there are more variables to it, than I realise what with all the registry and such, but the fact of the matter is if a completely fresh install and completely modern driver 2.x piplay version has the same black line, that to me is pointing away from the OS and registry and firmly at the interaction between the firmware of the device an d the software, and/or some setting or variable in the HMD.

At least we’re getting closer to alluding to the symptoms being seen - thanks again for all the assist !

My working theory:

I think it’s odd that changing the view states in the legacy version got rid of black line first time, and then acidentally booting os with the bad piplay/pimax drivers put it back, and the black bar come back even after fresh os instal and recent drivers, i think because the fix also was changing the state and ‘render’ from 1x to 1.2x in device settings in the piplay, is very similar to the way the ‘mode fails’ to transition state in the modern piplay. I’m thinking there has been some pushes to the way the device interacts with the software, and a bug has been introduced that somehow not only leads this black line to be there, but for the device to also unreliably transition states, a resultant and atypical symptom I would expect to see, were the state transition differences in the legacy driver states to also either cause or remove the symptoms of the same.

I really hope I am making sense, I a m really determined to get to the bottom of this because I’m sure it’s just a bug in the piplay or the driver, and the headset is in really good condition other than this defect, project cars 2 is making me sad, especially that I have an expensive racing simulator I built just for the thing! AAAAAAAAAAAAAAAAAAAAAAAAAAAH :joy:

UPDATE 3:

Interestingly, after the view state fail transition in the piplay 2.x version, and turning headset off, then back on, I get a ‘blue led state’, and a completely grey screen, with NO BLACK LINE.

however, if i was to reboot, and restart the machine and then look into the headset, it would either by GREY(same grey with a black line), or have the PIMAX writing with the black line).

The black line is always in the same place. AND immediately after view state transition failure, then resetting headset, there is a gray screen with no black line, which I believe is telling about the view state fix i find in the legacy driver to both cause, and if done correctly, fix this HMD black line issue.

Hope this makes sense. Yes, also tried flashing to older firmware, and letting it reflash to the latest, which is by the way 265( the version I had when this problem was starting to begin with), though I believe I have seen the problem in earlier firmwares too, apologies, just looked up close, and the gray screen after c hanging view state this time actually has the black line too, but it’s significant to me, because i’ve seen the transition failure cause a gray screen with white pixel in middle, without any black line, and the black line even ghost fades, like there isnt an issue with the screen itself, but, I’m pretty sure this isn’t being caused by the cable, at least,

WHAT IS REALLY SIGNIFICANT?* I noticed in the older legacy versions if i changed resolution to 1024x768 the black line disappears, or moves substantially. I think this could actually be the crux of the issue, as it turned out async reprojection already ticked in the steam openvr settings!! :smiley: When transitioning state with the latest version of piplay 2 i notice for a momentary second the black line is not there!!! then the hmd flickers several times in <1 second and black line is back again. Interesting. I’m getting closer to some working theory, or enough for pimax dev or engineer to have an understanding what is happening with software, perhaps?? I also get ‘mode switched succesfully’ when seeing the grey screen with a black line, when going from video -> pimax and there is nothing at all and headset is led red, even though device reported as connected and said changed state succesfully, but hmd didn’t change state succesfully.

On clean boot, after headset being in RED HMD LED state. after failing to switch views. and having light gray background with black line, after reboot, have BLUE HMD LED state, and NO BLACK LINE whatsoever. Then when i click in piplay to VIDEO mode its LED goes to red again and screen goes black. So then i turn off HMD, turn on HMD. Green LED status bright gray screen with black line. :joy:

When enabling 1920x1080 mode in piplay the red hmd led status from mode changes go away, but black line still there continuous, and black pimax screen shows with black line thru it (as above), when not 1920x1080 ticked it transition to gray screen without black line or gray screen with black line, which is why this is significant to mention. (so with 1920x1080 mode disabled pimax logo black screen shows but black line always there, without 1920x1080 ticked in piplay settings the pimax black screen doesnt show and only gray screen but there is no black bar sometimes, running steamvr cannot connect to headset without 1920x1080p, because it always show red hmd status i think. Just checking atm. OK getting pimax black screen logo without 1920x1080 setting enabled now, hmmm, bit inconsistent but def the some significant findings here specifically when pimax black screen doesnt show and view mode/state doesnt change properly on hmd, but i do see a gray background with no whiteline, and a little wihte pixel dot in the middle. I just dont know what this means, AAAAAAH :joy:

The consistency of the behaviour is very hit and miss, but this explains why recreating the steps to reproduce are so difficult, with the older legacy drivers, which I believe can remove this black bar somehow by the manner in which they operate, specifically 1.2.97, but possibly 1.2.57 as well. I think in older versions before render can be changed without restarting the headset, some bug can be introduced that paints this black bar, that only the older legacy versions can fix (or create) under specific circumstances that retain in the hmd for older legacy, and for newer piplay versions, but may also interefere with mode change states, which occasionally show the black bar removed when those mode states fail and ‘fallback’ to the gray screen, either with, or w ithout the black, seemingly proving that I am not imagining it or losing my mind :joy: I am fairly sure of this anyay its just reproducing it is awkward and hard but the manner in which the black bars disappear during mode changes in all versions of piplay, and older legacy versions which dont change render in the same way, and i believe the render setting under devices in the older legacy versions of piplay can both cause and fix it, that really is the crux of the problem (sorry it is so much text lol) :blush:

Best,
Adam


#18

Hi adam

That was a lot to read on my phone!
You said that it all started when you booted an old OS… Can I ask if that old OS had piplay installed when it launched and was the pimax connected to the PC? , is the old OS on the same drive but different partition to the OS that has piplay installed (win10) I think you said it was?

I vaguely remember that there are a few directories that have piplay settings as well as steamvr configuration that have to be removed.

I know you said that the black line is there all the time on any version of piplay and tinkering can remove it… But have you considered it may be a steam issue maybe?

As a test can I suggest playing a non steam game like unity Chan… It can be downloaded and run from piplay… Does not use steamvr…

Also if one of my fellow community helpers can find the 2 Appdata directories and steam configuration path and post it here to help I would appreciate it. Searching via phone is difficult on slow hotel Wi-Fi :slight_smile:

Eno


#19

Hey @Enopho thanks for replying man , I appreciate it. So I have spent another 10 hours or so fudging around, still no luck, I do manage to get rid of the black bar, and the black bar disappears on the headset after fading out (much like ghosting but as the black line goes away), this only happens when defaulting to this weird grey screen with a white pixel dot in t he middle, but sometimes, even when it fails and goes to the gray screen, still the black line.

I need the transition state to succeed, and remove the black line, instead of fail, and remove it. Which is what happens every single time I get the gray screen and the black line fades to disappear. I need to know the difference between the gray screen and the normal screens which have the black line, is the gray screen coming from piplay, computer, or is it a default gray screen of the hmd? AAAAH :smiley:

I’ve tried nearly every single firmware and every single combination of the piplay now, absolutely no joy at all :frowning:

:cry:

I believe when i fixed it last time i might have noticed in a different mode that the line was gone, and I do remember running unity chan on the older versions of piplay, installed them though and seems download server is down, i downloaded the unity chan seperately as well, from mu;ltiple sources but couldnt get it to show on my VR display screen. what mode does the headset have to be in to get this to work? I was unsuccesful in all the different versions in finding unity chan and / or installing it, I think we’re along the right lines though Enopho, thanks man, I do remember doing this before when I was fudging before I fixed it, so hopefully we’ll get there. :frowning:

here is a snap of a version i could download (though not via piplay) but couldnt get to work with the pimax hmd

Any idea of a way I can easily test non steamvr games all the ones listed in the recent piplay are steamvr pretty much, bar one, which i get a fatal error when attempting to run :joy:

Thanks again for all the assist

PS the directories I’m wiping are c:\program files x86\piplay and pimax

MORE ABOUT WHAT IS Happening: when the pimax 4k hmd fails to transition states, it goes black screen or gray screen, SteamVR reports it as headset ready and tracking, and it tracks but then video appears on my own screen and not the HMD. though this is a new problem, i still feel it relates, and also, in older versions if i changed the resolution of the HMD screen (when you could in windows display in earlier versions of piplay) the black line would move, so it’s definitely coming from somewhere but aaaaah

Best wishes,
Adam


#20

I just fully read this post:

http://forum.pimaxvr.com/t/new-piplay-beta-version1-2-57-of-piplay-is-available-for-downloading/1133/672

It looks like the black bars are being caused by 1.2.57. I’ll do some fudging around with that, and hopefully not lose my mind in the meantime :joy:

Thanks again for all the assist, I believe something about version 1.2.57 might put the black bars there, and then maybe running next version removes them, or something similar to this. I’ll try and update more but at this stage I may need a few more directions of things to try :smiley:

Best,
Adam