[Pimax Official] Beta Test Release for Brainwarp 1.0



Well, results may vary my friend, but I am specifically putting myself in areas to force 45FPS - and the game feels smooth, noticeably smoother than it did before. I am getting some hiccups, a stutter here and there so it isn’t perfect but it’s working as intended and presumably it can only improve over time.


On a 2D screen, Elite is quite forgiving of low FPS, especially with FreeSync (or GSync). Recently, I was driving my SRV and I noticed that the framerate dropped into the 30s and yet, it was quite playable. This is with “ultra” settings on a 4K monitor with SS == 2.0 in the in-game settings. In space, I generally get ~65-75 fps.


Did anyone get smoothing to work well in Skyrim? I maxed out steam ss to 4000 * 3330 and get around 60 - 70 fps so smoothing kicks in.

Observed problems when using snap turn and also if I move my head I see smearing in grass and trees.like I am drunk but unfortunately not drinking :beers::crazy_face:


Hmm… sounds like you should start drinking! :laughing:


1 litre vodka = smart smoothing the world
2 litre = full brainwarp



Vive = drinking through a straw



So I haven’t t tested this yet since it looks unstable (it’s a beta after all), still it looks incredibly promising so big applause to @PimaxVR for this release and their great work on the software side, they are rightfully criticized a lot so kudos when they do things right.

What I’m curious is your impressions of the 64hz mode, technically you gain a ton of frames of advantage with this but I’m not reading much of how noticiable the flicker is, any comments?


re: 72 and 64hz modes, all I can say is that they work, too. I tried them both, but only while docked. I looked around my cockpit for the usual signs/performance issues that I, myself, look for. Both modes actually did quite well, in that regard, better than I was expecting but it’s hardly a thorough test. 72hz seemed to glitch a bit more than 64 or 90, but that could have just been a random thing. I don’t think I’d use either mode, myself, as I think 45/90fps is a low enough threshold and Im used to that with my previous headsets.

Im not sure I understand you with the frames but yes, being that you only have to meet a lower threshold (32FPS) you should be able to increase your visual settings and/or super sampling but I haven’t played with doing that - at this stage I’m still tuning everything for 45/90hz. I’ll have to try 64hz later when im out doing some mining and see how it really feels with a lot of objects and movement but it did well while docked*. I think this will be one of those things that will be an individual taste. I’m a FPS/hz person more than I am a SDE person, for example, and I think people will choose 64, 72 and 90 in the same way as they favor those other issues

But as I said - they definitely seem to work and do as expected. I was watching my frames, my system metrics.

*Sitting docked in ED VR is highly demanding.


Flickering in both, 72Hz and 64Hz mode, is very noticeable and therefore they are not usable at the moment. I tried with DCS and IL2. Especially in bright scenes (sky, snowy landscape) the flickering is unbearable.
Smart Smoothing is working ok. But if you play flight sims you will notice stuttering when rolling the aircraft (stick left/right) and you are looking to the sides. Then you will have stuttering and the landscape getting blurry. If you do some dogfighting the problem is very prominent. All modes (90,72,64Hz) suffer from that problem,when Smart Smoothing is on, but it is worse in 72 and 64Hz mode. 90Hz mode is ok, but still has that problem and needs optimisations. In addition to that you will get the same artefacts as with Oculus-ASW, especially when flying prop aircraft and looking through the visor.


R,M - What is you Il2 in flight fps when not using smoothing? Using the Il2 fps counter.

I find that you get flickering and warping myself if my non smoothing fps is above half what the smoothing Hz is set at.

I am going to try it again as we have a new update for Il2 but when I am with clouds PiTool 1 SteamVR 40% Balanced Graphics with high clouds, Shodows 4x AA in game with Nvidia enhancing AA at 8x, anyway with clouds and normal FOV I get no warping but on a sunny day with no clouds I found it was a little crappy at 72Hz so I am going to try 80Hz or go back to Large FOV again.


Which headset did you receive?


I get about 50-60 FPS without Smoothing in IL2.
The flickering doesn´t seem to be related to any frame rates, but just to the lower refresh rate of the screens in 72/36hz and 64/32Hz- modes. If I use the 64Hz mode, I can see the screens flicker even when reaching 64 fps.
On the other side, warping/stuttering of course occurs, when the Smoothing jumps in between half of the refresh rate and until reaching the refresh rate. Having reached the refresh rate of 64Hz with 64fps warping and stuttering stops, of course.


That would be because smoothing is only active if your fps> 1/2 screen refresh rate. If your fps is lower than that then smoothing turns off.

EDIT: Basically, you always have issues with flickering/warping when smoothing is on.



Twenty 202020 20 2020


What are you using to get your FPS count in the headset?


I didn’t notice the flickering becoming too disturbing, when I tried it (my impressions might change when in brighter environments than Elite Dangerous, and/or more tired), but everything got noticeably darker.




Thanks & congrats! :beers::sunglasses::+1::sparkles:

@Dallas.Hao please add to Earlybackers.


Despite being ugly in VR nomatterwhatyoudo, Fallout 4 VR seems to be playing ball with 103 very nicely.
On my 1080Ti With PiTool 1.0 and SS 84-100% and even with AA full (it gets kinda blurry tho) and AF. I get ~50 fps shown in FPS VR, but it feels like 80-90 fps smooth, with smoothing on in PiTool.

This is pretty remarkable!
Edge distortion sometimes seems to be stronger there, looking bluish on the edges of the fov, and sometimes not. But despite that and the “Thumper-Rhythm-game-desync” issue, i’m pretty happy about that beta driver.


@Sallwitz Try my TAA settings here to make the AA sharper. I’ve barely touched the game since that post (waiting for optimizations/nicer headset to play it in, maybe the 5K+ makes it worth trying again), so I’m assuming the instructions are the same: https://www.reddit.com/r/fo4vr/comments/7jxihs/taa_tinker_test_for_fallout_4_vr_get_less_blur