Pimax only working with integrated graphics, not with 1080ti cards


#1

I have had a 4K for a while now but it has sat unused for a good chunk of time when it stopped working. I decided it had spent enough time gathering dust so I had another go trying to get it working only to find it works perfectly fine when I connect the HDMI to the on-board graphics HDMI port. It refuses to connect to PiPlay when I try and connect it to either to the 1080ti cards I have. It used to work great with these 1080ti cards. Nothing has changed with the hardware configuration of my machine since it used to work.

I have tried disabling SLI. The Nvidia drivers and PiMax drivers and firmware have all been updated to the latest versions but no joy.

Does anyone have any idea why my 4K will not work with my Nvidia cards?


#2

By default, integrated graphics is the go to output for non GPU intensive operations. in essence the 4K is another screen… so is not seen as a GPU hungry application so will try to run using Integrated graphics. Problem here is the 4K will not run using integrated graphics so you have a catch 22.

the way you get it to play ball, is to disable the IGPU in the BIOS, then disable it in your device manager. That way your dedicated GPU - in your case the 1080ti will be the only GPU it has on offer and will push the signal that way. This does mean that your device will not be using your IGPU on low GPU applications and will use more power and not be running in power saving mode, but it will get your 4K working :slight_smile:

Good luck

Eno


#3

It’s nice to see knowledgable people helping others here, rather than the usual in-fighting and toxic negativity seen here too frequently.


#4

Many thanks for the suggestion but unfortunately this didn’t work. With the IGPU disabled in the BIOS there was no sign of it in device manager to be able to disable it. With it disabled there was still no joy with plugging it into the GTX cards.


#5

You mentioned sli, do you have two 1080ti? If so, check that the monitor and pimax4k are connected to the same graphics card.


#6

Did you disable it in the device manager and then in the bios… In that order?