Pimax with raspberry pi 3


#1

Hello. I want to use pimax on my projects. But my project computers are raspberry . Its arm and linux.
It have an hdmi port. Almost any hdmi device working with it. But i have 2560 x 1440px topfoison brand lcd module and its not working with raspberry. Manufacturer said " our screen orientation vertical raspberry has no vertical mode. But same brand with 1080p resolution lcd module with vertical orientation looks working with raspberry. I just wonder can pimax 4k work just like plug&play display.
I cant install software or drivers because its arm cpu based linux computer.

Raspberry working with 1080p resolution perfectly. I just want to use with 1080p. Dont need 4k. I just look for a solution :slight_smile: but there is no any answer around.


#2

I am also developing a device for a visually impared person using a Raspberry PI to provide collision information from cameras & sensors. I am unable to get any video onto the Pimax display from the Pi. Works OK directly from my windows PC but not from the Pi. Would it be possible to make this work? Would using the Win10 IoT version on the Raspberry Pi help? I am not completely stuck on Linux, but I would prefer it.
Any help on this would be greatfully received. If I cannot get this working I am back to the drawing board on either another VR headset, or a Windowns SBC that will work.


#3

Hello ruperpowell, i got information from directly pimax. They said it needs driver to work. Without driver pimax cant work. And there is only windows driver.

My experience is rpi 3 is not capable over 1080p resolution. There is people got 1440p resolution but its not stable. Also around 15 - 20hz.

I contacted so much vr headset manufacturer and all they products needs driver ( they said… ). I bought a 1080p display from topfoison. I will put it in a phone based vr gogles. I dont need sensor set. If you need sensor set and you familiar with arduino, you can simply put a 9 dof sensor in that gogles. There is tutorials and sample codes for sensors…


#4

The Raspi 3 works fine ar 1080p 60, so this should be fine for the Pimax as this is basically all it can do. The Pimax works fine from my Win7 PC, however I do not have the drivers installed on that PC so what Pimax have told you is not true. By trying to set custom HDMI modes in config.txt on the Pi I have been able to get the BLUE LED on the PiMax to come on. This apparently means the display is working, however I still have no image. If I can get this working I will let you know how to set-up the Raspi. In the mean-time here is teh EDID info from the Pimax. If you want more info on custom HDMI modes see here: http://elinux.org/RPiconfig

(54-71) Detailed Descriptor #1: Preferred Detailed Timing (1080x1920 @ 60Hz)

		Pixel Clock            : 142.25 MHz
		Horizontal Image Size  : 71 mm
		Vertical Image Size    : 126 mm
		Refresh Mode           : Non-interlaced
		Normal Display, No Stereo

		Horizontal:
			Active Time     : 1080 Pixels
			Blanking Time   : 132 Pixels
			Sync Offset     : 64 Pixels
			Sync Pulse Width: 4 Pixels
			Border          : 0 Pixels
			Frequency       : 117 kHz

		Vertical:
			Active Time     : 1920 Lines
			Blanking Time   : 36 Lines
			Sync Offset     : 16 Lines
			Sync Pulse Width: 4 Lines
			Border          : 0 Lines

		Digital Separate, Horizontal Polarity (+), Vertical Polarity (-)

		Modeline: "1080x1920" 142.250 1080 1144 1148 1212 1920 1936 1940 1956 +hsync -vsync

(72-89) Detailed Descriptor #2: Monitor Name

		Monitor Name: PIMAX P1

(90-107) Detailed Descriptor #3: Monitor Serial Number

		Monitor Serial Number: MSCEM8R6K9DAK

(108-125) Detailed Descriptor #4: Monitor Range Limits

		Horizontal Scan Range: 1kHz-255kHz
		Vertical Scan Range  : 20Hz-120Hz
		Supported Pixel Clock: 290 MHz
		Secondary GTF        : Not Supported

#5

Cracked it! Here is a config which allows you to use the Pimax 4K with your Raspberry Pi 3.

This is the file /boot/config.txt …

hdmi_ignore_cec_init=1
hdmi_drive=1
disable_overscan=1

overscan_left=0
overscan_right=0
overscan_top=0
overscan_bottom=0

hdmi_ignore_edid=0xa5000080
hdmi_group=2
hdmi_mode=87

display_rotate=3

hdmi_timings=1080 1 64 4 64 1920 0 16 4 16 0 0 1 60 0 142240320 3

hdmi_cvt 1080 1920 60

config_hdmi_boost=7

max_framebuffer_width=1080
max_framebuffer_height=1920

gpu_mem=128
arm_freq=900
gpu_freq=275
sdram_freq=500
avoid_pwm_pll=1


#6

Nice work. Could you clarify what software you are using? Thank you.


#7

I am using Raspberry Pi v3 B with Windows 10 IoT. What are you doing to get this to work from here?


#8

Hello…I am currently developing a device to help a visually impaired person to use a Pimax VR headset to see obstacles, detected from cameras and sensors. The VR headset has a slightly odd EDID. Would someone here be able to help suggest the correct settings for config.txt to get an image on the device? Here is the EDID file read using my PC.