Pimax4K setup issues


#1

Hi team,

I’m hoping some of the more experienced users here might be able to give me a hand, I’d primarily like to use the PiMax for movie watching, while our main TV is otherwise occupied with home improvement shows :frowning:

A few issues to work through, I’ve received a PiMax 4K headset with headphones.
I’m running it on an XPS 9560 (i7 7700, 32gb ram, GTX1050 onboard(disabled), Aorus Gaming Box with GTX1070).

I’ve hooked up the Pimax to the GTX1070 (both USB and HDMI), which then connects to the PC via Thunderbolt.
The PC recognises the GTX1070 as an external GPU without issue.

I’ve installed PiPlay, which successfully identifies the headset.
The Pimax logo displays on the screen ona field of stars, and is sort of sharp in the very centre, but gets very blurry around the edges.
I can play a movie trailer from within PiPlay which seems to work fine, except for the blurriness.
I’ve made IPD adjustments, which don’t seem to have any effect on the focus outside the very centre of the screen.

I’ve also installed SteamVR, which finds the headset, I tried using Simple Player VR, however this opens up within its own window on the main PC screen, I see no way to shift it to the Pimax?
If I click the ‘mirror’ option within SteamVR, it opens a second window on my laptop screen showing the black view I have within the headset, but no way to switch the 2 feeds that I can see.

Lastly, using the headset as an extended desktop - I have the default windows logo, my right eye sees only the very right half of the screen, my left eye sees only the very left half of the screen.
With both eyes open, the image is almost like double vision and gets painful after a short time, there doesn’t seem to be enough overlap between the view of each eye to give the correct effect (hopefully this makes sense)

So the issues at present:

  • The view through the lenses is very blurry and the screen seems too ‘close’ (troubleshooting on Gearbest mentioned setting the distance to screen value in PiPlay, but I can’t seem to find this)
  • SteamVR finds the headset, but the images of any appliacations open with the PC montior not the headset
  • The images through each lens on an extended desktop are widely divergent, which makes usability almost impossible. Is there any way to bring them more into line?

I’ve emailed and tried to send a skype message to Pimax, but no response as yet.

Any assistance appreciated, thanks!

@Pimax-Support


#2

Use virtual desktop (not free) or bigscreen (free) in pimax mode to see the desktop in the headset in front of you. You will not find a setting of the distance of the virtual screen in the piplay desktop app because there is no desktop viewing software integrated :slight_smile: .

Then just open your favorite video player like vlc to view your videos. And in virtual desktop you can also switch to 3d mode to view 3d-videos in a proper way.

Have fun!

Edit: sometimes my headset refuses to work properly (often when i start my pc while the pimax-usb is plugged in). Then just un- and replug the usb and your pimax will work. I used to unplug my pimax before i turn my pc off and replug the usb not before i see my windows-desktop. This way the headset works 95% when i start steamVR. Sometimes it helps if i start the ipd-settings app. Btw: the ipd-setting is very importnt to not get eye-strain. But pimax got it completely wrong. I have an ipd of 69.5mm and i used to have the ipd-setting at 50mm (lowest). After my hardware-mod where i achieved another 4mm more in distance between the centers of the lenses i play now with a setting of 57mm. So i can play with almost no eye-strain for hours. It is stil not as perfect as with my vive or my rift, but i got used to it and can play for hours now…


#3

There is also video for Vive free & cmoar has great ratings but has a small cost.


#4

Thank you for that mr.uu

Do you find that the image is sharp edge to edge, and top to bottom?
Could you point me in the direction of the hardware mod to increase the distance between lenses?

My personal IPD (checking in a mirror), seems to be about 68mm.

Have you ever had issues with the video player only being visible on the main screen?


#5

The image is not sharp from top to bottom - in no headset, unfortunately.
There is a relatively small sweetspot in the middle, you have to find it youself. When you adjust that look up or down in the ipd-setting-app and you see the chromatic aberration issue on the white text. Then it is sharp in the middle :slight_smile:
With an ipd of 68mm i suggest you to try the ipd setting at minimun (50mm). You should feel then only a minor stress for the eyes to focus while reading text.
The hardware-mod is in picture in the thread called “removing the shutters” or similar which is a pretty long read (i am to lazy to provide a link for you, but should be easy to find). I did something similar where i did not need to use my dremel too much and i could keep the plastic cover behind the proximity sensor on. Almost imposible to see the mod. The core mod is to have each lens fixed with only one of the three screws at the original place (i think the uppermost one) and turn the lenses outwards and then fix their position in making a new whole with the screws most outward just 2mm beside the old hole. Not a big deal. But this one plastic cover needs to be dremelled because the openings of the lenses are normally precise.
The window on the wrong screen in extenden mode is easily solved with the combination of the windows-key, shift and the right or left cursor (depends on the virtual position of the screen). Also easily to google.

Just read a post from another user with 68mm ipd who said he uses 58mm in piplay to have minimal eye-strain. Here: Pimax 4K and DCS

Frankly spoken i do not know what is the right ipd setting. Nobody seems to know. Even pimax seems to not know - they did not give any feedback so far which is hmm… i have no words for that. You have to find out yourself unfortunately…


#6

Thank you for the good advice.

I’ll try setting the IPD to minimum as well, I settled on 58mm last night, but then was pretty headachey :sweat_smile:

I will have a look for your thread, but will persevere with the settings in the first instance.
Thanks for shifting the screens between monitors, I tried the win+shit+left shortcut but it didn’t work then, I’ll continue to play with that.

Thanks again for the advice and recommendations.


#7

If you can move your mouse over the right end to the 4k use the right cursor key, if you can move the mouse out of the left side use the left cursor.
The window you want to shift must be in focus/active. And pimax 4k must be in video mode.
You can see the virtual position of the 4k also in the display settings.

Or you can manually drag the window over to the pimax and then maximise.

I would use bigscreen. It is free and worth a try. Also the overall performance (latency) will be better in pimax mode. I try to avoid extended mode for that reason.

Good luck!


#8

Hey have they updated bigscreen for non motion controls?


#9

I do not know. Normally I use bigscreen with my Vive but last week I tried to use the Xbox app on my 4k via bigscreen and it worked right away. I did just play for 5min not more. So I did not need to configure anything. SteamVR was running, then I started bigscreen, selected on the left side “show desktop” and put on the 4k…


#10

Cool another option he could do then. Would be to add his favourite nonvr Video player to steam ie Vlc & launch inside steamvr. This will open the player in steamvr theater.

Otherwise the easiest way to add motion controllers would be Razer Hydra. (Less hassles then most options)


#11

Hi folks,

the drama continues.

Here’s a screenshot which I hope shows the issue:

The Pimax is connected to the eGPU GTX1070 and is recognised correctly. When I load a a SteamVR application, it loads into a window like on the left, moving the Pimax, moves the image.
However, what I see in the Pimax is is the image on the right, it’s driving me insane trying to get them to switch over!


#12

so is your pimax in pimax mode or video mode when you launch simplevr? - I am assuming that the version of simplevr you have is not steam version? or is it in your steam library? if its in your steam library… make sure you click on SteamVR 1st, and then launch simplevr from within steam and not from the desktop icon i can see in your screenshot.

Eno


#13

Hi Eno,

I’m in Pimax mode, I launch Simple VR from within the Piplay application. Which you can see behind the 2 display screens.

Within the hmd I see the black field, moving the headset does move the view in the Simple VR window, but it seems to only play on the laptop screen.

I’ll see if launching from SteamVR makes a difference.


#14

I suggest you try Whirligig video player.
It will play just about any file, is free, works every time under SteamVR.
Whirligig free: http://www.whirligig.xyz/new-page-3/

I have been using it successfully for over a year and I wouldn’t use anything else.
Every other program I tried (including the ones mentioned) had issues, but not Whirligig.

Also you should set the IPD to what ever your true IDP is. Mine is 65mm and that is what I set it to and it gave me the bast display.
Earlier versions of Piplay had issues with IPD settings, but the latest few releases have all worked as intended.

Focus is a real issue with Pimax4K.
I wear glasses and I had to make serious mods to the unit to set focus to what I needed.
If you have a clearly focused area in the centre of the display, then that’s about as good as it gets.


#15

Just tried Simple VR Video Player and the File Explorer falls way down beyond reach…

Try the Vive version of Deo VR Video Player:

http://deovr.com/


#16

if you start steamVR, do you see the VR-surrounding in the pimax? Please activate the SteamVR-Home ) the very first in steam-vr-options and you should see the SteamVR-Home VR-Surrounding (half open house) in the 4k.

Maybe there is a problem because you use an external GPU. try to use the built-in GPU and if this works whe know the reason…


#17

GPU: GeForce GTX 1080
CPU: Intel® Core™ i7-6700K CPU @ 4.00GHz
Memory: 16 GB RAM (15.96 GB RAM usable)
Current resolution: 1920 x 1080, 60Hz
Operating system: Microsoft Windows 10 Pro

… And how is the resolution compared to the Vive or Rift?

I have tried the Primax successfully with the Virtual Desktop but every game I tried looks like a slideshow… SteamVR Home , 1.5 Secs lag between moving my head and the HMD reacting…Any ideas?

This unit is going back to Amazon in a couple weeks and less I can find a solution.

Thanks,
Chas


#18

Resolution is noticeable better, especially when compared side by side. But still you see pixels if you look for it. It is a shame that Samsung does not smear out the pixels like the Rift does with some kind of foil.
But it is clearly the best total experience. Screen of the 4K is better if you hold still and look movies or move the head just very slowly.
Honestly I did not connect my 4K for month. The blurring just keeps me away from it. So I can not verify your (Software?) Problem.

Send it back and wait for the 8k if you want to do more than movie watching with it.


#19

Follow-Up Pimax 4K…latest PiPlay.
Win 10 Pro Build 17115.1

The second I launch SteamVR, my Pimax 4K is recognized,…BUT my mouse turns into a hugely lagging pointer, I kill SteamVR and and mouse returns to normal. I launch SteamVR again, mouse goes to SH1T…

While I was able to launch X plane 11.20B1, In NON VR mode, it worked fine. Switched to VRmode, and XplaneVR AND FS2(Bought out of curiosity), both were a slideshow. Control input lagged by Several seconds.

I don’t intend in buying any additional VR sensors/controls, as I have every flight control that I need to fly my X-Plane simulator. The Pimax 4K was strictly for my flight Simming… as was my test WMR HMD… which is no longer functional in the above version of windows insider. It worked fine With Win 10 Pro 1709(Build 16299.64).

A positive Note here…The Pimax 4K resolution is subjectively BETTER, than any VR-HMD I have tried…including the Rift and Lenovo WMR…NOW if I could get my mouse and frame rate up, I would keep Pimax 4K.

Thanks,
Chas


#20

@Enopho might have some ideas as he plays alot of ED. If you use the search functiom there was a fellow running Prepared3d(sp?).

@SweViver may have some ideas on settings/setup.

@Pimax-Support can likely help with your mouse freezing. Another user recently had a mouse freezing issue. If mem serves i think it might have been K-lite codec (think he uninstalled & let pimax reinstall it)

Correction here is the link not fixed yet.