Piplay 3.0.0.85 -> FATAL ERROR


#1

Hi to everyone.
Finally I bought my new vr pimax 4K but I am getting the following error installing 3.0.0.85
OpenSSL: FATAL
OPENSSL_Uplink(00007FFB45DD4000,08): no OPENSSL_Applink
win10
i5-8400
8gb ram
GTX1070
I’ve already sent a message to the support center 3 days ago with no answer and I saw in this forum that this error is not so simple to fix. Is there a solution or have I to ask for a refund?
Thanks in advance.


#2

@Community

Try reinstalling as Admin. This usually fixes that error.


#3

I tried but same error :frowning:


#4

@Enopho might have some ideas. @PM_Sean @Pimax-Support

Check your AV & see if anything might have bern quarantineed.

Alternatively try Pitool download as it can run tge 4k as well.


#5

AV was disabled during installation and there are no files in quarantine.
What do you mean exactly with “Alternatively try Pitool download as it can run tge 4k as well.”? what is tge 4k?
Thanks.


#6

Your headset. Are you not running pimax 4k?

Pitool download is in the banner. It is the new program being used on the 5k & 8k. It can also run the old headset.


#7

I’ve tried three different version of Pitool but nothing.


#8

Same Error? The openssl?

Might need a Teamviewer session with support.

@Pimax-Support @PM_Sean

Try also messaging here.

http://support.pimaxvr.com/


#9

I sent a message on wendsday but no answer yet


#10

Okay. I know they have been pretty busy of late but we will see what we can do to escalate this.

@Enopho is a wizard with Windows and may have some ideas as to what might be causing these issues.


#11

Hi Silver,

You are right that this issue has been seen before. Pimax thought they had fixed this problem on Piplay .84 and a few people have said installing .76 and then updating to the later versions got round it as well…

there has been a thread where renaming a .dll while piplay is closed and then launching it has solved it, but a suspicion is that the library is merely masking other issues. that thread is here: Pimax 8k user since yesterday, totally desperate with "OPEN SSL FATAL ERROR"

But the long and the tall of it, the issue seems to be on a per user basis and most people do not get this problem, so Pimax Support will need to see what is causing it. you can email sean.huang@pimaxvr.com with the exported pimax logs and they will look into it. It is also worth while copying in support@pimaxvr.com (mailto:support@pimaxvr.com) so they have record of it, and you can chase them up if Sean hasn’t picked up the ticket.

On a side note, it might be worth installing an older version of piplay and seeing if that works and then if it does - try an inplace upgrade!

Eno


#12

Hello
Has a solution been found for this error? I am also concerned. Thank you in advance

Configuration
Win 10 pro
I5 6600k
Gtx 1080
16g ddr4
ssd


#13

use the latest piplay for installation.
http://pisetup.pimaxvr.com/PiPlay_Setup_3.0.0.85.exe
if the issue still exist, rename the file ssleay32.dll to _ssleay32.dll, and it will avoid this happen.

it worked for me.
Bye


#14

Umm that will not fix the problem it will mearly add a band aid. And I would expect that if you avoid that particular library other things will fail but might not report a failure


#15

fair enought…what do you suggest to fix the problem?


#16

My reply was about 4 posts up