PiPlay Service Freezing Mouse


#1

Hi Just wanted to Make it aware that i found a Bug to do with the Piplay Software it is only when the Piplay service is running.
Ok so i only noticed this problem around 2 months ago or so and i did not know what was the cause, at first i thought it was Windows 10, so i Google and Googled and tried every possible solution.

What happens is if i rotate the mouse in circles on my desktop the Cursor Freezes Every single Second, i count 1 second then freeze i start to count again freeze, so i noticed that when windows is on its loading screen before i sign in that the Mouse cursor does not Freeze, so i opened Task Manager and i started to disable background processes that were not being used and as soon as i stopped the Piplay Service the Mouse Cursor Freezing Stopped.

So i Started back up Piplay Desktop App Checked for any updates and its fully Up to date as of 15/03/2018, as soon as it started up Piplay Service my Mouse cursor started to Freeze Again.

So i reopened Task manager and Stopped the Piplay Service and again the Micro Mouse Freezing Stops, so i think that because my 4K VR Headset is not plugged into my Computer the Piplay service is Constantly Scanning my USB ports looking for the Headset and this is somehow causing my problem.

Here is a Video of the Problem so Support can see that it is Piplay service causing this

https://youtu.be/0A_f68sXUeo

The Video is best watched on Youtube @ 1080p60 FPS “https://www.youtube.com/watch?v=0A_f68sXUeo

As you can Clearly see in the Video my Mouse starts to Freeze up in 1 second intervals when the piplay service is Running as soon as i stop the Piplay Service the Mouse Freezing goes away.

Please note i have tried 3 Different mice reinstalled Windows 2 times and Reinstall Piplay 5 times and the results are the same it is 100% Piplay Service Causing this problem

@Pimax-Support


Pimax4K setup issues
#2

Interesting, so just to be clear…

Using a USB mouse with latest piplay version and Pimax 4k unplugged during win 10 x64 starting from a cold start?

Can you also tell the community what Nvidia drivers you have and are windows updates current?

I could test this tonight when I get home if you like

Eno


#3

Hi thnx for reply

This has happened over 3 different win 10 installs as i have 3 Drive with Operating systems on 7 Hard drives in the machine in total.

I am Using a Radeon r9 390x AMD video card and just to be clear this happens with default windows drivers for the AMD card or any other version i’ve tried, it does not seem to be GPU driver related, this does not happen when windows first boots to the Password screen the Mouse moves fine the problem arises the second the Piplay Service loads.

I have also tried 3 different USB mice and also a Wireless USB mouse the results are the same.

before i found out what was causing this i tried everything changing mice unplugging stuff i was not using, uninstalling various drivers sound drivers etc, i even messed around with mouse Polling rates, none of which had any effect.

It was by chance i found it today as i rebooted and noticed the mouse micro freeze was back, sometimes when its been booted a while it goes away and stays away, so i used to leave the PC powered on for days/weeks with no problems.

But i had to reboot today and after it powered up i signed in and noticed the Freeze was back, so annoyed i took to googling again with no results, there are lots of threads on Windows 10 Mouse freeze all of which has Shown no results.

The only one thing that causes and stop this Mouse freeze is Stopping the Piplay Service so its as if its Polling like the mouse does constantly checking if the VR headsets powered or plugged to USB.

Its Like this is interrupting the Polling of the USB on the PC itself, why else would it stop the second you disable Piplay.

Nothing else causes it, if i uninstall Piplay completely and reboot the PC the Problem is gone, this does sometimes disappear when the Piplay service is running that’s why i say its a bug with Piplay but when the freezing comes back only sure thing i can do to Stop it is End Task on piplay if i relaunch Piplay the freeze comes back so Obviously its Piplay.

This has Happened over various Software Version of Piplay and is persistent from Version to Version, and through Video Card drivers its Persistent, i don’t think its VIdeo Card related because its clearly affecting the mouse Movement, if i load a 3d game the game does not pause or freeze its fine, but the mouse Freeze is present in any game so for example there’s running water flowing that i’m looking at it does not freeze other graphices in game only the looking movements of the Character micro freeze because its tied to mouse Movement so turning my head to look using a mouse in game makes the looking micro freeze if that makes sense.

This is not in a VR game btw this is just in normal battlefield 1 not even using the Headset at all its not even plugged in when this occurs just the Piplay service running in the Background to Which i now know i have to disable to use my PC in any way with mouse movement being interrupted.

Thanks for your help.


#4

thanks for the detailed answer… i will defiantly be able to test this. So if you have had this issue for a while then it would be on the older 2.x version of piplay - it does not look like you are using the beta piplay 3.0 even though you said you have latest piplay as of 15/3? I may be wrong but i cant see DrPi icon on your desktop - (this comes with Piplay 3.0). Can you try installing piplay 3.0 beta, does the fault appear on that version as well?

I have 3.0 piplay installed on one of my pcs so i will unplug my pimax 4k tonight and boot up to see if its on my pc as well. - i also have a pc with 1.1.92 version of piplay as well, and i can test on that version also… but i dont know what piplay version you are using… it would be good to know?

@Pimax-Support will need to monitor this thread in case you have come across a new bug they are not aware of.

Eno


#5

@Enopho sure,we will monitor this.


#6

Many thanks :slight_smile: appreciate it


#7

#8