Pitool 1.0.1.111 Beta Test Release for Brainwarp 1.0


#204

I have similar issue but with IL 2.
2 Days ago installed Pitool .111, turned on FFR and its works with fps benefits! Today I do not know what happend but any FFR options is not active during game session. Tested all 3 methods. Reinstalled nvidia , rebooted PC , services , reinstaled SteamVR ( also tried beta) nothing works… Any idea ?


#205

According to Kevin in this stream with MRTV, next Pitool is coming out this week.


#206

I menaged to run FFR with IL 2 Sturmovik again. When it’s stuck the procedure is more less in this order:
close SteamVr app -> kill pi_server process -> stop/run pitool services - > luck - > start game again, repeat ! sometimes “reboot HMD” in pitool options helps

Conclusion: FFR is very unstable with il2 , “conservative” ( very ugly) works only 2 minutes and hangs game , “balanced” and “aggressive” hangs my game just after jumping to plane…
@PimaxUSA @PimaxVR @Sean.Huang

Tested with RTX 2080Ti Asus Strix gaming OC , i7 8700k , DDR4 3200 , latest nvidia drivers


#207

Elite D no longer loads for me with this new Pitool. Any suggestions?

Also, any suggestions to stop the auto audio switching when running the headset. I use wireless headphones that use the monitor/TV output.


#208

I think @neal_white_iii might be using latest pitool.


#209

sure, turn off FFR, reboot hmd & services
I had the same issue with Dirt Rally after turning off FFR its working again


#210

Yes, I’m playing Elite Dangerous with PiTool .111, which I think is the latest version. The only issues I’m having appear to be due to a bad cable (sparkles and flashes) and my on-going difficulties getting my headset to track the base station. (It just takes a frustrating move-the-headset-all-over-procedure, until the link is established.)

I’ve turned off smart smoothing and FFR and have the refresh rate set to 72 Hz.


#211

Conclusion: FFR is very unstable with il2 , “conservative” ( very ugly) works only 2 minutes and hangs game , “balanced” and “aggressive” hangs my game just after jumping to plane…
@PimaxUSA @PimaxVR

Tested with RTX 2080Ti Asus Strix gaming OC , i7 8700k , DDR4 3200 , latest nvidia drivers

Yata, I am running foreated rendering on Conservative in Il2 BoS with no issues and it looks nicer than in Balanced or Aggressive. Are you running AntiAliasing in game or Nvidia Control panel?

I have found it is good to not have any AntiAliasing and only run SteamVR settings with a render res target vertical of 3240 but this is for the 8K. Also I have turned off in game Sharpening in the Graphics Settings and have found this reduces artifacts dramatically on the 8K headset.

As for PiTool Smoothing, not bothering with that at the moment. Il2 requires Parallel Projections Compatability enabled and with that - smoothing sucks.


#212

no AA in game and Nvidia control panel but we have different HMD and maybe on 8k this feature is better implemented


#213

Hey guys, Ive just catched up the whole thread. Very interesting and helpful discussions, thanks! As Ive been away for a while, Im catching up with the latest updates and features. This weekend I started testing the PiTool 111 Beta version and Im very impressed by the new features such as Brainwarp and FFR. Im currently testing it on the 5K BE OLED headset, and would like to start with one issue Ive noticed (and I dont think Ive seen anyone mentioning it here):

While using fpsVR overlay, having either BW or FFR enabled, I see transparent overlay being “stuck” to the screens on top of the game image. It can either be the SteamVR dashboard, some times the in-game menus or the fpsVR overlay itself being stuck in one or some times several transparent “layers” on top of each other. This problem does not exists if I disable fpsVR overlay completely. Im about to test the same on the 5K+ as well tonight, but would like to ask if anyone have the same issue with fpsvr running with PiTool 111?

Also:

I noticed in certain areas where Skyrim dropped to 70-72fps (max settings in game plus PiTool 1.25), running on 2080Ti, when I turn on FFR aggressive mode, I get instantly 82fps (which is max for BE OLED). So FFR definitely makes a difference in Skyrim VR.


#214

Welcome back, we have missed you. hope all ok now, now F off and get on with some more videos :smiling_face_with_three_hearts::kissing_heart::heart_eyes::sparkling_heart::kiss:


#216

Glad that you finally back from AWOL :slight_smile: No issue here with fpsVR on 5k+ and Brainwarp on.
Runing SteamVR beta BTW…


#217

No issues here with fpsvr in pitool v1.11. No FFR here though as have 1080ti.

Have you tried it on reg 5k+ or 8k? As this maybe a 5k oled issue.


#218

Interesting… I got the same issue on my 2 windows 10 installs, all apps and drivers updated. Gonna test it on the 5K+ now…

Thanks guys :kissing_heart:


#219

I have not seen this problem.


#220

Welcome back man, look forward to some of your analysis. As for this, yes it’s very noticable in Steam VR Home for example but completely non exisitent in games as far as I can tell. No issues with Skyrim or PCARS 2. Virtual Desktop also looks fine. As does DeoPlayer or SLR app. Only issue I had is with the left screen being low res in Elite Dangerous with FFR on. As mentioned in another thread I am finding FFR helps a little with the blur in one eye issue although I am still testing, it might just be improvements made in 111 rather than the FFR.


#221

Hey Swe! So nice to have you back here. Thx for observations. FPSVR shows the same behaviour for me. But only since i very agressively OCd my MSI Gaming X. Thought its because of that. I’m on .111 too.
Skyrim with FFR sounds very interesting, since depending on ENB and weather mod i try to balance my ultra modded SkyrimVR between 40-45 FPS every small boost sounds very tempting.
cheers

edit: Do you have SteamVR SS on recommended, when using PiTool 1.25?
I use PiTool 1.0 and SteamVR SS manually @
sth X ~2880 and ingame SS off, because then i don’t see any difference in resolution quality on modded textures compared to ingame SS maxed, but have a huge FPS bump.


#222

Butter SMOTH. We missed you welcome Bk.


#223

According to David Heaney there is a stable release at GDC today?


#224

I think he is confused unless a newer than pitool 111 is out. Lol