Pitool 1.0.1.111 Beta Test Release for Brainwarp 1.0


#21

I did a quick test, with SteamVR Home and Project Cars 2.

The FFR effect is visible in SteamVR Home on the trees, there is a circle in the center on the vision where they look normal, outside of that they are more grey. Maybe FFR is not compatible with all kinds of shaders? Normally, it should only make things look more blurry/blocky, not change the color.

I could not see any positive effect on GPU usage, and it double the CPU render time.

In Project Cars 2, I could not see any artifact, and could not see any effect on performance, positive or negative. I suspect it wasn’t active. Actually I could have checked in PiTool, it shows the status of FFR, but I’ve just realized that. EDIT: It wasn’t ON, I checked.

So, not impressed so far. It’s only a beta after all, I’m curious to see if it can be improved.

EDIT:
I’ve also tried IL-2 Sturmovik: Great Battles (aka IL-2 Sturmovik: Battle Of Stalingrad).
Looks promising in the menus: no CPU overhead, Aggressive FFR halves the GPU frame time, and it’s hard to notice the artifacts. I had to offset the HMD horizontally to see the pixelation in the sides.
Sadly, the game crashes once I get in a plane.

With this edit, I can update my first impression to “potentially impressive”. Now I just need to find a game where it works!

EDIT2:
I’ve tried DCS. It works, effect on GPU is slightly positive: it shaves 1-2 ms off the GPU frame time. I’m limited by my CPU (an overclocked 4690K) in this game anyway, and FFR wasn’t going to save me. There the FFR settings seemed to be flipped: Aggressive was only noticeable on the sides. Easiest to notice it is to look at the comms menu. Balanced and Conservative were unusable, too pixelated, too close to the center of vision.

I’m using PiTool quality 1.5, 72Hz, and resolution between 2000 and 3000 lines depending on the game.


#22

Lucky’s tale camera’s height is still bugged.

It works just fine in .91

Edge of nowhere still very blurry


#23

My 5K+ arrives today. What Pitool version should I start with guys?


#24

I’m getting this too on the out side and inside of the lens. Odd thing is it does not happen right away. Seems to take 20-30 mins to start appearing. This is while playing fallout 4 VR on pi tool 109


#25

It really depends of what you want to play.

Oculus support is … SECONDARY to put it simply.

If you gonna play modern games that isn’t from Oculus, just use the latest.


#26

I do have Oculus games I would like to play

Island 359
Arizona Sushine
Lone Echo
In Death
Robo Recall
The Climb
Rush
From Other Suns


#27

Is there a new fimware in 111 if so version please.


#28
  • Island 359 - Never heard of it, gonna check it later
  • Arizona Sunshine have a native SteamVR version, get it
  • Lone Echo is working ok ! Normal FOV and Pitool at 1.0 - Awesome game, one of the best
  • In Death - Have a SteamVR native, played a little and looked awesome
  • Robo Recall - Working OK, VERY heavy game, will have to mess with the settings
  • The Climb and Chronos - Both have DRM hardlocked. So you will need to run Revive in SteamVR INSTEAD of running directly thru Pitool, because of this, they will need PP on (so the FPS tanks), but it is “playable”
  • Rush - Never heard of it
  • From other suns - Never heard of it

No new firmware in this version (at least for the 8k)


#29

Agreed. Version .111 is beta and has issues. .95 is the most stable, imo, but is missing some recently-added features. .109 seems pretty good.


#30

no same firmware file as in pitools 109


#31

Awesome thanks then no new Firmware. Should still be 195. Did you upgrade from 109?


#32

It was 195 in 109 & 193 in 103

Is 195 included with 111?


#33

Been testing this out. Foreated rendering works but Aggressive is that - quite sever instead I banged it down to Balanced and I do see improvement in image and frames over non.

Not using it with the latest Nvidia Drivers but version 418.91
The lastest Nvidia drivers have a large bug in them that locks up single CPU core and thrashes it. I will await a hotfix driver and test that instead.

Not tested Smoothing yet to see if the frame warping is diminished with bright lit scenes. In time.


#34

Strange, mine is .193 :thinking:


#35

I might have numbers mixed it might be 191 then 193. Yeah I do have it mixed. 103 was 191 & 109 193. Lol


#36

also look at


Pitool Official” says
“Pitool 1.0.1.109 FW 191”
but should be
“Pitool 1.0.1.109 FW 193”


#37

Thank you will fix. :beers::sunglasses::+1::sparkles:


#38

For edge of nowhere try small fov, it helps a bit.


#39

For the blue lines on edges issue, simply unplug the USB and power to your Pimax, then plug it back in after a few seconds. That’s it. I also close steam vr before/reopen it after.


#40

Had to kill piservice.exe or one file couldn’t be erased during install of 1.0.1.111