Pitool Beta Test Release for Brainwarp 1.0


I’m running the climb ‘native’ through pitool, no steam/revive.


Go with 109, zero issues for me so far…


-In assetto corsa loose a lot of frames with FFR on.
-In fallout the image is very pixeled and the performance it,s the same


5k+ or 8k? Backer or Pre Order?



Pimax 5k+ and backer


@dallas.hao please add to earlybackers.


Are you sure it’s the nVidia drivers? “Pimax VR Home” has the same issue. You can uncheck it in PiTool, on the Settings / General page.


I had strange Cpu spikes on idle in steamvr home. Switching Nvidia from Optimal to max fixed it.

The bug he mentions was on Nvidia Forums; likely why 419 was released so quickly after 418.


Ah, it sounds like I should update my nVidia version 418.91 drivers. Thanks for the tip!


2 same issues with my Pimax in the same conditions.


Been testing with .109 all day in IL2 trying to get rid of stutters when turning my head… without success.
Updated to .111 and the stutters when turning my head are completely gone. Good job Pimax!


I had a chance to try it in x-plane 11. The smoothness is much better (36fps) with no judder in positional tracking. I still have the blue lines and vanishing rendering on the edge of the lenses. Definitely an improvement over 109 for me. I just wish those two artifacts could be addressed. Maybe it’s a parallel projection issue! I forgot to turn off motion smoothing to check. Will try again tomorrow…


Is there any word on Tracker support in the latest version of PiTool?

Using trackers for e.g. IK is very popular, would be great if those didn’t get intercepted by PiTool. The same goes for controllers really, be they original vive wands or the upcoming knuckles controllers. Having those intercepted by PiTool will always have us running behind the latest fixes by Valve.

I do understand why the HMD needs PiTool on a driver level to support the large FOV, but when using SteamVR as the main interface, everything else must interface directly.

If it’s Oculus support that requires controller interception, this should be branched off into a separate functionality in my opinion, ideally started automatically when PiTool detects the launch of an Oculus game.

What do you think @Dallas.Hao, @xunshu, @PimaxUSA?


Please download fpsvr. Load a scene in fallout. Observe fps, average fps, cpu frame timing (example 7ms) and gpu frame timing. Now exit game, turn ffr in pitool, restart pitool, then restart steamvr. Don’t change any settings and reload that same scene in fallout 4 vr and compare.

Please let us know how it goes.


Fully agree with this, having the Vive trackers and controllers be overridden by the Pimax drivers is currently causing issues including:

  • Vive controllers and trackers are being turned off when left idle for a few minutes regardless of what is set in SteamVR’s power management settings. The HMD also ignores SteamVR power management settings. **
  • Vive controllers do not appear correctly in VRChat during the full body calibration step.
  • Vive trackers are incorrectly represented with a base station model instead of the official tracker model.
  • Vive tracker firmware updates are not offered through SteamVR unless the PiLauncherService has been stopped first.

@Dallas.Hao, @xunshu, @PimaxUSA

** After digging into PiService for answers it is possible to change the inactivity timer used by the Vive controllers and trackers in C:/Users/[username]/AppData/Local/Pimax/runtime/profile.json

    "Pimax P2 8K Formal" : {
    "standby_timeout_min" : 60, // Increases controller/tracker inactivity timer to 60 minutes.
    "enable_screen_saver" : 0 // Prevents the screen backlight from switching off when idle.

PiServiceLauncher should be restarted after editing the config file for any changes to take effect (Start > Run > services.msc > right click PiServiceLauncher > Restart). I hope that these settings can eventually be included in PiTool’s UI for simplicity.

Is Motion compensation working with Pimax ? (ATM not really)

They must have changed it. Trackers were only synced in steamvr & not Pitool when @VoodooDE originally tested them in the Test phase. Controllers & LHes were in Pitool & Trackers setup in SteamVR.


Just played ED for a good few hours. Smoothing makes the lower edges of any image look super pixelated. I turned it off. But stuttering is gone


Can confirm, back in October the trackers worked fine even though the rest of PiTool has definitely improved significantly since.


No, the bug is with 419

I end up with full CPU utilisation and my eGPU case spins up fans to full bore and Thunderbolt fails kicking me back to my laptops screen. So I have to go back to 418 for system stability.


91 if you plan to play Onward, otherwise 109 has brainwarp but seems less stable.