Pitool 1.0.1.111 Beta Test Release for Brainwarp 1.0


#162

PiTool reports 90Hz, but it’s actually at 72Hz, as the SteamVR options panel correctly shows

The bug is present, but is visual


#163

roger that, and thanks


#164

Anyone else notice the blue edge on the right side of the right eye when Brain Warp is on? With it off it is not there.

Also as others have noted Fixed FFR “Balanced” and “Aggressive” settings are swapped. I’ve also found that there isn’t much FPS gain setting it to anything other than “Conservative”. In DCS I’ll get about 5-8 FPS boost on conservative and it doesn’t impact visuals very much since there is already distortion out at the edges. If anything it looks a bit better.


#165

You really make me want to install Beta guys :smiley:


#166

Yes. It often does not start out this way for me but comes 20-30 mins later. Some times its also in the inside part close to the nose


#167

I noticed it across the bottom of both eyes…


#168

Strange results with FFR you guys are getting. For me, on the Pimax 8K Aggressive is that and Balanced is the preferable setting to use. Haven’t tried Low.

Thinking with the 5K+ guys running Il2 - have you tried running a Vertical Render Target Resolution of 2880?

Just wondering how that would go for you with image quality and performance as in my experience with the Pimax 8K on Il2, Vertical Resolutions that are native or doubled seem to perform quite well. That is 2160 or 4320 dialed in via SteamVR and PiTool for the 8K. Not much difference for me performance wise with 4320 (SS 2x of Native) as compared to 3024 (SS 1.4x of native)or above.

Smoothing doesn’t work in Il2 as Il2 requires Parallel Projection Compatibility which messes with Smoothing in PiTool. Better to keep it off in my opinion.


#169

103 I had blue edge left & right side with Smart Smoothing on. 109 seems better. Will install 111 soon.


#170

Yup I am on 111 haven’t tried anything earlier…


#171

Interesting idea, but I am not sure the steam render target works in that fashion. It is only a target and not set in stone as each app can modify the resolution independently, so even if you aim for exactly your headset resolution, there is no guarantee that the app will actually render at that value etc…


#172

I have experienced non compliant resolution rendering but I took it more as a failing of piserver / steamVR than anything else. Exiting out of the VR app and restarting as required to get the res I dialed in.

Using VR apps through Steam - I would assume the VR target resolution is set by SteamVR and not in app. This applies also to Assetto Corsa as well as Il2. Not sure about other apps like Elite Dangerous as I have not used them. Virtual Desktop has a SS option as well as MSAA so it can be tuned further in app but it still takes its base render target from SteamVR.

Sometimes PiTool Smoothing and even Foreated Rendering can cause target render hickups. A matter of fiddling but I hope things become more solidified and also more structured with regards to software and actual hardware capabilities with user settings being logical and consistent down the track with new initiatives in VR.


#173

Yesterday I had the blue edges in Fallout 4 VR on .111, likely the most annoying bug to date because it is an immersion breaker

Strange enough that in Fallout 4 balanced FFR works and is clearly noticeable, but I have a 15 fps drop! (45 fps without FFR, 30 fps with FFR)


#175

I would love to have per game/app setting so I can setup profiles with and without PP, FFR, etc. Of course they would need to be launch out of PiPlay


#176

Problem at present is many options require steamvr restart or hmd reboot. But am sure it’s in the roadmap.


#177

On .109, I notice it while Elite Dangerous is loading (the wire-model of ship is displayed) - on both sides actually, left & right. Once loaded - in game - it is not there anymore.

Other applications I did not notice it at all, but I only have few to try.


#178

I’d recommend .111. It feels more stable compared to .103/.109 and regarding 90Hz, 72Hz and 64Hz modes with smart smoothing. But tbh, i think it all comes down to the stability and performance you’re system or game setup can already provide for the pimax.
If i run SkyrimVR ultra modded with ENB and my system can only provide ~40FPS, 90Hz and 72Hz modes with smart smoothing won’t feel perfect. Neither will the heavy simulators feel nice. Its not a thingamagic, but its a nice piece of software. And if you’re system can pump ~50-60 FPS with youre desired resolution setup, its really nice with the smart smoothing. And i don’t have any issues with the .111


#179

I installed .111 beta, too, yesterday evening with my new 2080 Ti.

At first, I tried the different FFR settings, and from my point of view, CONSERVATIVE is the best option. Both, BALANCED as well as AGGRESSIVE are to invasive for my taste, so you notice that drop in resolution and the blur much too easily, at least with FOV NORMAL; it is a bit better with LARGE, but still noticeable. CONSERVATIVE does exactly what I expected FFR to do: It blurs the outer edges and gives a significant boost to fps…

… at least yesterday evening…

I was playing American Truck Simulator with FFR OFF and CONSERVATIVE yesterday evening and this morning, and while it worked well yesterday, it didn’t at all this morning:

Overall settings:
PiTool 1.0.1.111 beta
Lighthouse Tracking ON
Brightness HIGH
Brainwarp OFF
FOV NORMAL
PiTool 1.0
SteamVR-SS 150%

Yesterday:
FFR OFF: Avg. FPS: 67.1
FFR CONSERVATIVE: Avg. FPS: 84.8 = +30% !!

Today:
FFR CONSERVATIVE: Avg. FPS: 63.4 = appr. the same than with FFR OFF yesterday
=> Seems as if FFR setting didn’t work properly although it was on and I was able to notice it in-game on the outer edges.

… ?!?

Related fpsVR-Screenshots:

FFR OFF:

FFR CONSERVATIVE yesterday:

FFR CONSERVATIVE this morning:

So, if it works, FFR really is a huge improvement. But apparently, there still are some little bugs, I suppose…

Besides FFR, Brainwarp doesn’t work well with PP: I get blurry areas and images, 3D is drifting into separate, flickering images randomly from time to time. Sometimes, I can play without issues for 5-10 minutes, sometimes, it flickers every 10 seconds… Going into the map of ATS/ETS solves it for a couple of seconds or minutes in most cases, but well… not completely.
So, Brainwarp is buggy, too, but up to now, this doesn’t bother me too much, whereas buggy FFR does - drop of fps by 30% is quite significant and noticeable.


#180

So I just noticed that whenever I had my wired gamepad connected I got a critical problem with SteamVR the moment i turned the wands on, so @PimaxVR @Pimax-Support should check that out.


#181

Has someone already tested FFR with SkyrimVR. Overall impression with different FOV? FPS difference, annoying issues?

I’m very curious as to what can be expected here and appreciate any thoughts and observations.


#182

The pi_server/pi_overlay drivers are a bit buggy. If you are noticing performance drops from what you had previously experienced - then you need to restart everything from PiTools - SteamVR and App that you experienced issues with.

Using Task Manager, one can kill all but PiServiceLauncher.exe and then give it a little while to restart everything. Usually, check that your headset is displaying the Pimax Logo Screen properly before firing up any other software.

I also wish we could control the Headset Power Off Timers - as it is really annoying to have the headset fall asleep when you are mid game and just going out for a min to do something and return to find the Headset is Blank and won’t wake back up. 5 Minutes later after numerous resets of the underlying driver software, one might if lucky be able to resume their VR game but not without some hairloss :laughing: